]> git.pld-linux.org Git - packages/php.git/commitdiff
This commit was manufactured by cvs2git to create tag 'auto-ac-php-5_2_1-6'. auto/ac/php-5_2_1-6
authorcvs2git <feedback@pld-linux.org>
Sun, 18 Mar 2007 15:33:57 +0000 (15:33 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Sprout from master 2007-02-09 08:38:31 UTC Elan Ruusamäe <glen@pld-linux.org> '- update to 5.2.1'
Cherrypick from unlabeled-1.631.2 2007-03-18 15:33:57 UTC Elan Ruusamäe <glen@pld-linux.org> '- rel 6 (curl)':
    php.spec -> 1.631.2.26
Delete:
    php-apr-apu.patch
    php-bug-40073.patch
    php-curl.patch
    php-db4.5.patch
    php-dextension.patch
    php-memory-limit.patch
    php-stupidapache_version.patch
    php-threads-acfix.patch

php-apr-apu.patch [deleted file]
php-bug-40073.patch [deleted file]
php-curl.patch [deleted file]
php-db4.5.patch [deleted file]
php-dextension.patch [deleted file]
php-memory-limit.patch [deleted file]
php-stupidapache_version.patch [deleted file]
php-threads-acfix.patch [deleted file]
php.spec

diff --git a/php-apr-apu.patch b/php-apr-apu.patch
deleted file mode 100644 (file)
index 5a932f2..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
---- php/sapi/apache2filter/config.m4~  2005-09-01 16:33:47.000000000 +0200
-+++ php/sapi/apache2filter/config.m4   2006-08-20 14:38:27.856722182 +0200
-@@ -42,9 +42,9 @@
-   # Pick up ap[ru]-N-config if using httpd >=2.1
-   APR_CONFIG=`$APXS -q APR_CONFIG 2>/dev/null ||
--    echo $APR_BINDIR/apr-config`
-+    echo $APR_BINDIR/apr-1-config`
-   APU_CONFIG=`$APXS -q APU_CONFIG 2>/dev/null ||
--    echo $APU_BINDIR/apu-config`
-+    echo $APU_BINDIR/apu-1-config`
-   APR_CFLAGS="`$APR_CONFIG --cppflags --includes`"
-   APU_CFLAGS="`$APU_CONFIG --includes`"
---- php/sapi/apache2handler/config.m4~ 2006-08-20 14:25:30.607537446 +0200
-+++ php/sapi/apache2handler/config.m4  2006-08-20 14:38:52.423756303 +0200
-@@ -41,9 +41,9 @@
-   # Pick up ap[ru]-N-config if using httpd >=2.1
-   APR_CONFIG=`$APXS -q APR_CONFIG 2>/dev/null ||
--    echo $APR_BINDIR/apr-config`
-+    echo $APR_BINDIR/apr-1-config`
-   APU_CONFIG=`$APXS -q APU_CONFIG 2>/dev/null ||
--    echo $APU_BINDIR/apu-config`
-+    echo $APU_BINDIR/apu-1-config`
-   APR_CFLAGS="`$APR_CONFIG --cppflags --includes`"
-   APU_CFLAGS="`$APU_CONFIG --includes`"
diff --git a/php-bug-40073.patch b/php-bug-40073.patch
deleted file mode 100644 (file)
index 1c35a41..0000000
+++ /dev/null
@@ -1,218 +0,0 @@
---- exif.c     2006/10/10 22:22:43     1.173.2.5.2.4
-+++ exif.c     2007/01/09 17:55:29     1.173.2.5.2.10
-@@ -2,7 +2,7 @@
-    +----------------------------------------------------------------------+
-    | PHP Version 5                                                        |
-    +----------------------------------------------------------------------+
--   | Copyright (c) 1997-2006 The PHP Group                                |
-+   | Copyright (c) 1997-2007 The PHP Group                                |
-    +----------------------------------------------------------------------+
-    | This source file is subject to version 3.01 of the PHP license,      |
-    | that is bundled with this package in the file LICENSE, and is        |
-@@ -17,7 +17,7 @@
-    +----------------------------------------------------------------------+
-  */
--/* $Id$ */
-+/* $Id$ */
- /*  ToDos
-  *
-@@ -139,7 +139,7 @@
- };
- /* }}} */
--#define EXIF_VERSION "1.4 $Id$"
-+#define EXIF_VERSION "1.4 $Id$"
- /* {{{ PHP_MINFO_FUNCTION
-  */
-@@ -1150,6 +1150,80 @@
- }
- /* }}} */
-+#ifdef EXIF_DEBUG
-+char * exif_dump_data(int *dump_free, int format, int components, int length, int motorola_intel, char *value_ptr TSRMLS_DC) /* {{{ */
-+{
-+      char *dump;
-+      int len;
-+
-+      *dump_free = 0;
-+      if (format == TAG_FMT_STRING) {
-+              return value_ptr ? value_ptr : "<no data>";
-+      }
-+      if (format == TAG_FMT_UNDEFINED) {
-+              return "<undefined>\n";
-+      }
-+      if (format == TAG_FMT_IFD) {
-+              return "";
-+      }
-+      if (format == TAG_FMT_SINGLE || format == TAG_FMT_DOUBLE) {
-+              return "<not implemented>";
-+      }
-+      *dump_free = 1;
-+      if (components > 1) {
-+              len = spprintf(&dump, 0, "(%d,%d) {", components, length);
-+      } else {
-+              len = spprintf(&dump, 0, "{");
-+      }
-+      while(components > 0) {
-+              switch(format) {
-+                      case TAG_FMT_BYTE:
-+                      case TAG_FMT_UNDEFINED:
-+                      case TAG_FMT_STRING:
-+                      case TAG_FMT_SBYTE:
-+                              dump = erealloc(dump, len + 4);
-+                              sprintf(dump + len, "0x%02X", *value_ptr);
-+                              len += 4;
-+                              value_ptr++;
-+                              break;
-+                      case TAG_FMT_USHORT:
-+                      case TAG_FMT_SSHORT:
-+                              dump = erealloc(dump, len + 6);
-+                              sprintf(dump + len, "0x%04X", php_ifd_get16s(value_ptr, motorola_intel));
-+                              len += 6;
-+                              value_ptr += 2;
-+                              break;
-+                      case TAG_FMT_ULONG:
-+                      case TAG_FMT_SLONG:
-+                              dump = erealloc(dump, len + 6);
-+                              sprintf(dump + len, "0x%04X", php_ifd_get32s(value_ptr, motorola_intel));
-+                              len += 6;
-+                              value_ptr += 4;
-+                              break;
-+                      case TAG_FMT_URATIONAL:
-+                      case TAG_FMT_SRATIONAL:
-+                              dump = erealloc(dump, len + 13);
-+                              sprintf(dump + len, "0x%04X/0x%04X", php_ifd_get32s(value_ptr, motorola_intel), php_ifd_get32s(value_ptr+4, motorola_intel));
-+                              len += 13;
-+                              value_ptr += 8;
-+                              break;
-+              }
-+              if (components > 0) {
-+                      dump = erealloc(dump, len + 2);
-+                      sprintf(dump + len, ", ");
-+                      len += 2;                       
-+                      components--;
-+              } else{
-+                      break;
-+              }
-+      }
-+      dump = erealloc(dump, len + 2);
-+      sprintf(dump + len, "}");
-+      return dump;
-+}
-+/* }}} */
-+#endif
-+
- /* {{{ exif_convert_any_format
-  * Evaluate number, be it int, rational, or float from directory. */
- static double exif_convert_any_format(void *value, int format, int motorola_intel TSRMLS_DC)
-@@ -1599,6 +1673,7 @@
-       image_info->info_list[section_index].list = list;
-       info_data  = &image_info->info_list[section_index].list[image_info->info_list[section_index].count];
-+      memset(info_data, 0, sizeof(image_info_data));
-       info_data->tag    = tag;
-       info_data->format = format;
-       info_data->length = length;
-@@ -2746,10 +2821,14 @@
-       char *value_ptr, tagname[64], cbuf[32], *outside=NULL;
-       size_t byte_count, offset_val, fpos, fgot;
-       xp_field_type *tmp_xp;
-+#ifdef EXIF_DEBUG
-+      char *dump_data;
-+      int dump_free;
-+#endif /* EXIF_DEBUG */
-       /* Protect against corrupt headers */
-       if (ImageInfo->ifd_nesting_level > MAX_IFD_NESTING_LEVEL) {
--              exif_error_docref("exif_read_data#error_ifd" TSRMLS_CC, ImageInfo, E_WARNING, "corrupt EXIF header: maximum directory nesting level reached");
-+              exif_error_docref("exif_read_data#error_ifd" EXIFERR_CC, ImageInfo, E_WARNING, "corrupt EXIF header: maximum directory nesting level reached");
-               return FALSE;
-       }
-       ImageInfo->ifd_nesting_level++;
-@@ -2834,7 +2913,11 @@
-       ImageInfo->sections_found |= FOUND_ANY_TAG;
- #ifdef EXIF_DEBUG
--      exif_error_docref(NULL EXIFERR_CC, ImageInfo, E_NOTICE, "Process tag(x%04X=%s,@x%04X + x%04X(=%d)): %s%s", tag, exif_get_tagname(tag, tagname, -12, tag_table TSRMLS_CC), offset_val+displacement, byte_count, byte_count, (components>1)&&format!=TAG_FMT_UNDEFINED&&format!=TAG_FMT_STRING?"ARRAY OF ":"", format==TAG_FMT_STRING?(value_ptr?value_ptr:"<no data>"):exif_get_tagformat(format));
-+      dump_data = exif_dump_data(&dump_free, format, components, length, ImageInfo->motorola_intel, value_ptr TSRMLS_CC);
-+      exif_error_docref(NULL EXIFERR_CC, ImageInfo, E_NOTICE, "Process tag(x%04X=%s,@x%04X + x%04X(=%d)): %s%s %s", tag, exif_get_tagname(tag, tagname, -12, tag_table TSRMLS_CC), offset_val+displacement, byte_count, byte_count, (components>1)&&format!=TAG_FMT_UNDEFINED&&format!=TAG_FMT_STRING?"ARRAY OF ":"", exif_get_tagformat(format), dump_data);
-+      if (dump_free) {
-+              efree(dump_data);
-+      }
- #endif
-       if (section_index==SECTION_THUMBNAIL) {
-               if (!ImageInfo->Thumbnail.data) {
-@@ -3023,7 +3106,9 @@
-                                               exif_error_docref("exif_read_data#error_ifd" EXIFERR_CC, ImageInfo, E_WARNING, "Illegal IFD Pointer");
-                                               return FALSE;
-                                       }
--                                      exif_process_IFD_in_JPEG(ImageInfo, Subdir_start, offset_base, IFDlength, displacement, sub_section_index TSRMLS_CC);
-+                                      if (!exif_process_IFD_in_JPEG(ImageInfo, Subdir_start, offset_base, IFDlength, displacement, sub_section_index TSRMLS_CC)) {
-+                                              return FALSE;
-+                                      }
- #ifdef EXIF_DEBUG
-                                       exif_error_docref(NULL EXIFERR_CC, ImageInfo, E_NOTICE, "Subsection %s done", exif_get_sectionname(sub_section_index));
- #endif
-@@ -3590,7 +3675,7 @@
-                                                               exif_error_docref(NULL EXIFERR_CC, ImageInfo, E_NOTICE, "%s THUMBNAIL @0x%04X + 0x%04X", ImageInfo->Thumbnail.data ? "Ignore" : "Read", ImageInfo->Thumbnail.offset, ImageInfo->Thumbnail.size);
- #endif
-                                                               if (!ImageInfo->Thumbnail.data) {
--                                                                      ImageInfo->Thumbnail.data = emalloc(ImageInfo->Thumbnail.size);
-+                                                                      ImageInfo->Thumbnail.data = safe_emalloc(ImageInfo->Thumbnail.size, 1, 0);
-                                                                       php_stream_seek(ImageInfo->infile, ImageInfo->Thumbnail.offset, SEEK_SET);
-                                                                       fgot = php_stream_read(ImageInfo->infile, ImageInfo->Thumbnail.data, ImageInfo->Thumbnail.size);
-                                                                       if (fgot < ImageInfo->Thumbnail.size) {
-@@ -3623,7 +3708,7 @@
-                                       exif_error_docref(NULL EXIFERR_CC, ImageInfo, E_NOTICE, "%s THUMBNAIL @0x%04X + 0x%04X", ImageInfo->Thumbnail.data ? "Ignore" : "Read", ImageInfo->Thumbnail.offset, ImageInfo->Thumbnail.size);
- #endif
-                                       if (!ImageInfo->Thumbnail.data && ImageInfo->Thumbnail.offset && ImageInfo->Thumbnail.size && ImageInfo->read_thumbnail) {
--                                              ImageInfo->Thumbnail.data = emalloc(ImageInfo->Thumbnail.size);
-+                                              ImageInfo->Thumbnail.data = safe_emalloc(ImageInfo->Thumbnail.size, 1, 0);
-                                               php_stream_seek(ImageInfo->infile, ImageInfo->Thumbnail.offset, SEEK_SET);
-                                               fgot = php_stream_read(ImageInfo->infile, ImageInfo->Thumbnail.data, ImageInfo->Thumbnail.size);
-                                               if (fgot < ImageInfo->Thumbnail.size) {
-@@ -3914,7 +3999,7 @@
-               exif_iif_add_int(&ImageInfo, SECTION_COMPUTED, "ByteOrderMotorola", ImageInfo.motorola_intel TSRMLS_CC);
-       }
-       if (ImageInfo.FocalLength) {
--              exif_iif_add_fmt(&ImageInfo, SECTION_COMPUTED, "FocalLength" TSRMLS_CC, "%4.1fmm", ImageInfo.FocalLength);
-+              exif_iif_add_fmt(&ImageInfo, SECTION_COMPUTED, "FocalLength" TSRMLS_CC, "%4.1Fmm", ImageInfo.FocalLength);
-               if(ImageInfo.CCDWidth) {
-                       exif_iif_add_fmt(&ImageInfo, SECTION_COMPUTED, "35mmFocalLength" TSRMLS_CC, "%dmm", (int)(ImageInfo.FocalLength/ImageInfo.CCDWidth*35+0.5));
-               }
-@@ -3924,19 +4009,19 @@
-       }
-       if(ImageInfo.ExposureTime>0) {
-               if(ImageInfo.ExposureTime <= 0.5) {
--                      exif_iif_add_fmt(&ImageInfo, SECTION_COMPUTED, "ExposureTime" TSRMLS_CC, "%0.3f s (1/%d)", ImageInfo.ExposureTime, (int)(0.5 + 1/ImageInfo.ExposureTime));
-+                      exif_iif_add_fmt(&ImageInfo, SECTION_COMPUTED, "ExposureTime" TSRMLS_CC, "%0.3F s (1/%d)", ImageInfo.ExposureTime, (int)(0.5 + 1/ImageInfo.ExposureTime));
-               } else {
--                      exif_iif_add_fmt(&ImageInfo, SECTION_COMPUTED, "ExposureTime" TSRMLS_CC, "%0.3f s", ImageInfo.ExposureTime);
-+                      exif_iif_add_fmt(&ImageInfo, SECTION_COMPUTED, "ExposureTime" TSRMLS_CC, "%0.3F s", ImageInfo.ExposureTime);
-               }
-       }
-       if(ImageInfo.ApertureFNumber) {
--              exif_iif_add_fmt(&ImageInfo, SECTION_COMPUTED, "ApertureFNumber" TSRMLS_CC, "f/%.1f", ImageInfo.ApertureFNumber);
-+              exif_iif_add_fmt(&ImageInfo, SECTION_COMPUTED, "ApertureFNumber" TSRMLS_CC, "f/%.1F", ImageInfo.ApertureFNumber);
-       }
-       if(ImageInfo.Distance) {
-               if(ImageInfo.Distance<0) {
-                       exif_iif_add_str(&ImageInfo, SECTION_COMPUTED, "FocusDistance", "Infinite" TSRMLS_CC);
-               } else {
--                      exif_iif_add_fmt(&ImageInfo, SECTION_COMPUTED, "FocusDistance" TSRMLS_CC, "%0.2fm", ImageInfo.Distance);
-+                      exif_iif_add_fmt(&ImageInfo, SECTION_COMPUTED, "FocusDistance" TSRMLS_CC, "%0.2Fm", ImageInfo.Distance);
-               }
-       }
-       if (ImageInfo.UserComment) {
-@@ -4005,7 +4090,7 @@
-    Reads the embedded thumbnail */
- PHP_FUNCTION(exif_thumbnail)
- {
--      zval *p_width, *p_height, *p_imagetype;
-+      zval *p_width = 0, *p_height = 0, *p_imagetype = 0;
-       char *p_name;
-       int p_name_len, ret, arg_c = ZEND_NUM_ARGS();
-       image_info_type ImageInfo;
diff --git a/php-curl.patch b/php-curl.patch
deleted file mode 100644 (file)
index 111741d..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
---- php-5.2.0/ext/curl/interface.c.orig        2006-10-11 01:12:59.000000000 +0200
-+++ php-5.2.0/ext/curl/interface.c     2006-11-21 22:57:41.498291750 +0100
-@@ -369,7 +369,9 @@
-       REGISTER_CURL_CONSTANT(CURLOPT_FTPAPPEND);
-       REGISTER_CURL_CONSTANT(CURLOPT_NETRC);
-       REGISTER_CURL_CONSTANT(CURLOPT_FOLLOWLOCATION);
-+#if CURLOPT_FTPASCII != 0
-       REGISTER_CURL_CONSTANT(CURLOPT_FTPASCII);
-+#endif
-       REGISTER_CURL_CONSTANT(CURLOPT_PUT);
- #if CURLOPT_MUTE != 0
-       REGISTER_CURL_CONSTANT(CURLOPT_MUTE);
-@@ -409,7 +411,9 @@
-       REGISTER_CURL_CONSTANT(CURLOPT_FILETIME);
-       REGISTER_CURL_CONSTANT(CURLOPT_WRITEFUNCTION);
-       REGISTER_CURL_CONSTANT(CURLOPT_READFUNCTION);
-+#if CURLOPT_PASSWDFUNCTION != 0
-       REGISTER_CURL_CONSTANT(CURLOPT_PASSWDFUNCTION);
-+#endif
-       REGISTER_CURL_CONSTANT(CURLOPT_HEADERFUNCTION);
-       REGISTER_CURL_CONSTANT(CURLOPT_MAXREDIRS);
-       REGISTER_CURL_CONSTANT(CURLOPT_MAXCONNECTS);
-@@ -1158,11 +1162,13 @@
-       dupch->handlers->read->fp = ch->handlers->read->fp;
-       dupch->handlers->read->fd = ch->handlers->read->fd;
-+#if CURLOPT_PASSWDDATA != 0
-       if (ch->handlers->passwd) {
-               zval_add_ref(&ch->handlers->passwd);
-               dupch->handlers->passwd = ch->handlers->passwd;
-               curl_easy_setopt(ch->cp, CURLOPT_PASSWDDATA, (void *) dupch);
-       }
-+#endif
-       if (ch->handlers->write->func_name) {
-               zval_add_ref(&ch->handlers->write->func_name);
-               dupch->handlers->write->func_name = ch->handlers->write->func_name;
diff --git a/php-db4.5.patch b/php-db4.5.patch
deleted file mode 100644 (file)
index 455277a..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- php-5.1.2/ext/dba/config.m4.orig   2005-11-29 19:25:58.000000000 +0100
-+++ php-5.1.2/ext/dba/config.m4        2006-02-19 22:52:01.317248250 +0100
-@@ -262,7 +262,7 @@
-         break
-       fi
-     done
--    PHP_DBA_DB_CHECK(4, db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
-+    PHP_DBA_DB_CHECK(4, db-4.5 db-4.4 db-4.3 db-4.2 db-4.1 db-4.0 db-4 db4 db, [(void)db_create((DB**)0, (DB_ENV*)0, 0)])
-   fi
- ])
- AC_DBA_STD_RESULT(db4,Berkeley DB4)
diff --git a/php-dextension.patch b/php-dextension.patch
deleted file mode 100644 (file)
index 97ef3d3..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-backported loading dl extension with -dexetnsion=extension.so from php5.1-200512091130
-
---- php-5.0.5/sapi/cli/php_cli.c       2005-03-22 17:09:20.000000000 +0200
-+++ php5.1-200512091130/sapi/cli/php_cli.c     2005-12-10 01:11:54.000000000 +0200
-@@ -397,7 +397,7 @@
- }
- /* }}} */
--static void define_command_line_ini_entry(char *arg)
-+static void define_command_line_ini_entry(char *arg TSRMLS_DC)
- {
-       char *name, *value;
-@@ -409,7 +409,14 @@
-       } else {
-               value = "1";
-       }
--      zend_alter_ini_entry(name, strlen(name)+1, value, strlen(value), PHP_INI_SYSTEM, PHP_INI_STAGE_ACTIVATE);
-+
-+      if (!strcasecmp(name, "extension")) { /* load function module */
-+              zval extension, zval;
-+              ZVAL_STRING(&extension, value, 0);
-+              php_dl(&extension, MODULE_PERSISTENT, &zval TSRMLS_CC);
-+      } else {
-+              zend_alter_ini_entry(name, strlen(name)+1, value, strlen(value), PHP_INI_SYSTEM, PHP_INI_STAGE_ACTIVATE);
-+      }
- }
-@@ -656,7 +663,7 @@
-                       switch (c) {
-                       case 'd': /* define ini entries on command line */
--                              define_command_line_ini_entry(php_optarg);
-+                              define_command_line_ini_entry(php_optarg TSRMLS_CC);
-                               break;
-                       case 'h': /* help & quit */
diff --git a/php-memory-limit.patch b/php-memory-limit.patch
deleted file mode 100644 (file)
index 8692209..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- php-5.1.4/php.ini~ 2006-06-20 15:47:05.186965387 +0300
-+++ php-5.1.4/php.ini  2006-06-20 15:48:05.188306604 +0300
-@@ -320,7 +320,7 @@
- max_execution_time = 30     ; Maximum execution time of each script, in seconds
- max_input_time = 60   ; Maximum amount of time each script may spend parsing request data
--memory_limit = 16M      ; Maximum amount of memory a script may consume (16MB)
-+memory_limit = 32M      ; Maximum amount of memory a script may consume (32MB)
- ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
diff --git a/php-stupidapache_version.patch b/php-stupidapache_version.patch
deleted file mode 100644 (file)
index e76de12..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
---- ./acinclude.m4~    2005-06-16 21:20:24.000000000 +0300
-+++ ./acinclude.m4     2005-06-16 21:20:34.000000000 +0300
-@@ -1949,8 +1949,14 @@
- dnl This macro is used to get a comparable
- dnl version for apache1/2.
- dnl
-+
- AC_DEFUN([PHP_AP_EXTRACT_VERSION],[
-+if test "$with_apache_version" != "no"; then
-+  ac_output="foo bar baz $with_apache_version"
-+else
-   ac_output=`$1 -v 2>&1`
-+fi
-+
-   ac_IFS=$IFS
- IFS="- /.
- "
diff --git a/php-threads-acfix.patch b/php-threads-acfix.patch
deleted file mode 100644 (file)
index 2245eac..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-diff -burN php-5.0.4RC1.orig/TSRM/threads.m4 php-5.0.4RC1/TSRM/threads.m4
---- php-5.0.4RC1.orig/TSRM/threads.m4  2005-03-15 18:02:27.630294512 +0100
-+++ php-5.0.4RC1/TSRM/threads.m4       2005-03-15 18:07:05.301082136 +0100
-@@ -116,7 +116,6 @@
- else
-   save_CFLAGS=$CFLAGS
-   save_LIBS=$LIBS
--  PTHREADS_ASSIGN_VARS
-   PTHREADS_CHECK_COMPILE
-   LIBS=$save_LIBS
-   CFLAGS=$save_CFLAGS
-@@ -134,9 +133,10 @@
-         break
-       fi
-     done
-+    pthreads_working=
-   fi
--fi
- ])
-+fi
- AC_CACHE_CHECK(for pthreads_lib, ac_cv_pthreads_lib,[
- ac_cv_pthreads_lib=
-@@ -163,6 +163,7 @@
- dnl
- dnl
- AC_DEFUN([PTHREADS_ASSIGN_VARS],[
-+if test "$pthreads_assign_done" != "yes" ; then
- if test -n "$ac_cv_pthreads_lib"; then
-   LIBS="$LIBS -l$ac_cv_pthreads_lib"
- fi
-@@ -170,4 +171,6 @@
- if test -n "$ac_cv_pthreads_cflags"; then
-   CFLAGS="$CFLAGS $ac_cv_pthreads_cflags"
- fi
-+pthreads_assign_done="yes"
-+fi
- ])dnl
index cc508659c0edec798439c819601d0cc1a885c879..2cdee3bd112cc761c6bdc6cc4a1d92b59f9af66a 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -1,4 +1,5 @@
-# TODO:
+# TODO
+# - fix -threads-acfix.patch
 # - deal with modules removed from php and not moved to PECL, still not obsoleted anywhere
 #   - removed from php 5.0 (currently in php4):
 #   db, hyperwave, java, mcal, overload, qtdom
 %undefine      with_mm
 %endif
 
-%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha
-# ppc disabled (broken on th-ppc)
+%ifnarch %{ix86} %{x8664} sparc sparcv9 alpha ppc
 %undefine      with_interbase
 %endif
 
-%if !%{with apache1} && !%{with apache2}
+%if %{without apache1} && %{without apache2}
 ERROR: You need to select at least one Apache SAPI to build shared modules.
 %endif
 
@@ -69,7 +69,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define        _rel 11
+%define        _rel 6
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr):   Le langage de script embarque-HTML PHP
 Summary(pl):   Jêzyk skryptowy PHP
@@ -77,13 +77,13 @@ Summary(pt_BR):     A linguagem de script PHP
 Summary(ru):   PHP ÷ÅÒÓÉÉ 5 - ÑÚÙË ÐÒÅÐÒÏÃÅÓÓÉÒÏ×ÁÎÉÑ HTML-ÆÁÊÌÏ×, ×ÙÐÏÌÎÑÅÍÙÊ ÎÁ ÓÅÒ×ÅÒÅ
 Summary(uk):   PHP ÷ÅÒÓ¦§ 5 - ÍÏ×Á ÐÒÅÐÒÏÃÅÓÕ×ÁÎÎÑ HTML-ÆÁÊ̦×, ×ÉËÏÎÕ×ÁÎÁ ÎÁ ÓÅÒ×ÅÒ¦
 Name:          php
-Version:       5.2.0
+Version:       5.2.1
 Release:       %{_rel}%{?with_hardening:hardened}
 Epoch:         4
 License:       PHP
 Group:         Libraries
 Source0:       http://www.php.net/distributions/%{name}-%{version}.tar.bz2
-# Source0-md5: e6029fafcee029edcfa2ceed7a005333
+# Source0-md5: 261218e3569a777dbd87c16a15f05c8d
 Source2:       zend.gif
 Source3:       %{name}-mod_%{name}.conf
 Source4:       %{name}-cgi-fcgi.ini
@@ -106,9 +106,7 @@ Patch8:             %{name}-no-metaccld.patch
 Patch9:                %{name}-sh.patch
 Patch10:       %{name}-ini.patch
 Patch11:       %{name}-acam.patch
-Patch12:       %{name}-curl.patch
-Patch13:       %{name}-bug-40073.patch
-Patch15:       %{name}-threads-acfix.patch
+#Patch15:      %{name}-threads-acfix.patch
 Patch16:       %{name}-tsrmlsfetchgcc2.patch
 Patch17:       %{name}-no_pear_install.patch
 Patch18:       %{name}-zlib.patch
@@ -124,9 +122,8 @@ Patch32:    %{name}-builddir.patch
 Patch33:       %{name}-zlib-for-getimagesize.patch
 Patch35:       %{name}-versioning.patch
 Patch36:       %{name}-linkflags-clean.patch
-Patch38:       %{name}-memory-limit.patch
+
 Patch39:       %{name}-pear.patch
-Patch40:       %{name}-db4.5.patch
 Patch41:       %{name}-config-dir.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
@@ -164,7 +161,7 @@ BuildRequires:      libwrap-devel
 BuildRequires: libxml2-devel >= 2.5.10
 BuildRequires: libxslt-devel >= 1.1.0
 %{?with_mhash:BuildRequires:   mhash-devel}
-%{?with_ming:BuildRequires:    ming-devel >= 0.2a-11}
+%{?with_ming:BuildRequires:    ming-devel >= 0.3}
 %{?with_mm:BuildRequires:      mm-devel >= 1.3.0}
 BuildRequires: mysql-devel >= 4.0.0
 %{?with_mysqli:BuildRequires:  mysql-devel >= 4.1.0}
@@ -201,6 +198,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                php_sysconfdir          /etc/php
 %define                php_extensiondir        %{_libdir}/php
+%define                _sysconfdir             %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
 %define                php_api_version         20041225
@@ -1125,6 +1123,8 @@ Summary(pl):      Modu
 Group:         Libraries
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Provides:      php(pgsql)
+Provides:      php-pecl-PDO_PGSQL
+Obsoletes:     php-pecl-PDO_PGSQL
 
 %description pgsql
 This is a dynamic shared object (DSO) for PHP that will add PostgreSQL
@@ -1310,6 +1310,7 @@ Group:            Libraries
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Provides:      php(sybase)
 Obsoletes:     php-sybase-ct
+Conflicts:     php-sybase-ct
 
 %description sybase
 This is a dynamic shared object (DSO) for PHP that will add Sybase and
@@ -1329,6 +1330,7 @@ Group:            Libraries
 Requires:      %{name}-common = %{epoch}:%{version}-%{release}
 Provides:      php(sybase-ct)
 Obsoletes:     php-sybase
+Conflicts:     php-sybase
 
 %description sybase-ct
 This is a dynamic shared object (DSO) for PHP that will add Sybase and
@@ -1562,11 +1564,7 @@ cp php.ini-dist php.ini
 # for ac2.53b/am1.6b - AC_LANG_CXX has AM_CONDITIONAL, so cannot be invoked
 # conditionally...
 %patch11 -p1
-%patch12 -p1
-cd ext/exif
-%patch13 -p0
-cd ../../
-%patch15 -p1
+#%patch15 -p1 # breaks with ac cache vars, but later -lpthread is missing ...
 %patch16 -p1
 %patch17 -p1
 %patch18 -p1
@@ -1584,12 +1582,10 @@ patch -p1 < %{PATCH30} || exit 1
 %patch31 -p1
 %patch32 -p1
 %patch33 -p1
+
 %{?with_versioning:%patch35 -p1}
-%ifarch %{x8664} alpha
-%patch38 -p1
-%endif
+
 %patch39 -p1
-%patch40 -p1
 %patch41 -p1
 
 # conflict seems to be resolved by recode patches
@@ -1800,7 +1796,7 @@ done
 %{__make} build-modules
 
 %if %{with apache1}
-%{__make} libtool-sapi LIBTOOL_SAPI=sapi/apache/libphp5.la -f Makefile.apxs1
+%{__make} libtool-sapi LIBTOOL_SAPI=sapi/apache/libphp5.la -f Makefile.apxs1 LDFLAGS=-lpthread
 %endif
 
 %if %{with apache2}
@@ -1810,18 +1806,18 @@ done
 # FCGI
 %if %{with fcgi}
 cp -af php_config.h.fcgi main/php_config.h
-%{__make} sapi/cgi/php -f Makefile.fcgi
+%{__make} sapi/cgi/php -f Makefile.fcgi LDFLAGS=-lpthread
 cp -r sapi/cgi sapi/fcgi
 rm -rf sapi/cgi/.libs sapi/cgi/*.lo
 %endif
 
 # CGI
 cp -af php_config.h.cgi main/php_config.h
-%{__make} sapi/cgi/php -f Makefile.cgi
+%{__make} sapi/cgi/php -f Makefile.cgi LDFLAGS=-lpthread
 
 # CLI
 cp -af php_config.h.cli main/php_config.h
-%{__make} sapi/cli/php -f Makefile.cli
+%{__make} sapi/cli/php -f Makefile.cli LDFLAGS=-lpthread
 
 %install
 rm -rf $RPM_BUILD_ROOT
This page took 0.115696 seconds and 4 git commands to generate.