]> git.pld-linux.org Git - packages/php.git/commitdiff
- updated to 4.0RC1
authorbonkey <bonkey@bonkey.pl.eu.org>
Sun, 2 Apr 2000 17:05:30 +0000 (17:05 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- problems with pgsql module -- compiled in libphp4.so
- problems with gd module -- compiled in libphp4.so
- probably impossible to compile mysql as a module -- compiled in libphp4.so
- mysql has its own library -- BuildPreq: mysql-devel doesn't need anymore?
- added some `-l pl' translations
- /usr/sbin/apxs -> %{_sbindir}/apxs
- %post unhash 'AddType' in httpd.conf

Changed files:
    php.spec -> 1.19

php.spec

index 239b85a929ed73ece8707b7dadcb03a960b95441..1331e050876f104ab5c4a8c8b920718b4ec823bb 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2,12 +2,12 @@ Summary:      The PHP HTML-embedded scripting language for use with Apache.
 Summary(fr):   Le langage de script embarque-HTML PHP pour Apache.
 Summary(pl):   Jêzyk skryptowy PHP -- u¿ywany wraz z serwerem Apache.
 Name:          php
-Version:       4.0b4pl1
+Version:       4.0RC1
 Release:       1
 Group:         Libraries
 Group(fr):     Librairies
 Group(pl):     Biblioteki
-License:       GPL
+License: The PHP license (see "LICENSE" file included in distribution)
 Source0:       http://www.php.net/distributions/%{name}-%{version}.tar.gz
 Source1:       FAQ.php
 Source2:       php.ini
@@ -17,13 +17,14 @@ Icon:               php4.gif
 URL:           http://www.php.net/
 BuildRequires: apache(EAPI)-devel
 BuildRequires: zlib-devel
-BuildRequires: mysql-devel >= 3.22.30-2
+# BuildRequires:       mysql-devel >= 3.22.30-2
 BuildRequires: kaffe-devel
 BuildRequires: libxml-devel >= 1.0.0
 BuildRequires: postgresql-devel
+BuildRequires: pdflib-devel >= 3.0
 BuildRequires: gd-devel
 Requires:      apache(EAPI) >= 1.3.9
-Prereq:                /usr/sbin/apxs
+Prereq:                %{_sbindir}/apxs
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _pkglibdir      %{_libdir}/apache
@@ -64,50 +65,53 @@ Apache), kt
 dynamicznie stron WWW. Spora czê¶æ sk³adni PHP zapo¿yczona zosta³a
 z jêzyków: C, Java i Perl.
 
-%package mysql
-Summary:       MySQL database module for PHP4
-Summary(pl):   Modu³ bazy danych MySQL dla PHP4
-Group:         Libraries
-Group(fr):     Librairies
-Group(pl):     Biblioteki
-Requires:      %{name} = %{version}
-
-%description mysql
-This is a dynamic shared object (DSO) for Apache that will add MySQL
-database support to PHP4.  If you need back-end support for MySQL,
-you should install this package in addition to the main %{name} package.
-
-%description mysql -l pl
-
-%package pgsql
-Summary:       PostgreSQL database module for PHP4
-Summary(pl):   Modu³ bazy danych PostgreSQL dla PHP4
-Group:         Libraries
-Group(fr):     Librairies
-Group(pl):     Biblioteki
-Requires:      %{name} = %{version}
-
-%description pgsql
-This is a dynamic shared object (DSO) for Apache that will add PostgreSQL
-database support to PHP4.  If you need back-end support for PostgreSQL,
-you should install this package in addition to the main %{name} package.
-
-%description pgsql -l pl
-
-%package gd
-Summary:       GD extension module for PHP4
-Summary:       Modu³ GD dla PHP4
-Group:         Libraries
-Group(fr):     Librairies
-Group(pl):     Biblioteki
-Requires:      %{name} = %{version}
-
-%description gd
-This is a dynamic shared object (DSO) for Apache that will add GD
-support to PHP4. You should install this package in addition to the main
-%{name} package if you want to create and manipulate images with PHP.
-
-%description gd -l pl
+#%package mysql
+#Summary:      MySQL database module for PHP4
+#Summary(pl):  Modu³ bazy danych MySQL dla PHP4
+#Group:                Libraries
+#Group(fr):    Librairies
+#Group(pl):    Biblioteki
+#Requires:     %{name} = %{version}
+#
+#%description mysql
+#This is a dynamic shared object (DSO) for Apache that will add MySQL
+#database support to PHP4.  If you need back-end support for MySQL,
+#you should install this package in addition to the main %{name} package.
+#
+#%description mysql -l pl
+#Modu³ PHP4 umo¿liwiaj±cy dostêp do bazy danych MySQL.
+
+
+#%package pgsql
+#Summary:      PostgreSQL database module for PHP4
+#Summary(pl):  Modu³ bazy danych PostgreSQL dla PHP4
+#Group:                Libraries
+#Group(fr):    Librairies
+#Group(pl):    Biblioteki
+#Requires:     %{name} = %{version}
+#
+#%description pgsql
+#This is a dynamic shared object (DSO) for Apache that will add PostgreSQL
+#database support to PHP4.  If you need back-end support for PostgreSQL,
+#you should install this package in addition to the main %{name} package.
+#
+#%description pgsql -l pl
+#Modu³ PHP4 umo¿liwiaj±cy dostêp do bazy danych PostgreSQL.
+
+#%package gd
+#Summary:      GD extension module for PHP4
+#Summary:      Modu³ GD dla PHP4
+#Group:                Libraries
+#Group(fr):    Librairies
+#Group(pl):    Biblioteki
+#Requires:     %{name} = %{version}
+#
+#%description gd
+#This is a dynamic shared object (DSO) for Apache that will add GD
+#support to PHP4. You should install this package in addition to the main
+#%{name} package if you want to create and manipulate images with PHP.
+#
+#%description gd -l pl
 
 %package java
 Summary:       Java extension module for PHP4
@@ -175,16 +179,17 @@ CFLAGS="$RPM_OPT_FLAGS -DEAPI"; export CFLAGS
        --with-zlib \
        --with-regex=system \
        --with-gettext \
-       --with-mysql=shared \
-       --with-gd=shared \
+       --with-mysql \
+       --with-gd \
        --with-dbase \
        --with-filepro \
        --with-ftp \
        --with-hyperwave \
+       --with-pdflib \
        --with-java \
-       --with-pgsql=shared,/usr
+       --with-pgsql=/usr
 
-#      --with-snmp=shared 
+#      --with-snmp=shared  \
 
 make
 
@@ -208,83 +213,94 @@ strip --strip-unneeded    \
        $RPM_BUILD_ROOT%{_pkglibdir}/*.so \
        $RPM_BUILD_ROOT%{_pkglibdir}/php/*.so
 
-install  %{SOURCE1}    .
-gzip -9nf CODING_STANDARDS CREDITS FAQ* ChangeLog FUNCTION_LIST.txt \
-       MAINTAINERS MODULES_STATUS NEWS TODO*
+install %{SOURCE1} .
+gzip -9nf CODING_STANDARDS CREDITS ChangeLog FUNCTION_LIST.txt \
+      MAINTAINERS MODULES_STATUS NEWS TODO* LICENSE Zend/LICENSE \
+      Zend/ZEND_CHANGES
 
 %post
-/usr/sbin/apxs -e -a -n php4 %{_pkglibdir}/libphp4.so 1>&2
+%{_sbindir}/apxs -e -a -n php4 %{_pkglibdir}/libphp4.so 1>&2
+perl -pi -e 's|^#AddType application/x-httpd-php .php|AddType application/x-httpd-php .php|'
+echo "There were some conflicts with mod_magic module."
+echo "If you ecounter problems with running .php files"
+echo "try turn off it in httpd.conf before using php4."
 if [ -f /var/lock/subsys/httpd ]; then
        /etc/rc.d/init.d/httpd restart 1>&2
 fi
 
+%postun
+perl -pi -e 's|^AddType application/x-httpd-php .php|#AddType application/x-httpd-php .php|'
+if [ -f /var/lock/subsys/httpd ]; then
+      /etc/rc.d/init.d/httpd restart 1>&2
+fi
+
 %preun
 if [ "$1" = "0" ]; then
-       /usr/sbin/apxs -e -A -n php4 %{_pkglibdir}/libphp4.so 1>&2
+       %{_sbindir}/apxs -e -A -n php4 %{_pkglibdir}/libphp4.so 1>&2
        if [ -f /var/lock/subsys/httpd ]; then
                /etc/rc.d/init.d/httpd restart 1>&2
        fi
 fi
 
-%post mysql
-if [ -f %{_sysconfdir}/httpd/php.ini ]; then
-       echo "activating module 'mysql.so' in /etc/httpd/php.ini" 1>&2
-       perl -pi -e 's|^;extension=mysql.so|extension=mysql.so|g' \
-       %{_sysconfdir}/httpd/php.ini
-fi
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
-fi
-
-%postun mysql
-if [ -f %{_sysconfdir}/httpd/php.ini ]; then
-       echo "deactivating module 'mysql.so' in /etc/httpd/php.ini" 1>&2
-       perl -pi -e 's|^extension=mysql.so|;extension=mysql.so|g' \
-       %{_sysconfdir}/httpd/php.ini
-fi
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
-fi
-
-%post pgsql
-if [ -f %{_sysconfdir}/httpd/php.ini ]; then
-       echo "activating module 'pgsql.so' in /etc/httpd/php.ini" 1>&2
-       perl -pi -e 's|^;extension=pgsql.so|extension=pgsql.so|g' \
-       %{_sysconfdir}/httpd/php.ini
-fi
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
-fi
-
-%postun pgsql
-if [ -f %{_sysconfdir}/httpd/php.ini ]; then
-       echo "deactivating module 'pgsql.so' in /etc/httpd/php.ini" 1>&2
-       perl -pi -e 's|^extension=pgsql.so|;extension=pgsql.so|g' \
-       %{_sysconfdir}/httpd/php.ini
-fi
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
-fi
-
-%post gd
-if [ -f %{_sysconfdir}/httpd/php.ini ]; then
-       echo "activating module 'gd.so' in /etc/httpd/php.ini" 1>&2
-       perl -pi -e 's|^;extension=gd.so|extension=gd.so|g' \
-       %{_sysconfdir}/httpd/php.ini
-fi
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
-fi
-
-%postun gd
-if [ -f %{_sysconfdir}/httpd/php.ini ]; then
-       echo "deactivating module 'gd.so' in /etc/httpd/php.ini" 1>&2
-       perl -pi -e 's|^extension=gd.so|;extension=gd.so|g' \
-       %{_sysconfdir}/httpd/php.ini
-fi
-if [ -f /var/lock/subsys/httpd ]; then
-       /etc/rc.d/init.d/httpd restart 1>&2
-fi
+#%post mysql
+#if [ -f %{_sysconfdir}/httpd/php.ini ]; then
+#      echo "activating module 'mysql.so' in /etc/httpd/php.ini" 1>&2
+#      perl -pi -e 's|^;extension=mysql.so|extension=mysql.so|g' \
+#      %{_sysconfdir}/httpd/php.ini
+#fi
+#if [ -f /var/lock/subsys/httpd ]; then
+#      /etc/rc.d/init.d/httpd restart 1>&2
+#fi
+#
+#%postun mysql
+#if [ -f %{_sysconfdir}/httpd/php.ini ]; then
+#      echo "deactivating module 'mysql.so' in /etc/httpd/php.ini" 1>&2
+#      perl -pi -e 's|^extension=mysql.so|;extension=mysql.so|g' \
+#      %{_sysconfdir}/httpd/php.ini
+#fi
+#if [ -f /var/lock/subsys/httpd ]; then
+#      /etc/rc.d/init.d/httpd restart 1>&2
+#fi
+#
+#%post pgsql
+#if [ -f %{_sysconfdir}/httpd/php.ini ]; then
+#      echo "activating module 'pgsql.so' in /etc/httpd/php.ini" 1>&2
+#      perl -pi -e 's|^;extension=pgsql.so|extension=pgsql.so|g' \
+#      %{_sysconfdir}/httpd/php.ini
+#fi
+#if [ -f /var/lock/subsys/httpd ]; then
+#      /etc/rc.d/init.d/httpd restart 1>&2
+#fi
+#
+#%postun pgsql
+#if [ -f %{_sysconfdir}/httpd/php.ini ]; then
+#      echo "deactivating module 'pgsql.so' in /etc/httpd/php.ini" 1>&2
+#      perl -pi -e 's|^extension=pgsql.so|;extension=pgsql.so|g' \
+#      %{_sysconfdir}/httpd/php.ini
+#fi
+#if [ -f /var/lock/subsys/httpd ]; then
+#      /etc/rc.d/init.d/httpd restart 1>&2
+#fi
+#
+#%post gd
+#if [ -f %{_sysconfdir}/httpd/php.ini ]; then
+#      echo "activating module 'gd.so' in /etc/httpd/php.ini" 1>&2
+#      perl -pi -e 's|^;extension=gd.so|extension=gd.so|g' \
+#      %{_sysconfdir}/httpd/php.ini
+#fi
+#if [ -f /var/lock/subsys/httpd ]; then
+#      /etc/rc.d/init.d/httpd restart 1>&2
+#fi
+#
+#%postun gd
+#if [ -f %{_sysconfdir}/httpd/php.ini ]; then
+#      echo "deactivating module 'gd.so' in /etc/httpd/php.ini" 1>&2
+#      perl -pi -e 's|^extension=gd.so|;extension=gd.so|g' \
+#      %{_sysconfdir}/httpd/php.ini
+#fi
+#if [ -f /var/lock/subsys/httpd ]; then
+#      /etc/rc.d/init.d/httpd restart 1>&2
+#fi
 
 %post xml
 if [ -f %{_sysconfdir}/httpd/php.ini ]; then
@@ -331,8 +347,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc {CODING_STANDARDS,CREDITS,FAQ*,ChangeLog,FUNCTION_LIST.txt}.gz
-%doc {MAINTAINERS,MODULES_STATUS,NEWS,TODO*}.gz  
+%doc {CODING_STANDARDS,CREDITS,ChangeLog,FUNCTION_LIST.txt,Zend/ZEND_CHANGES}.gz
+%doc {LICENSE,Zend/LICENSE,MAINTAINERS,MODULES_STATUS,NEWS,TODO*}.gz  
 
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/*
 %dir %{_pkglibdir}/php
@@ -343,17 +359,17 @@ rm -rf $RPM_BUILD_ROOT
 
 %attr(755,root,root) %{_pkglibdir}/libphp4.so
 
-%files mysql
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_pkglibdir}/php/mysql.so
-
-%files pgsql
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_pkglibdir}/php/pgsql.so
-
-%files gd
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_pkglibdir}/php/gd.so
+#%files mysql
+#%defattr(644,root,root,755)
+#%attr(755,root,root) %{_pkglibdir}/php/mysql.so
+#
+#%files pgsql
+#%defattr(644,root,root,755)
+#%attr(755,root,root) %{_pkglibdir}/php/pgsql.so
+#
+#%files gd
+#%defattr(644,root,root,755)
+#%attr(755,root,root) %{_pkglibdir}/php/gd.so
 
 %files xml
 %defattr(644,root,root,755)
This page took 0.066759 seconds and 4 git commands to generate.