]> git.pld-linux.org Git - packages/php.git/commitdiff
fix hash<>phar issues auto/th/php56-5.6.20-2
authorElan Ruusamäe <glen@delfi.ee>
Mon, 23 Nov 2015 11:44:30 +0000 (13:44 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Sat, 23 Apr 2016 22:01:08 +0000 (01:01 +0300)
cherry-picked c5579dea175b65dfb0b2f63361b7161234b3798d

dep-tests.sh
phar-hash-shared.patch
php.spec

index f28ab54a592683196151a83137324a6a51e6b811..9abd19b6cc9149ec56efc99de0a8362fd0684bbe 100755 (executable)
@@ -19,7 +19,7 @@ dep_pdo_dblib="$dep_pdo pdo"
 dep_pdo_mysql="$dep_pdo pdo $with_mysqlnd"
 dep_simplexml="$dep_spl spl"
 dep_imap="pcre"
-dep_phar="$dep_spl spl"
+dep_phar="$dep_spl spl hash"
 dep_sqlite="$dep_pdo pdo"
 dep_fileinfo="pcre"
 dep_wddx='xml'
index 28119af9590f14c69035951e0d7bd4e34975a718..621fe6dd0927d2c5ddeaf85e580edad26177a079 100644 (file)
    if test "$PHP_OPENSSL_SHARED" = "yes"; then
      AC_MSG_RESULT([no (shared openssl)])
    else
+--- php-7.0.0RC7/ext/phar/Makefile.frag~       2015-11-23 11:06:31.000000000 +0200
++++ php-7.0.0RC7/ext/phar/Makefile.frag        2015-11-23 11:15:36.452443959 +0200
+@@ -9,7 +9,7 @@
+               $(top_srcdir)/build/shtool echo -n -- "$(top_builddir)/$(SAPI_CLI_PATH) -n"; \
+               if test "x$(PHP_MODULES)" != "x"; then \
+               $(top_srcdir)/build/shtool echo -n -- " -d extension_dir=$(top_builddir)/modules"; \
+-              for i in pcre spl bz2 zlib phar; do \
++              for i in pcre spl bz2 zlib hash phar; do \
+                       if test -f "$(top_builddir)/modules/$$i.la"; then \
+                               . $(top_builddir)/modules/$$i.la; $(top_srcdir)/build/shtool echo -n -- " -d extension=$$dlname"; \
+                       fi; \
index 482ca8e55162341e617549bb393e78a2b43d7068..b57c75d9cdb550ba1de0871a7133e465241836b0 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -150,7 +150,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     1
+%define                rel     2
 %define                orgname php
 %define                ver_suffix 56
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
This page took 0.047894 seconds and 4 git commands to generate.