]> git.pld-linux.org Git - packages/php.git/commitdiff
- consistent packages/files order
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 28 Oct 2010 07:50:03 +0000 (07:50 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php.spec -> 1.903

php.spec

index 2cc61821812825fc480e274bfdb969e518527d42..bba5ab096a6c2ec47607c2fccd5345afa1a05bec 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -7,7 +7,7 @@
 #   - removed from php 5.1:
 #   cpdf, fam, oracle
 #   - removed from php 5.2:
-#   filepro, hw
+#   filepro, hwapi
 #   - removed from php 5.3:
 #   dbase, mime_magic, ming, ncurses, sybase
 # - make additional headers and checking added by mail patch configurable
@@ -973,43 +973,6 @@ databases support through FreeTDS library.
 Moduł PHP dodający obsługę baz danych MS SQL poprzez bibliotekę
 FreeTDS.
 
-%package mysqlnd
-Summary:       MySQL Native Client Driver for PHP
-Summary(pl.UTF-8):     Sterownik natywnego klienta MySQL dla PHP
-Group:         Libraries
-URL:           http://www.php.net/manual/en/book.mysqlnd.php
-Requires:      %{name}-common = %{epoch}:%{version}-%{release}
-Provides:      php(mysqlnd)
-
-%description mysqlnd
-MySQL Native Driver is a replacement for the MySQL Client Library
-(libmysql).
-
-Because MySQL Native Driver is written as a PHP extension, it is
-tightly coupled to the workings of PHP. This leads to gains in
-efficiency, especially when it comes to memory usage, as the driver
-uses the PHP memory management system. It also supports the PHP memory
-limit. Using MySQL Native Driver leads to comparable or better
-performance than using MySQL Client Library, it always ensures the
-most efficient use of memory. One example of the memory efficiency is
-the fact that when using the MySQL Client Library, each row is stored
-in memory twice, whereas with the MySQL Native Driver each row is only
-stored once in memory.
-
-%description mysqlnd -l pl.UTF-8
-MySQL Native Driver (natywny sterownik MySQL) to zamiennik biblioteki
-klienckiej MySQL (libmysql).
-
-Ponieważ sterownik natywny jest napisany jako rozszerzenie PHP, jest
-ściśle powiązany z pracą PHP. Daje to większą wydajność, zwłaszcza
-jeśli chodzi o wykorzystanie pamięci, jako że sterownik wykorzystuje
-system zarządzania pamięcią PHP; obsługuje także ograniczenie pamięci
-z PHP. Niniejszy sterownik ma wydajność porównywalną lub lepszą niż
-biblioteka kliencka MySQL, a pamięć zawsze wykorzystuje efektywniej.
-Przykładem tego może być fakt, że w przypadku biblioteki klienckiej
-każdy wiersz jest przechowywany w pamięci dwukrotnie, natomiast przy
-tym sterowniku - tylko raz.
-
 %package mysql
 Summary:       MySQL database module for PHP
 Summary(pl.UTF-8):     Moduł bazy danych MySQL dla PHP
@@ -1050,6 +1013,43 @@ Moduł PHP umożliwiający udoskonalony dostęp do bazy danych MySQL.
 Różnicą między nim a modułem mysql jest dostęp do funkcjonalności
 MySQL w wersji 4.1 i nowszych.
 
+%package mysqlnd
+Summary:       MySQL Native Client Driver for PHP
+Summary(pl.UTF-8):     Sterownik natywnego klienta MySQL dla PHP
+Group:         Libraries
+URL:           http://www.php.net/manual/en/book.mysqlnd.php
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+Provides:      php(mysqlnd)
+
+%description mysqlnd
+MySQL Native Driver is a replacement for the MySQL Client Library
+(libmysql).
+
+Because MySQL Native Driver is written as a PHP extension, it is
+tightly coupled to the workings of PHP. This leads to gains in
+efficiency, especially when it comes to memory usage, as the driver
+uses the PHP memory management system. It also supports the PHP memory
+limit. Using MySQL Native Driver leads to comparable or better
+performance than using MySQL Client Library, it always ensures the
+most efficient use of memory. One example of the memory efficiency is
+the fact that when using the MySQL Client Library, each row is stored
+in memory twice, whereas with the MySQL Native Driver each row is only
+stored once in memory.
+
+%description mysqlnd -l pl.UTF-8
+MySQL Native Driver (natywny sterownik MySQL) to zamiennik biblioteki
+klienckiej MySQL (libmysql).
+
+Ponieważ sterownik natywny jest napisany jako rozszerzenie PHP, jest
+ściśle powiązany z pracą PHP. Daje to większą wydajność, zwłaszcza
+jeśli chodzi o wykorzystanie pamięci, jako że sterownik wykorzystuje
+system zarządzania pamięcią PHP; obsługuje także ograniczenie pamięci
+z PHP. Niniejszy sterownik ma wydajność porównywalną lub lepszą niż
+biblioteka kliencka MySQL, a pamięć zawsze wykorzystuje efektywniej.
+Przykładem tego może być fakt, że w przypadku biblioteki klienckiej
+każdy wiersz jest przechowywany w pamięci dwukrotnie, natomiast przy
+tym sterowniku - tylko raz.
+
 %package oci8
 Summary:       Oracle 8+ database module for PHP
 Summary(pl.UTF-8):     Moduł bazy danych Oracle 8+ dla PHP
@@ -2454,9 +2454,9 @@ fi
 %extension_scripts mbstring
 %extension_scripts mcrypt
 %extension_scripts mssql
-%extension_scripts mysqlnd
 %extension_scripts mysql
 %extension_scripts mysqli
+%extension_scripts mysqlnd
 %extension_scripts oci8
 %extension_scripts odbc
 %extension_scripts openssl
@@ -2770,6 +2770,11 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/dom.ini
 %attr(755,root,root) %{php_extensiondir}/dom.so
 
+%files exif
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/exif.ini
+%attr(755,root,root) %{php_extensiondir}/exif.so
+
 %files fileinfo
 %defattr(644,root,root,755)
 %doc README.input_filter
@@ -2784,11 +2789,6 @@ fi
 %attr(755,root,root) %{php_extensiondir}/filter.so
 %endif
 
-%files exif
-%defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/exif.ini
-%attr(755,root,root) %{php_extensiondir}/exif.so
-
 %files ftp
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/ftp.ini
@@ -2867,13 +2867,6 @@ fi
 %attr(755,root,root) %{php_extensiondir}/mssql.so
 %endif
 
-%if %{with mysqlnd}
-%files mysqlnd
-%defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/MySQLND.ini
-%attr(755,root,root) %{php_extensiondir}/mysqlnd.so
-%endif
-
 %files mysql
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/mysql.ini
@@ -2886,6 +2879,13 @@ fi
 %attr(755,root,root) %{php_extensiondir}/mysqli.so
 %endif
 
+%if %{with mysqlnd}
+%files mysqlnd
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/MySQLND.ini
+%attr(755,root,root) %{php_extensiondir}/mysqlnd.so
+%endif
+
 %if %{with oci8}
 %files oci8
 %defattr(644,root,root,755)
@@ -3011,11 +3011,6 @@ fi
 %attr(755,root,root) %{php_extensiondir}/recode.so
 %endif
 
-%files simplexml
-%defattr(644,root,root,755)
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/simplexml.ini
-%attr(755,root,root) %{php_extensiondir}/simplexml.so
-
 %files session
 %defattr(644,root,root,755)
 %doc ext/session/mod_files.sh
@@ -3027,6 +3022,11 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/shmop.ini
 %attr(755,root,root) %{php_extensiondir}/shmop.so
 
+%files simplexml
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/simplexml.ini
+%attr(755,root,root) %{php_extensiondir}/simplexml.so
+
 %if %{with snmp}
 %files snmp
 %defattr(644,root,root,755)
This page took 0.060348 seconds and 4 git commands to generate.