]> git.pld-linux.org Git - packages/php.git/commitdiff
- fix bug 55439 (crypt() returns only the salt for MD5); release 2 auto/th/php-5_3_7-2
authorAdam Gołębiowski <adamg@pld-linux.org>
Mon, 22 Aug 2011 19:05:22 +0000 (19:05 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php-crypt-bugfix-55439.patch -> 1.1
    php.spec -> 1.947

php-crypt-bugfix-55439.patch [new file with mode: 0644]
php.spec

diff --git a/php-crypt-bugfix-55439.patch b/php-crypt-bugfix-55439.patch
new file mode 100644 (file)
index 0000000..83e5fa4
--- /dev/null
@@ -0,0 +1,11 @@
+--- PHP_5_3/ext/standard/php_crypt_r.c 2011/08/19 22:45:43     315217
++++ PHP_5_3/ext/standard/php_crypt_r.c 2011/08/19 22:49:18     315218
+@@ -382,7 +382,7 @@
+       /* Now make the output string */
+       memcpy(passwd, MD5_MAGIC, MD5_MAGIC_LEN);
+       strlcpy(passwd + MD5_MAGIC_LEN, sp, sl + 1);
+-      strlcat(passwd, "$", 1);
++      strcat(passwd, "$");
+       PHP_MD5Final(final, &ctx);
index 1f79c2f042447dbb0cb77ec26424aeb381316639..cace703728ebdc208199ad50564141e014051ddb 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -105,7 +105,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     1
+%define                rel     2
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -189,6 +189,7 @@ Patch61:    %{name}-krb5-ac.patch
 Patch62:       mcrypt-libs.patch
 Patch63:       %{name}-mysql-nowarning.patch
 Patch64:       %{name}-m4.patch
+Patch65:       %{name}-crypt-bugfix-55439.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -1871,6 +1872,7 @@ cp php.ini-production php.ini
 %patch62 -p1
 %patch63 -p1
 %patch64 -p1
+%patch65 -p1
 %{__rm} -r sapi/litespeed
 gzip -dc %{SOURCE15} | tar xf - -C sapi/
 
This page took 0.051489 seconds and 4 git commands to generate.