]> git.pld-linux.org Git - packages/php.git/commitdiff
up to 5.5.0alpha3
authorElan Ruusamäe <glen@delfi.ee>
Sun, 13 Jan 2013 15:57:14 +0000 (17:57 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 13 Jan 2013 15:57:14 +0000 (17:57 +0200)
php-mail.patch
php.spec
suhosin.patch

index 272b2f9f29fb8fb8e0c21b4c4071aa73324e4f0d..5a7919734df34618cccb41b7a4922e7c2b11f78c 100644 (file)
@@ -1,14 +1,5 @@
 --- php-5.2.0/ext/standard/mail.c      2006-12-01 14:20:27.881416250 +0100
 +++ php-5.2.4/ext/standard/mail.c      2007-08-31 19:25:50.777713042 +0300
-@@ -21,6 +21,8 @@
- #include <stdlib.h>
- #include <ctype.h>
- #include <stdio.h>
-+#include <syslog.h>
-+#include <string.h>
- #include "php.h"
- #include "ext/standard/info.h"
 @@ -35,6 +37,8 @@
  #include "php_ini.h"
  #include "safe_mode.h"
@@ -44,8 +35,8 @@
 -              fprintf(sendmail, "To: %s\n", to);
 -              fprintf(sendmail, "Subject: %s\n", subject);
 +              TSRMLS_FETCH();
-+              
-+              if ((to != NULL) && (strlen(to)!=0)) { 
++
++              if ((to != NULL) && (strlen(to)!=0)) {
 +                      fprintf(sendmail, "To: %s\n", to);
 +              }
 +              if ((subject != NULL) && (strlen(subject)!=0)) {
@@ -55,7 +46,7 @@
 +              if (PG(http_globals)[TRACK_VARS_SERVER]) {
 +                      zval **remote_addr, **server_name, **server_port,
 +                              **script_name, **http_user_agent;
-+                      
++
 +                      if (zend_hash_find(PG(http_globals)[TRACK_VARS_SERVER]->value.ht, "REMOTE_ADDR", sizeof("REMOTE_ADDR"), (void **) &remote_addr)==SUCCESS) {
 +                              convert_to_string_ex(remote_addr);
 +                              fprintf(sendmail, "HTTP-Posting-Client: %s\n", Z_STRVAL_PP(remote_addr));
@@ -66,7 +57,7 @@
 +                              if (zend_hash_find(PG(http_globals)[TRACK_VARS_SERVER]->value.ht, "SERVER_PORT", sizeof("SERVER_PORT"), (void **) &server_port)==SUCCESS) {
 +                                      convert_to_string_ex(server_port);
 +                                      fprintf(sendmail, ":%s", Z_STRVAL_PP(server_port));
-+                              }       
++                              }
 +                              if (zend_hash_find(PG(http_globals)[TRACK_VARS_SERVER]->value.ht, "SCRIPT_NAME", sizeof("SCRIPT_NAME"), (void **) &script_name)==SUCCESS) {
 +                                      convert_to_string_ex(script_name);
 +                                      fprintf(sendmail, "%s", Z_STRVAL_PP(script_name));
index 20eff84d08d54bbf7a336aa12d2daf8c4b99d416..c9721ec513e041ce2e98a18e941a600c10d06405 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -127,7 +127,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %define                php_suffix 55
 
 %define                rel     0.3
-%define                subver  alpha2
+%define                subver  alpha3
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -141,7 +141,7 @@ Epoch:              4
 License:       PHP
 Group:         Libraries
 Source0:       http://downloads.php.net/dsp/%{orgname}-%{version}%{subver}.tar.xz
-# Source0-md5: e634cdb6cb0d5069e8a27d93fb2efda0
+# Source0-md5: 8c537fbbf4c7439ceec36297b4deac8c
 Source2:       %{orgname}-mod_%{orgname}.conf
 Source3:       %{orgname}-cgi-fcgi.ini
 Source4:       %{orgname}-apache.ini
index d3bc2143ccebee0bc77fb206c1d3e731749e5982..f13727e091fe2773d1661a916aa490a5e2f730b2 100644 (file)
@@ -5587,17 +5587,17 @@ the following modifications have been made:
                                                        }
 +#if SUHOSIN_PATCH
  #if ZEND_DEBUG
--                                                      php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
-+                                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
+-                                                      php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2013 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
++                                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2013 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
  #else
--                                                      php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
-+                                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
+-                                                      php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2013 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
++                                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s)\nCopyright (c) 1997-2013 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
 +#endif
 +#else
 +  #if ZEND_DEBUG
-+                                                      php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
++                                                      php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2013 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
 +  #else
-+                                                      php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
++                                                      php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2013 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
 +  #endif
  #endif
                                                        php_request_shutdown((void *) 0);
@@ -5609,9 +5609,9 @@ the following modifications have been made:
  
                        case 'v': /* show php version & quit */
 +#if SUHOSIN_PATCH
-+                              php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s) %s\nCopyright (c) 1997-2012 The PHP Group\n%s",
++                              php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s) %s\nCopyright (c) 1997-2013 The PHP Group\n%s",
 +#else
-                               php_printf("PHP %s (%s) (built: %s %s) %s\nCopyright (c) 1997-2012 The PHP Group\n%s",
+                               php_printf("PHP %s (%s) (built: %s %s) %s\nCopyright (c) 1997-2013 The PHP Group\n%s",
 +#endif
                                        PHP_VERSION, cli_sapi_module.name, __DATE__, __TIME__,
  #if ZEND_DEBUG && defined(HAVE_GCOV)
@@ -5624,15 +5624,15 @@ the following modifications have been made:
                                if (php_request_startup(TSRMLS_C) != FAILURE) {
 +#if SUHOSIN_PATCH
 +#if ZEND_DEBUG
-+                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
++                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2013 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
 +#else
-+                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
++                                      php_printf("PHP %s with Suhosin-Patch (%s) (built: %s %s)\nCopyright (c) 1997-2013 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
 +#endif
 +#else
  #if ZEND_DEBUG
-                                       php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
+                                       php_printf("PHP %s (%s) (built: %s %s) (DEBUG)\nCopyright (c) 1997-2013 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
  #else
-                                       php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
+                                       php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2013 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
  #endif
 +#endif
  #ifdef PHP_OUTPUT_NEWAPI
@@ -5645,9 +5645,9 @@ the following modifications have been made:
                                SG(headers_sent) = 1;
                                SG(request_info).no_headers = 1;
 +#if SUHOSIN_PATCH
-+                              php_printf("PHP with Suhosin-Patch %s (%s) (built: %s %s)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
++                              php_printf("PHP with Suhosin-Patch %s (%s) (built: %s %s)\nCopyright (c) 1997-2013 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
 +#else
-                               php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2012 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
+                               php_printf("PHP %s (%s) (built: %s %s)\nCopyright (c) 1997-2013 The PHP Group\n%s", PHP_VERSION, sapi_module.name, __DATE__, __TIME__, get_zend_version());
 +#endif
                                php_output_teardown();
                                exit(1);
This page took 0.06146 seconds and 4 git commands to generate.