]> git.pld-linux.org Git - packages/php.git/commitdiff
- rel 5; fixed icu build auto/th/php70-7.0.33-5
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 19 Oct 2019 19:35:04 +0000 (21:35 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 19 Oct 2019 19:35:04 +0000 (21:35 +0200)
php-icu64.patch
php.spec

index f11af7d1a12f8509f0ee8dd028f73959a3e4ba8c..2f0b549dad52a0bdb1512d36386e5f917f0888d4 100644 (file)
  #endif
  
  #include <unicode/calendar.h>
-+#include <unicode/gregocal.h>
++
 +#include <unicode/datefmt.h>
  
  extern "C" {
  
 +using icu::Locale;
 +using icu::Calendar;
-+using icu::GregorianCalendar;
++
 +using icu::DateFormat;
 +
  int datefmt_process_calendar_arg(zval* calendar_zv,
  U_CFUNC PHP_METHOD(IntlTimeZone, __construct)
  {
        zend_throw_exception( NULL,
+
+--- php-7.0.33/ext/intl/dateformat/dateformat_helpers.cpp~     2018-12-04 18:22:53.000000000 +0100
++++ php-7.0.33/ext/intl/dateformat/dateformat_helpers.cpp      2019-10-19 21:29:32.416045611 +0200
+@@ -28,6 +28,8 @@ extern "C" {
+ #include "../calendar/calendar_class.h"
+ }
++using icu::GregorianCalendar;
++
+ int datefmt_process_calendar_arg(zval* calendar_zv,
+                                                                Locale const& locale,
+                                                                const char *func_name,
index 5da4993b68b8963a37278c6b1b63c5c6c33e8d34..9cdf7b102b431b8a9433ae31a412637e403facbb 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -150,7 +150,7 @@ Summary(ru.UTF-8):  PHP Версии 7 - язык препроцессирова
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
 Version:       7.0.33
-Release:       4
+Release:       5
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
This page took 0.272005 seconds and 4 git commands to generate.