]> git.pld-linux.org Git - packages/php.git/commitdiff
- from DEVEL
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 15 Dec 2005 13:41:19 +0000 (13:41 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php-gd_imagerotate_enable.patch -> 1.3
    php-ini.patch -> 1.16
    php-no_pear_install.patch -> 1.5
    php-nohttpd.patch -> 1.2

php-gd_imagerotate_enable.patch
php-ini.patch
php-no_pear_install.patch
php-nohttpd.patch

index 07871644366412bb9b52693601fa97729ef633fc..2d8aa8ce8d08992dc4e8963e3c3f939274b99504 100644 (file)
@@ -1,5 +1,6 @@
---- ./ext/gd/gd.c.org  2004-08-17 01:08:56.000000000 +0200
-+++ ./ext/gd/gd.c      2004-10-18 14:24:15.797275104 +0200
+diff -urbB php-5.1.0RC1.org/ext/gd/gd.c php-5.1.0RC1/ext/gd/gd.c
+--- php-5.1.0RC1.org/ext/gd/gd.c       2005-08-25 15:26:22.317049000 +0200
++++ php-5.1.0RC1/ext/gd/gd.c   2005-08-25 15:27:37.644598376 +0200
 @@ -209,8 +209,8 @@
        PHP_FE(imagecopyresampled,                                              NULL)
  #endif
@@ -10,7 +11,7 @@
        PHP_FE(imageantialias,                                                  NULL)
  #endif
  
-@@ -416,11 +416,11 @@
+@@ -429,11 +429,11 @@
  #ifdef GD2_FMT_COMPRESSED
        REGISTER_LONG_CONSTANT("IMG_GD2_COMPRESSED", GD2_FMT_COMPRESSED, CONST_CS | CONST_PERSISTENT);
  #endif
@@ -23,7 +24,7 @@
        REGISTER_LONG_CONSTANT("GD_BUNDLED", 1, CONST_CS | CONST_PERSISTENT);
        /* Section Filters */
        REGISTER_LONG_CONSTANT("IMG_FILTER_NEGATE", IMAGE_FILTER_NEGATE, CONST_CS | CONST_PERSISTENT);
-@@ -1191,7 +1191,6 @@
+@@ -1204,7 +1204,6 @@
  /* }}} */
  #endif
  
  /* {{{ proto resource imagerotate(resource src_im, float angle, int bgdcolor)
     Rotate an image using a custom angle */
  PHP_FUNCTION(imagerotate)
-@@ -1221,7 +1220,6 @@
+@@ -1221,7 +1220,7 @@
+       ZEND_FETCH_RESOURCE(im_src, gdImagePtr, &SIM, -1, "Image", le_gd);
+-      im_dst = gdImageRotate(im_src, degrees, color, ignoretransparent);
++      im_dst = gdImageRotate(im_src, degrees, color);
+       if (im_dst != NULL) {
+               ZEND_REGISTER_RESOURCE(return_value, im_dst, le_gd);
+@@ -1230,7 +1229,6 @@
        }
  }
  /* }}} */
@@ -39,8 +49,9 @@
  
  #if HAVE_GD_IMAGESETTILE
  /* {{{ proto bool imagesettile(resource image, resource tile)
---- ./ext/gd/php_gd.h.org      2004-01-08 18:32:08.000000000 +0100
-+++ ./ext/gd/php_gd.h  2004-10-18 14:24:34.372451248 +0200
+diff -urbB php-5.1.0RC1.org/ext/gd/php_gd.h php-5.1.0RC1/ext/gd/php_gd.h
+--- php-5.1.0RC1.org/ext/gd/php_gd.h   2005-08-25 15:26:22.366042000 +0200
++++ php-5.1.0RC1/ext/gd/php_gd.h       2005-08-25 15:27:37.645598224 +0200
 @@ -103,8 +103,8 @@
  PHP_FUNCTION(imagecopyresampled);
  #endif
index 6fed978b71874a21d216a65d4e98524cfb3d964b..e19b45f5539ccdc718a55b4fc466354dfc453f8c 100644 (file)
@@ -1,5 +1,6 @@
---- php-5.0.1.org/php.ini      2004-08-13 13:28:45.800911928 +0200
-+++ php-5.0.1/php.ini  2004-08-13 13:31:28.844125592 +0200
+diff -urbB php-5.1.0.org/php.ini php-5.1.0/php.ini
+--- php-5.1.0.org/php.ini      2005-11-25 02:24:23.408519000 +0100
++++ php-5.1.0/php.ini  2005-11-25 02:26:06.570966750 +0100
 @@ -3,13 +3,18 @@
  ;;;;;;;;;;;
  ; WARNING ;
  
  ;;;;;;;;;;;;;;;;;;;
  ; About php.ini   ;
-@@ -59,10 +64,72 @@
+@@ -59,11 +64,73 @@
  ;;;;;;;;;;;;;;;;;;;
  ; About this file ;
  ;;;;;;;;;;;;;;;;;;;
 -; All the values in the php.ini-dist file correspond to the builtin
 -; defaults (that is, if no php.ini is used, or if you delete these lines,
 -; the builtin defaults will be identical).
--
 +; If you use constants in your value, and these constants belong to a
 +; dynamically loaded extension (either a PHP extension or a Zend extension),
 +; you may only use these constants *after* the line that loads the extension.
-+
-+
 +; Below is the list of settings changed from default as specified in
 +; php.ini-recommended. These settings make PHP more secure and encourage
 +; cleaner coding.
 +;     It's not possible to decide to force a variable to be passed by reference
 +;     when calling a function.  The PHP 4 style to do this is by making the
 +;     function require the relevant argument by reference.
++
  ;;;;;;;;;;;;;;;;;;;;
  ; Language Options ;
+ ;;;;;;;;;;;;;;;;;;;;
 @@ -86,7 +153,7 @@
  asp_tags = Off
  
  
  ; Enforce year 2000 compliance (will cause problems with non-compliant browsers)
  y2k_compliance = On
-@@ -285,14 +352,14 @@
+@@ -289,14 +356,16 @@
  ;
--;   - Show all errors except for notices and coding standards warnings
-+;   - Show all errors
+ ;   - Show all errors except for notices and coding standards warnings
  ;
--error_reporting  =  E_ALL & ~E_NOTICE & ~E_STRICT
-+error_reporting  =  E_ALL
+-error_reporting  =  E_ALL & ~E_NOTICE
++;error_reporting  =  E_ALL & ~E_NOTICE
++
++error_reporting = E_ALL
  
  ; Print out errors (as a part of the output).  For production web sites,
  ; you're strongly encouraged to turn this feature off, and use error logging
  
  ; Even when display_errors is on, errors that occur during PHP's startup
  ; sequence are not displayed.  It's strongly recommended to keep
-@@ -447,7 +514,7 @@
- user_dir =
- ; Directory in which the loadable extensions (modules) reside.
--extension_dir = "./"
-+extension_dir = "/usr/lib/php"
- ; Whether or not to enable the dl() function.  The dl() function does NOT work
- ; properly in multithreaded servers, such as IIS or Zeus, and is automatically
---- php-5.0.4/php.ini~ 2005-06-19 19:19:01.000000000 +0300
-+++ php-5.0.4/php.ini  2005-06-19 19:19:21.000000000 +0300
-@@ -369,7 +369,7 @@
+@@ -306,7 +375,7 @@
  ; Log errors into a log file (server-specific log, stderr, or error_log (below))
  ; As stated above, you're strongly advised to use error logging in place of
  ; error displaying on production web sites.
  
  ; Set maximum length of log_errors. In error_log information about the source is
  ; added. The default is 1024 and 0 allows to not apply any maximum length at all.
+@@ -458,7 +527,7 @@
+ user_dir =
+ ; Directory in which the loadable extensions (modules) reside.
+-extension_dir = "./"
++extension_dir = "/usr/lib/php"
+ ; Whether or not to enable the dl() function.  The dl() function does NOT work
+ ; properly in multithreaded servers, such as IIS or Zeus, and is automatically
index dda57759559cbe65a76d9ac79ad53d534005d7a0..13a8dc552357804db950fdc8022784c5359800ec 100644 (file)
@@ -4,35 +4,8 @@
  CXXFLAGS="$CXXFLAGS $standard_libtool_flag"
  
  all_targets='$(OVERALL_TARGET) $(PHP_MODULES) $(PHP_CLI_TARGET)'
--install_targets="$install_modules $install_pear install-build install-headers install-programs"
+-install_targets="$install_modules install-build install-headers install-programs $install_pear"
 +install_targets="$install_modules install-build install-headers install-programs"
  
  case $PHP_SAPI in
    cgi)
---- ./configure.in~    2005-10-17 19:09:07.000000000 +0300
-+++ ./configure.in     2005-10-17 19:19:18.000000000 +0300
-@@ -937,15 +937,6 @@
-   dnl
-   dnl PEAR dependancies
-   dnl
--  if test "$PHP_PCRE_REGEX" = "no"; then
--    pear_error_msg="$pear_error_msg 
--                    PEAR requires PCRE to be enabled.    Add --with-pcre-regex to the configure line. (or --without-pear)"
--  fi
--  if test "$PHP_XML" = "no"; then
--    pear_error_msg="$pear_error_msg 
--                    PEAR requires XML to be enabled.     Add --enable-xml to the configure line. (or --without-pear)"
--  fi
--
- dnl
- dnl ext/xmlrpc is not really there yet to be a requirement..
- dnl
-@@ -968,8 +959,6 @@
-       *)   PEAR_INSTALLDIR=$libdir/php;;
-     esac
-   fi
--
--  PHP_ADD_MAKEFILE_FRAGMENT($abs_srcdir/pear/Makefile.frag,$abs_srcdir/pear,pear)
- fi
index c4d7a9fee76f7fd26b3d91be916d3e4f6506888f..dcaafc4107d31b868d5a25741b2bdafa912c8b9b 100644 (file)
@@ -1,6 +1,7 @@
---- php-4.3.8/sapi/apache2handler/config.m4.orig       2003-07-16 07:46:46.000000000 +0200
-+++ php-4.3.8/sapi/apache2handler/config.m4    2004-07-30 00:45:48.301382112 +0200
-@@ -52,9 +52,9 @@
+diff -urBb php-5.1.0RC1.org/sapi/apache2handler/config.m4 php-5.1.0RC1/sapi/apache2handler/config.m4
+--- php-5.1.0RC1.org/sapi/apache2handler/config.m4     2005-08-05 10:14:54.000000000 +0200
++++ php-5.1.0RC1/sapi/apache2handler/config.m4 2005-08-25 15:09:38.486655320 +0200
+@@ -58,9 +58,9 @@
  
    # Test that we're trying to configure with apache 2.x
    PHP_AP_EXTRACT_VERSION($APXS_HTTPD)
@@ -9,6 +10,6 @@
      AC_MSG_ERROR([You have enabled Apache 2 support while your server is Apache 1.3.  Please use the appropiate switch --with-apxs (without the 2)])
 -  elif test "$APACHE_VERSION" -lt 2000044; then
 +  elif test "$APACHE_VERSION" -gt 0 -a "$APACHE_VERSION" -lt 2000044; then
-     AC_MSG_ERROR([Please note that Apache version >= 2.0.44 is required.])
+     AC_MSG_ERROR([Please note that Apache version >= 2.0.44 is required])
    fi
  
This page took 0.394919 seconds and 4 git commands to generate.