]> git.pld-linux.org Git - packages/php.git/commitdiff
Rel 5; use crypt() from system auto/th/php74-7.4.33-5
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 13 Mar 2024 21:24:42 +0000 (22:24 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 13 Mar 2024 21:24:42 +0000 (22:24 +0100)
crypt.patch [new file with mode: 0644]
php.spec

diff --git a/crypt.patch b/crypt.patch
new file mode 100644 (file)
index 0000000..7bedc96
--- /dev/null
@@ -0,0 +1,87 @@
+--- php-5.6.40/configure.ac~   2024-03-13 20:25:10.000000000 +0100
++++ php-5.6.40/configure.ac    2024-03-13 20:36:57.496650674 +0100
+@@ -591,7 +591,6 @@ alphasort \
+ asctime_r \
+ chroot \
+ ctime_r \
+-crypt \
+ explicit_memset \
+ flock \
+ fpclass \
+@@ -655,6 +654,11 @@ nanosleep \
+ memmem \
+ )
++AC_SEARCH_LIBS([crypt], [crypt], [
++    LIBS="$LIBS -lcrypt"
++    AC_DEFINE(HAVE_CRYPT, 1, [ ])
++])
++
+ AX_FUNC_WHICH_GETHOSTBYNAME_R
+ dnl Some systems (like OpenSolaris) do not have nanosleep in libc.
+@@ -719,7 +723,7 @@ AC_FUNC_ALLOCA
+ PHP_TIME_R_TYPE
+ PHP_CHECK_IN_ADDR_T
+-AC_CHECK_FUNCS(crypt_r, [ php_crypt_r="1" ], [ php_crypt_r="0" ])
++AC_SEARCH_LIBS(crypt_r, crypt, [ php_crypt_r="1" ], [ php_crypt_r="0" ])
+ if test "x$php_crypt_r" = "x1"; then
+   PHP_CRYPT_R_STYLE
+ fi
+--- php-5.6.40/ext/standard/config.m4~ 2019-01-09 10:54:13.000000000 +0100
++++ php-5.6.40/ext/standard/config.m4  2024-03-13 21:03:19.596650607 +0100
+@@ -69,6 +69,8 @@ AC_CACHE_CHECK(for standard DES crypt, a
+ #include <crypt.h>
+ #endif
++#include <stdlib.h>
++
+ int main() {
+ #if HAVE_CRYPT
+       char *encrypted = crypt("rasmuslerdorf","rl");
+@@ -94,6 +96,8 @@ AC_CACHE_CHECK(for extended DES crypt, a
+ #include <crypt.h>
+ #endif
++#include <stdlib.h>
++
+ int main() {
+ #if HAVE_CRYPT
+       char *encrypted = crypt("rasmuslerdorf","_J9..rasm");
+@@ -119,6 +123,8 @@ AC_TRY_RUN([
+ #include <crypt.h>
+ #endif
++#include <stdlib.h>
++
+ int main() {
+ #if HAVE_CRYPT
+       char salt[15], answer[40];
+@@ -154,6 +160,8 @@ AC_TRY_RUN([
+ #include <crypt.h>
+ #endif
++#include <stdlib.h>
++
+ int main() {
+ #if HAVE_CRYPT
+       char salt[30], answer[70];
+@@ -186,6 +194,8 @@ AC_TRY_RUN([
+ #include <crypt.h>
+ #endif
++#include <stdlib.h>
++
+ int main() {
+ #if HAVE_CRYPT
+       char salt[21], answer[21+86];
+@@ -217,6 +227,8 @@ AC_TRY_RUN([
+ #include <crypt.h>
+ #endif
++#include <stdlib.h>
++
+ int main() {
+ #if HAVE_CRYPT
+       char salt[21], answer[21+43];
index c804e30201a957290425138f1f043ff1507e5dd6..7bf154cfc3e71c80cba5160fee27ebc620d3b294 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -150,7 +150,7 @@ Summary(ru.UTF-8):  PHP Версии 7 - язык препроцессирова
 Summary(uk.UTF-8):     PHP Версії 7 - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
 Version:       7.4.33
-Release:       4
+Release:       5
 Epoch:         4
 # All files licensed under PHP version 3.01, except
 # Zend is licensed under Zend
@@ -179,6 +179,7 @@ Patch7:             %{orgname}-sapi-ini-file.patch
 Patch9:                libtool-tag.patch
 Patch10:       %{orgname}-ini.patch
 Patch11:       embed.patch
+Patch12:       crypt.patch
 Patch14:       %{orgname}-no_pear_install.patch
 Patch17:       %{orgname}-readline.patch
 Patch18:       %{orgname}-nohttpd.patch
@@ -1894,6 +1895,9 @@ cp -p php.ini-production php.ini
 %patch7 -p1
 %patch9 -p1
 %patch10 -p1
+
+%patch12 -p1
+
 %patch14 -p1
 %patch17 -p1
 %patch18 -p1
This page took 1.303631 seconds and 4 git commands to generate.