]> git.pld-linux.org Git - packages/php.git/commitdiff
- proper dom configure option - now shared dom module is built
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 26 Dec 2004 15:26:42 +0000 (15:26 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php.spec -> 1.397

php.spec

index fdb2198bc2b5f9a7bb03e28f8a3bcab35b9b234d..fe8249e7403ad2b65f2933993cc45fc55aa5f905 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -510,6 +510,20 @@ file I/O support.
 %description dio -l pl
 Modu³ PHP dodaj±cy obs³ugê bezpo¶rednich operacji I/O na plikach.
 
+%package dom
+Summary:       DOM extension module for PHP
+Summary(pl):   Modu³ DOM dla PHP
+Group:         Libraries
+Requires(post,preun):  %{name}-common = %{epoch}:%{version}-%{release}
+Requires:      %{name}-common = %{epoch}:%{version}-%{release}
+
+%description dom
+This is a dynamic shared object (DSO) for PHP that will add new DOM
+support.
+
+%description dom -l pl
+Modu³ PHP dodaj±cy now± obs³ugê DOM.
+
 %package exif
 Summary:       exif extension module for PHP
 Summary(pl):   Modu³ exif dla PHP
@@ -1419,6 +1433,7 @@ for i in fcgi cgi cli apxs ; do
        --enable-dba=shared \
        --enable-dbx=shared \
        --enable-dio=shared \
+       --enable-dom=shared \
        --enable-exif=shared \
        --enable-filepro=shared \
        --enable-ftp=shared \
@@ -1448,7 +1463,6 @@ for i in fcgi cgi cli apxs ; do
        %{!?with_curl:--without-curl}%{?with_curl:--with-curl=shared} \
        %{?with_db3:--with-db3}%{!?with_db3:--with-db4} \
        --with-dbase=shared \
-       --with-dom=shared \
 %if %{with wddx} || %{with xmlrpc}
        --with-expat-dir=shared,/usr \
 %else
@@ -1688,6 +1702,14 @@ if [ "$1" = "0" ]; then
        %{_sbindir}/php-module-install remove dio %{_sysconfdir}/php.ini
 fi
 
+%post dom
+%{_sbindir}/php-module-install install dom %{_sysconfdir}/php.ini
+
+%preun dom
+if [ "$1" = "0" ]; then
+       %{_sbindir}/php-module-install remove dom %{_sysconfdir}/php.ini
+fi
+
 %post exif
 %{_sbindir}/php-module-install install exif %{_sysconfdir}/php.ini
 
@@ -2213,6 +2235,10 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{extensionsdir}/dio.so
 
+%files dom
+%defattr(644,root,root,755)
+%attr(755,root,root) %{extensionsdir}/dom.so
+
 %if %{with fam}
 %files fam
 %defattr(644,root,root,755)
This page took 0.053691 seconds and 4 git commands to generate.