]> git.pld-linux.org Git - packages/php.git/commitdiff
test fixes
authorElan Ruusamäe <glen@delfi.ee>
Tue, 17 Nov 2015 22:04:20 +0000 (00:04 +0200)
committerElan Ruusamäe <glen@delfi.ee>
Wed, 21 Dec 2016 19:23:25 +0000 (21:23 +0200)
php.spec
skip-tests.sh

index fdd7b5402fff7cae64635a173679fad9bf7d1c2c..6374c330ee8f3694e04c7d0b20156357d1463dde 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -2198,13 +2198,31 @@ sed -i -e 's#-fvisibility=hidden##g' configure*
 %{__rm} -r ext/sqlite3/tests
 %endif
 
+# ----- Manage known as failed test -------
+# affected by systzdata patch
+%{__rm} ext/date/tests/timezone_location_get.phpt
+%{__rm} ext/date/tests/timezone_version_get.phpt
+%{__rm} ext/date/tests/timezone_version_get_basic1.phpt
+# Should be skipped but fails sometime
+%{__rm} ext/standard/tests/file/file_get_contents_error001.phpt
+# fails sometimes
+%{__rm} ext/sockets/tests/mcast_ipv?_recv.phpt
+# causes stack exhausion
+%{__rm} Zend/tests/bug54268.phpt
+%{__rm} Zend/tests/bug68412.phpt
+
+# avoid issues when two builds run simultaneously
+%ifarch %{x8664}
+sed -e 's/64321/64322/' -i ext/openssl/tests/*.phpt
+%endif
+
 # skip XFAILs
 # no point testing stuff that is knowingly broken
-find -name '*.phpt' | xargs grep XFAIL -l | xargs rm -v
+find -name '*.phpt' | xargs grep '^--XFAIL--' -l | xargs rm -v
 
 env \
 %ifarch %{ix86}
-ix86= x8664=:
+ix86= x8664=: \
 %endif
 %ifarch %{x8664}
 ix86=: x8664= \
@@ -2615,6 +2633,7 @@ exit 1
 cat <<'EOF' > run-tests.sh
 #!/bin/sh
 export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
+export SKIP_ONLINE_TESTS=1
 unset TZ LANG LC_ALL || :
 %{__make} test \
        EXTENSION_DIR=modules \
index 8d76b128dcebffd83639f14bc3dbc6edfa5a339c..d128cbb576f707968639a7d8ceb0102d3d1d544c 100644 (file)
@@ -1,6 +1,4 @@
 #!/bin/sh
-# timezone_location_get: Test that timezone_location_get returns a correct array of information
-mv ext/date/tests/timezone_location_get.phpt{,.skip}
 # DBA DB4 magic_quotes_runtime Test (info: DB4 handler used)
 mv ext/dba/tests/dba_db4_010.phpt{,.skip}
 # DBA TCADB handler test
@@ -119,10 +117,6 @@ mv ext/snmp/tests/snmpset.phpt{,.skip}
 mv ext/snmp/tests/snmpwalk.phpt{,.skip}
 # SOAP Server 9: setclass and setpersistence(SOAP_PERSISTENCE_SESSION)
 mv ext/soap/tests/server009.phpt{,.skip}
-# Multicast support: IPv4 receive options
-mv ext/sockets/tests/mcast_ipv4_recv.phpt{,.skip}
-# Multicast support: IPv6 receive options
-mv ext/sockets/tests/mcast_ipv6_recv.phpt{,.skip}
 # socket_import_stream: Test with multicasting
 mv ext/sockets/tests/socket_import_stream-3.phpt{,.skip}
 # Test function getservbyname()
This page took 0.058469 seconds and 4 git commands to generate.