]> git.pld-linux.org Git - packages/php.git/commitdiff
Rel 33; fix openssl 3 build auto/th/php54-5.4.45-33
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 23 Oct 2021 17:33:24 +0000 (19:33 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 23 Oct 2021 17:33:24 +0000 (19:33 +0200)
openssl.patch
php.spec

index d054a1b115d019ec65fd4221a3d177e4631a0514..a3efe506e0a45b492217f8659c0c0989a5b39495 100644 (file)
@@ -1004,3 +1004,15 @@ diff -ur php-5.4.45/ext/openssl.org/openssl.c php-5.4.45/ext/openssl/openssl.c
                        break;
                case STREAM_CRYPTO_METHOD_SSLv2_SERVER:
  #ifdef OPENSSL_NO_SSL2
+--- php-5.3.29/ext/openssl/openssl.c~  2021-10-23 19:18:21.000000000 +0200
++++ php-5.3.29/ext/openssl/openssl.c   2021-10-23 19:19:01.483125024 +0200
+@@ -1044,7 +1044,9 @@ PHP_MINIT_FUNCTION(openssl)
+       REGISTER_LONG_CONSTANT("PKCS7_NOSIGS", PKCS7_NOSIGS, CONST_CS|CONST_PERSISTENT);
+       REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_PADDING", RSA_PKCS1_PADDING, CONST_CS|CONST_PERSISTENT);
++#ifdef RSA_SSLV23_PADDING
+       REGISTER_LONG_CONSTANT("OPENSSL_SSLV23_PADDING", RSA_SSLV23_PADDING, CONST_CS|CONST_PERSISTENT);
++#endif
+       REGISTER_LONG_CONSTANT("OPENSSL_NO_PADDING", RSA_NO_PADDING, CONST_CS|CONST_PERSISTENT);
+       REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_OAEP_PADDING", RSA_PKCS1_OAEP_PADDING, CONST_CS|CONST_PERSISTENT);
index 034267d671518a019ce26459b1594b981fe5d97c..9df326d31044151653dbabea638e3eb188e134bd 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -138,7 +138,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     32
+%define                rel     33
 %define                orgname php
 %define                ver_suffix 54
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
This page took 0.046186 seconds and 4 git commands to generate.