]> git.pld-linux.org Git - packages/php.git/commitdiff
- rel 2 auto/ac/php-5_0_5-2
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 10 Sep 2005 20:15:20 +0000 (20:15 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fix phpize in builddir.patch
- force-cgi-redirect enabled for cgi-like SAPIs
- enable zts mode for all SAPIs
- use php_config.h.fcgi.${sapi} instead of hardcoded CFLAGS
- install SAPI so's using libtool

Changed files:
    php.spec -> 1.471

php.spec

index aa056809bec717d0b331b169e952ac80268f666a..403c24b62609cc62551216e745bd3b586dff051d 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -77,7 +77,7 @@ Summary(ru):  PHP 
 Summary(uk):   PHP ÷ÅÒÓ¦§ 5 - ÍÏ×Á ÐÒÅÐÒÏÃÅÓÕ×ÁÎÎÑ HTML-ÆÁÊ̦×, ×ÉËÏÎÕ×ÁÎÁ ÎÁ ÓÅÒ×ÅÒ¦
 Name:          php
 Version:       5.0.5
-Release:       1%{?with_hardening:hardened}
+Release:       2%{?with_hardening:hardened}
 Epoch:         4
 Group:         Libraries
 License:       PHP
@@ -125,6 +125,7 @@ Patch28:    %{name}-cpdf-fix.patch
 Patch29:       %{name}-gcc4.patch
 Patch30:       %{name}-hardening-fix.patch
 Patch31:       %{name}-both-apxs.patch
+Patch32:       %{name}-builddir.patch
 Icon:          php.gif
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
@@ -1473,15 +1474,11 @@ zcat %{SOURCE9} | patch -p1
 patch -p1 < %{PATCH30}
 %endif
 %patch31 -p1
+%patch32 -p1
 
 # conflict seems to be resolved by recode patches
 rm -f ext/recode/config9.m4
 
-# fix lib path in phpize
-cd scripts/
-sed -i -e 's,lib/php,%{_lib}/php,' phpize.in
-cd ..
-
 # new apr
 sed -i -e 's#apr-config#apr-1-config#g' sapi/apache*/*.m4
 
@@ -1518,13 +1515,13 @@ for sapi in $sapis; do
        `
        case $sapi in
        cgi)
-               echo --enable-discard-path
+               echo --enable-discard-path --enable-force-cgi-redirect
        ;;
        cli)
                echo --disable-cgi
        ;;
        fcgi)
-               echo --enable-fastcgi --with-fastcgi=/usr
+               echo --enable-fastcgi --with-fastcgi=/usr --enable-force-cgi-redirect
        ;;
        apxs1)
                ver=%(rpm -q --qf '%%{version}' apache1-apxs)
@@ -1532,7 +1529,7 @@ for sapi in $sapis; do
        ;;
        apxs2)
                ver=%(rpm -q --qf '%%{version}' apache-apxs)
-               echo --with-apxs2=%{apxs2} --with-apache-version=$ver --enable-maintainer-zts
+               echo --with-apxs2=%{apxs2} --with-apache-version=$ver
        ;;
        esac
        ` \
@@ -1541,6 +1538,7 @@ for sapi in $sapis; do
        --with-config-file-scan-dir=%{_sysconfdir}/conf.d \
        --with-exec-dir=%{_bindir} \
        --%{!?debug:dis}%{?debug:en}able-debug \
+       --enable-maintainer-zts \
        --enable-memory-limit \
        --enable-bcmath=shared \
        --enable-calendar=shared \
@@ -1651,9 +1649,6 @@ done
 # fix install paths, avoid evil rpaths
 sed -i -e "s|^libdir=.*|libdir='%{_libdir}'|" libphp_common.la
 
-# for fcgi: -DDISCARD_PATH=0 -DENABLE_PATHINFO_CHECK=1 -DFORCE_CGI_REDIRECT=0
-# -DHAVE_FILENO_PROTO=1 -DHAVE_FPOS=1 -DHAVE_LIBNSL=1(die) -DHAVE_SYS_PARAM_H=1
-# -DPHP_FASTCGI=1 -DPHP_FCGI_STATIC=1 -DPHP_WRITE_STDOUT=1
 %if %{with apache1}
 %{__make} libtool-sapi LIBTOOL_SAPI=sapi/apache/libphp5.la -f Makefile.apxs1
 sed -i -e "
@@ -1668,19 +1663,18 @@ s|^libdir=.*|libdir='%{_libdir}/apache'|;
 s|^(relink_command=.* -rpath )[^ ]*/libs |$1%{_libdir}/apache |" sapi/apache2handler/libphp5.la
 %endif
 
-%{__make} sapi/cgi/php -f Makefile.fcgi \
-       CFLAGS_CLEAN="%{rpmcflags} -DDISCARD_PATH=0 -DENABLE_PATHINFO_CHECK=1 -DFORCE_CGI_REDIRECT=0 -DHAVE_FILENO_PROTO=1 -DHAVE_FPOS=1 -DHAVE_LIBNSL=1 -DHAVE_SYS_PARAM_H=1 -DPHP_FASTCGI=1 -DPHP_FCGI_STATIC=1 -DPHP_WRITE_STDOUT=1"
+# FCGI
+cp -af php_config.h.fcgi main/php_config.h
+%{__make} sapi/cgi/php -f Makefile.fcgi
 cp -r sapi/cgi sapi/fcgi
 rm -rf sapi/cgi/.libs sapi/cgi/*.lo
 
-# notes:
-# -DENABLE_CHROOT_FUNC=1 (cgi,fcgi) is used in ext/standard/dir.c (libphp_common)
-# -DPHP_WRITE_STDOUT is used also for cli, but not set by its config.m4
-
-%{__make} sapi/cgi/php -f Makefile.cgi \
-       CFLAGS_CLEAN="%{rpmcflags} -DDISCARD_PATH=1 -DENABLE_PATHINFO_CHECK=1 -DFORCE_CGI_REDIRECT=0 -DPHP_WRITE_STDOUT=1"
+# CGI
+cp -af php_config.h.cgi main/php_config.h
+%{__make} sapi/cgi/php -f Makefile.cgi
 
 # CLI
+cp -af php_config.h.cli main/php_config.h
 %{__make} sapi/cli/php -f Makefile.cli
 
 %install
@@ -1695,21 +1689,19 @@ install -d $RPM_BUILD_ROOT{%{_libdir}/{php,apache{,1}},%{_sysconfdir}/{apache,cg
 # install apache1 DSO module
 %if %{with apache1}
 # TODO: use libtool here
-install sapi/apache/.libs/libphp5.so $RPM_BUILD_ROOT%{_libdir}/apache1/libphp5.so
+libtool --silent --mode=install install sapi/apache/libphp5.la $RPM_BUILD_ROOT%{_libdir}/apache1/
 %endif
 
 # install apache2 DSO module
 %if %{with apache2}
-# TODO: use libtool here
-install sapi/apache2handler/.libs/libphp5.so $RPM_BUILD_ROOT%{_libdir}/apache/libphp5.so
+libtool --silent --mode=install install sapi/apache2handler/libphp5.la $RPM_BUILD_ROOT%{_libdir}/apache/
 %endif
 
 libtool --silent --mode=install install libphp_common.la $RPM_BUILD_ROOT%{_libdir}
 
 # install the apache modules' files
 make install-headers install-build install-modules install-programs \
-       INSTALL_ROOT=$RPM_BUILD_ROOT \
-       phpbuilddir=%{_libdir}/php/build
+       INSTALL_ROOT=$RPM_BUILD_ROOT
 
 # as of 5.0.5, phpextdist isn't installed by default
 install scripts/dev/phpextdist $RPM_BUILD_ROOT%{_bindir}
This page took 0.070368 seconds and 4 git commands to generate.