]> git.pld-linux.org Git - packages/php.git/commitdiff
Rel 12; fix openssl 3 build auto/th/php56-5.6.40-12
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 23 Oct 2021 17:46:17 +0000 (19:46 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 23 Oct 2021 17:46:17 +0000 (19:46 +0200)
openssl.patch
php.spec

index f653440674c1898ffe3929edebcf44dd4175a5cd..00b8a8b063ac102ba19e8d2077326034ebba28a8 100644 (file)
@@ -964,3 +964,15 @@ diff -urNp -x '*.orig' php-5.6.40.org/ext/openssl/openssl.c php-5.6.40/ext/opens
  
        if (len >= 0) {
                data[len] = 0;
+--- php-5.3.29/ext/openssl/openssl.c~  2021-10-23 19:18:21.000000000 +0200
++++ php-5.3.29/ext/openssl/openssl.c   2021-10-23 19:19:01.483125024 +0200
+@@ -1044,7 +1044,9 @@ PHP_MINIT_FUNCTION(openssl)
+       REGISTER_LONG_CONSTANT("PKCS7_NOSIGS", PKCS7_NOSIGS, CONST_CS|CONST_PERSISTENT);
+       REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_PADDING", RSA_PKCS1_PADDING, CONST_CS|CONST_PERSISTENT);
++#ifdef RSA_SSLV23_PADDING
+       REGISTER_LONG_CONSTANT("OPENSSL_SSLV23_PADDING", RSA_SSLV23_PADDING, CONST_CS|CONST_PERSISTENT);
++#endif
+       REGISTER_LONG_CONSTANT("OPENSSL_NO_PADDING", RSA_NO_PADDING, CONST_CS|CONST_PERSISTENT);
+       REGISTER_LONG_CONSTANT("OPENSSL_PKCS1_OAEP_PADDING", RSA_PKCS1_OAEP_PADDING, CONST_CS|CONST_PERSISTENT);
index bd29cf633c0c854e977cdc40c3343152dfba93eb..028e46a968da973cc6d688c53782bfe6615c3e2b 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -155,7 +155,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %undefine      with_filter
 %endif
 
-%define                rel     11
+%define                rel     12
 %define                orgname php
 %define                ver_suffix 56
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
This page took 0.051668 seconds and 4 git commands to generate.