]> git.pld-linux.org Git - packages/php.git/commitdiff
- add API versions for php-common package (modules_api, zend_module_api, zend_extensi...
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 13 Sep 2005 17:55:07 +0000 (17:55 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php.spec -> 1.473

php.spec

index 43f1fb3e51ac58bbca6e700754bf35eab766b0f4..d5b1268aa73ca5d0a51f327c5a92ef506206e828 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -77,7 +77,7 @@ Summary(ru):  PHP 
 Summary(uk):   PHP ÷ÅÒÓ¦§ 5 - ÍÏ×Á ÐÒÅÐÒÏÃÅÓÕ×ÁÎÎÑ HTML-ÆÁÊ̦×, ×ÉËÏÎÕ×ÁÎÁ ÎÁ ÓÅÒ×ÅÒ¦
 Name:          php
 Version:       5.0.5
-Release:       3%{?with_hardening:hardened}
+Release:       3.1%{?with_hardening:hardened}
 Epoch:         4
 Group:         Libraries
 License:       PHP
@@ -206,6 +206,12 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _phpsharedir    %{_datadir}/php
 %define                extensionsdir   %{_libdir}/php
 
+# redefine to use versions from current source
+%define                php_sourcedir %{_builddir}/%{name}-%{version}
+%define                php_api_version %(awk '/#define PHP_API_VERSION/{print $3}' %{php_sourcedir}/main/php.h)
+%define                zend_module_api %(awk '/#define ZEND_MODULE_API_NO/{print $3}' %{php_sourcedir}/Zend/zend_modules.h)
+%define                zend_extension_api %(awk '/#define ZEND_EXTENSION_API_NO/{print $3}' %{php_sourcedir}/Zend/zend_extensions.h)
+
 %description
 PHP is an HTML-embedded scripting language. PHP attempts to make it
 easy for developers to write dynamically generated web pages. PHP also
@@ -364,6 +370,9 @@ Requires:   glibc >= 6:2.3.5
 Requires:      sed >= 4.0
 Provides:      %{name}-session = %{epoch}:%{version}-%{release}
 Provides:      php-common(apache-modules-api) = %{apache_modules_api}
+Provides:      php(modules_api) = %{php_api_version}
+Provides:      php(zend_module_api) = %{zend_module_api}
+Provides:      php(zend_extension_api) = %{zend_extension_api}
 Obsoletes:     php-session < 3:4.2.1-2
 # for the posttrans scriptlet, conflicts because in vserver enviroinment rpm package is not installed.
 Conflicts:     rpm < 4.4.2-0.2
@@ -1432,8 +1441,10 @@ compression support to PHP.
 Modu³ PHP umo¿liwiaj±cy u¿ywanie kompresji zlib.
 
 %prep
+# IMPORTANT: if you change '%setup', you should change %php_sourcedir macro earlier in this file
 %setup -q
 # this patch is broken by design, breaks --enable-versioning for example
+# update: --enable-version is broken by itself, it disables dynamic modules.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
This page took 0.066778 seconds and 4 git commands to generate.