]> git.pld-linux.org Git - packages/php.git/commitdiff
- fix building with mysql 5.7 (ER macro uses unexported array) auto/th/php52-5.2.17-20130717.28
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 20 Mar 2018 20:34:26 +0000 (21:34 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 20 Mar 2018 20:34:26 +0000 (21:34 +0100)
- rel 28

mysqli-err.patch [new file with mode: 0644]
php.spec

diff --git a/mysqli-err.patch b/mysqli-err.patch
new file mode 100644 (file)
index 0000000..2987463
--- /dev/null
@@ -0,0 +1,29 @@
+--- php-5.4.45/ext/mysqli/mysqli.c.orig        2018-03-20 20:56:38.000000000 +0100
++++ php-5.4.45/ext/mysqli/mysqli.c     2018-03-20 21:15:42.030265770 +0100
+@@ -1376,7 +1376,7 @@
+       }
+       if (!(mysql = (MY_MYSQL *)userdata)) {
+-              LOCAL_INFILE_ERROR_MSG(data->error_msg, ER(CR_UNKNOWN_ERROR));
++              LOCAL_INFILE_ERROR_MSG(data->error_msg, "Unknown MySQL error");
+               return 1;
+       }
+@@ -1423,7 +1423,7 @@
+               int count = (int)php_stream_read(mysql->li_stream, buf, buf_len);
+               if (count < 0) {
+-                      LOCAL_INFILE_ERROR_MSG(data->error_msg, ER(2));
++                      LOCAL_INFILE_ERROR_MSG(data->error_msg, "Can't connect to local MySQL server");
+               }
+               return count;
+@@ -1499,7 +1499,7 @@
+               strlcpy(error_msg, data->error_msg, error_msg_len);
+               return 2000;
+       } 
+-      strlcpy(error_msg, ER(CR_OUT_OF_MEMORY), error_msg_len);
++      strlcpy(error_msg, "MySQL client ran out of memory", error_msg_len);
+       return CR_OUT_OF_MEMORY;
+ }
+ /* }}} */
index 06478e693028dbc40f8278750ab8dd3a2d713590..a82683c3e5b96e0e780e198c7f628848ffd47025 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -112,7 +112,7 @@ ERROR: You need to select at least one Apache SAPI to build shared modules.
 %define                magic_mime      /usr/share/misc/magic.mime
 %endif
 
-%define                rel     27
+%define                rel     28
 %define                orgname php
 %define                ver_suffix 52
 %define                php_suffix %{!?with_default_php:%{ver_suffix}}
@@ -226,6 +226,7 @@ Patch76:    CVE-2015-0232.patch
 Patch77:       x32.patch
 Patch78:       php-bug-68486.patch
 Patch79:       libevent-2.1.patch
+Patch80:       mysqli-err.patch
 # CENTALT patches
 # Backport from 5.3.6
 Patch311:      php-5.3.6-bug-47435.patch
@@ -1969,6 +1970,7 @@ done
 %patch77 -p1
 %patch78 -p1
 %patch79 -p1
+%patch80 -p1
 
 # Bugfix backport from 5.3.6
 %patch311 -p1 -b .bug-47435
This page took 0.053899 seconds and 4 git commands to generate.