]> git.pld-linux.org Git - packages/php.git/commitdiff
- added separate subpackage for mysql module
authorpius <pius@pld-linux.org>
Wed, 23 Feb 2000 15:20:42 +0000 (15:20 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- added fr translation
- other minor fixes

Changed files:
    php.spec -> 1.4

php.spec

index 0fe40ee5641a4b48a01cadaac6ac1cf28ee17ba2..7bd0c838541dab7494ecd9ba3d9c7ae63a5f8a3b 100644 (file)
--- a/php.spec
+++ b/php.spec
@@ -1,11 +1,12 @@
 Summary:       The PHP HTML-embedded scripting language for use with Apache.
+Summary(fr):   Le langage de script embarque-HTML PHP pour Apache.
 Summary(pl):   Jêzyk skryptowy PHP -- u¿ywany wraz z serwerem Apache.
 Name:          php
 Version:       4.0b4pl1
 Release:       1
 Group:         Libraries
-Group(pl):     X11/Programowanie/Biblioteki
-Group:         Biblioteki
+Group(fr):     Librairies
+Group(pl):     Biblioteki
 License:       GPL
 Source0:       http://www.php.net/distributions/%{name}-%{version}.tar.gz
 Source1:       FAQ.php
@@ -16,8 +17,12 @@ URL:         http://www.php.net/
 BuildRequires: apache-devel
 BuildRequires: zlib-devel
 BuildRequires: mysql-devel
+Requires:      apache >= 1.3.9
+Prereq:                /usr/sbin/apxs
 BuildRoot:     /tmp/%{name}-%{version}-root
 
+%define                _pkglibdir      %{_libdir}/apache
+
 %description
 PHP is an HTML-embedded scripting language.  PHP attempts to make it easy
 for developers to write dynamically generated web pages.  PHP also offers
@@ -26,14 +31,46 @@ database management systems, so writing a database-enabled web page with
 PHP is fairly simple.  The most common use of PHP coding is probably as a
 replacement for CGI scripts.  The mod_php module enables the Apache web
 server to understand and process the embedded PHP language in web pages.
-This package contains PHP.  If you use applications which specifically rely
-on PHP/FI (PHP v2 and earlier), you should instead install the PHP/FI
-module contained in the phpfi package.  If you're just starting with PHP,
-you should install this package.  You'll also need to install the Apache
-web server.
+This package contains PHP version %{version}.  If you use applications which
+specifically rely on PHP/FI (PHP v2 and earlier), you should instead install
+the PHP/FI module contained in the phpfi package.  If you're just starting
+with PHP, you should install this package.  You'll also need to install
+the Apache web server.
+
+%description -l fr
+PHP est un langage de script embarque dans le HTM. PHP essaye de rendre
+simple aux developpeurs d'ecrire des pages web generees dynamiquement.
+PHP incorpore egalement une integration avec plusieurs systemes de gestion
+de bases de donnees commerciaux et non-connerciaux, qui rent facile
+la creation de pages web liees avec des bases de donnees. L'utilisation la
+plus commune de PHP est probablement en remplacement de scripts CGI. Le
+module mod_php permet au serveur web apache de comprendre et de traiter le
+langage PHP integre dans des pages web.
+Ce package contient PHP version %{version}. Si vous utilisez des
+applications qui utilisent specifiquement PHP/FI, vous devrez installer le
+module PHP/FI inclus dans le package mod_php. Si vous debutez avec PHP, vous
+devriez installer ce package. Vous aurez egalement besoin d'installer le
+serveur web Apache.
 
 %description -l pl
-PHP jest jêzykiem skryptowym
+PHP jest jêzykiem skryptowym, którego polecenia umieszcza siê w plikach
+HTML.  Pakiet ten zawiera modu³ przeznaczony dla serwera HTTP (jak np.
+Apache), który interpretuje te polecenia.  Umo¿liwia to tworzenie
+dynamicznie stron WWW.  Spora czê¶æ sk³adni PHP zapo¿yczona zosta³a
+z jêzyków: C, Java i Perl.
+
+%package mysql
+Summary:       MySQL database module for PHP4
+Summary(pl):   Modu³ bazy danych MySQL dla PHP4
+Group:         Libraries
+Group(fr):     Librairies
+Group(pl):     Biblioteki
+Requires:      %{name} = %{version}
+
+%description mysql
+This is a dynamic shared object (DSO) for Apache that will add MySQL
+database support to PHP4.  If you need back-end support for MySQL,
+you should install this package in addition to the main %{name} package.
 
 %prep
 %setup -q 
@@ -50,31 +87,58 @@ PHP jest j
        --enable-magic-quotes \
        --enable-track-vars \
        --without-gd \
-       --with-mysql \
+       --with-gettext \
+       --with-mysql=shared \
        --enable-shared 
 make
 
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_libdir}/apache,%{_sysconfdir}/httpd} \
+install -d $RPM_BUILD_ROOT{%{_pkglibdir},%{_sysconfdir}/httpd} \
                $RPM_BUILD_ROOT/home/httpd/html/icons
 
-install .libs/*.so     $RPM_BUILD_ROOT%{_libdir}/apache
-install %{SOURCE2}     $RPM_BUILD_ROOT%{_sysconfdir}/httpd/php.ini
-install %{SOURCE3}     $RPM_BUILD_ROOT/home/httpd/html/icons
+install .libs/*.so     $RPM_BUILD_ROOT%{_pkglibdir}
+install modules/*.so   $RPM_BUILD_ROOT%{_pkglibdir}
+
+install %{SOURCE2}             $RPM_BUILD_ROOT%{_sysconfdir}/httpd/php.ini
+install %{SOURCE3} php4.gif    $RPM_BUILD_ROOT/home/httpd/html/icons
 
-strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/apache/*.so
+strip --strip-unneeded $RPM_BUILD_ROOT%{_pkglibdir}/*.so
 
 install  %{SOURCE1}    .
-gzip -9nf CODING_STANDARDS CREDITS FAQ* 
+gzip -9nf CODING_STANDARDS CREDITS FAQ* ChangeLog FUNCTION_LIST.txt \
+       MAINTAINERS MODULES_STATUS NEWS TODO*
+
+%post
+/usr/sbin/apxs -e -a -n php %{_pkglibdir}/libphp4.so 1>&2
+if [ -f /var/lock/subsys/httpd ]; then
+       /etc/rc.d/init.d/httpd restart 1>&2
+fi
+
+
+%preun
+if [ "$1" = "0" ]; then
+       /usr/sbin/apxs -e -A -n php %{_pkglibdir}/libphp4.so 1>&2
+       if [ -f /var/lock/subsys/httpd ]; then
+               /etc/rc.d/init.d/httpd restart 1>&2
+       fi
+fi
+
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc {CODING_STANDARDS,CREDITS,FAQ*}.gz  
+%doc {CODING_STANDARDS,CREDITS,FAQ*,ChangeLog,FUNCTION_LIST.txt}.gz
+%doc {MAINTAINERS,MODULES_STATUS,NEWS,TODO*}.gz  
 
 %attr(640,root,root) %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/httpd/*
-%attr(755,root,root) %{_libdir}/apache/libphp4.so
+/home/httpd/html/icons/*
+
+%attr(755,root,root) %{_pkglibdir}/libphp4.so
+
+%files mysql
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_pkglibdir}/mysql.so
This page took 0.0604 seconds and 4 git commands to generate.