]> git.pld-linux.org Git - packages/php-xcache.git/blobdiff - php-xcache.spec
- use php(core) as dependency to require php version
[packages/php-xcache.git] / php-xcache.spec
index 68e39fa9c071affffa8cad33620a995a81c213fb..28ed49df00f1ff163867a17dbf24b93bb55caa9c 100644 (file)
@@ -1,22 +1,29 @@
-%define                _modname        xcache
-Summary:       %{_modname} - PHP opcode cacher
-Summary(pl.UTF-8):     %{_modname} - buforowanie opcodów PHP
-Name:          php-%{_modname}
-Version:       1.2.0
-Release:       1
+%define                modname xcache
+Summary:       %{modname} - PHP opcode cacher
+Summary(pl.UTF-8):     %{modname} - buforowanie opcodów PHP
+Name:          php-%{modname}
+Version:       2.0.1
+Release:       4
 License:       BSD
 Group:         Development/Languages/PHP
 URL:           http://xcache.lighttpd.net/
-Source0:       http://210.51.190.228/pub/XCache/Releases/xcache-%{version}.tar.bz2
-# Source0-md5: ffeaa9547037e098d9b041eb9741b51e
-Patch0:                xcache-m4.patch
-BuildRequires: php-devel >= 3:5.1
+Source0:       http://xcache.lighttpd.net/pub/Releases/%{version}/xcache-%{version}.tar.bz2
+# Source0-md5: d3bc9645dc1b084c1eb45cfc4d8e9ccc
+Source1:       %{modname}-apache.conf
+Source2:       %{modname}-lighttpd.conf
+Patch0:                ini.patch
+BuildRequires: php-devel >= 4:5.2.17-8
 BuildRequires: rpmbuild(macros) >= 1.344
 BuildRequires: sed >= 4.0
 %{?requires_zend_extension}
-Requires:      php-common >= 4:5.0.4
+Requires:      php(core) >= 5.0.4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _webapps        /etc/webapps
+%define                _webapp         %{modname}
+%define                _sysconfdir     %{_webapps}/%{_webapp}
+%define                _appdir         %{_datadir}/%{_webapp}
+
 %description
 XCache is a fast, stable PHP opcode cacher that has been tested and is
 now running on production servers under high load.
@@ -25,12 +32,24 @@ now running on production servers under high load.
 XCache to szybkie, stabilne buforowanie opcodów PHP, przetestowane i
 działające na produkcyjnych serwerach o dużym obciążeniu.
 
+%package web
+Summary:       WEB interface for xCache
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+Requires:      webapps
+Requires:      webserver(php) >= 5.0
+
+%description web
+Via this web interface script you can manage and view statistics of
+xCache.
+
+More information you can find at %{url}.
+
 %prep
-%setup -q -n xcache
+%setup -q -n %{modname}-%{version}
 %patch0 -p1
-%{__sed} -i -e '
-       s,zend_extension =.*,zend_extension = %{php_extensiondir}/xcache.so,
-       s,zend_extension_ts = .*,zend_extension_ts = %{php_extensiondir}/xcache.so,
+%{__sed} -i.bak -e '
+       s,@extensiondir@,%{php_extensiondir},
 ' xcache.ini
 
 %build
@@ -39,22 +58,26 @@ phpize
        --enable-xcache \
        --enable-xcache-optimizer \
        --enable-xcache-coverager
-%{__make} -j1
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
+install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{_sysconfdir}}
 
 %{__make} install \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
 # The cache directory where pre-compiled files will reside
-install -d $RPM_BUILD_ROOT/var/cache/php-xcache
-install -d $RPM_BUILD_ROOT%{_datadir}/xcache
+install -d $RPM_BUILD_ROOT/var/cache/php-%{modname}
+install -d $RPM_BUILD_ROOT%{_appdir}
 
 # Drop in the bit of configuration
-install xcache.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
-install -D admin/* $RPM_BUILD_ROOT%{_datadir}/xcache
+cp -p xcache.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
+cp -a admin/* $RPM_BUILD_ROOT%{_appdir}
+
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
+cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -67,10 +90,37 @@ if [ "$1" = 0 ]; then
        %php_webserver_restart
 fi
 
+%triggerin web -- apache1 < 1.3.37-3, apache1-base
+%webapp_register apache %{_webapp}
+
+%triggerun web -- apache1 < 1.3.37-3, apache1-base
+%webapp_unregister apache %{_webapp}
+
+%triggerin web -- apache < 2.2.0, apache-base
+%webapp_register httpd %{_webapp}
+
+%triggerun web -- apache < 2.2.0, apache-base
+%webapp_unregister httpd %{_webapp}
+
+%triggerin web -- lighttpd
+%webapp_register lighttpd %{_webapp}
+
+%triggerun web -- lighttpd
+%webapp_unregister lighttpd %{_webapp}
+
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS README THANKS
-%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
-%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
-%{_datadir}/xcache
+%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
+%attr(755,root,root) %{php_extensiondir}/%{modname}.so
+
+# XXX: what for this dir is used?
 %dir %attr(775,root,http) /var/cache/php-xcache
+
+%files web
+%defattr(644,root,root,755)
+%dir %attr(750,root,http) %{_sysconfdir}
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
+%{_appdir}
This page took 0.147367 seconds and 4 git commands to generate.