]> git.pld-linux.org Git - packages/php-xcache.git/blame_incremental - php-xcache.spec
- rel 3
[packages/php-xcache.git] / php-xcache.spec
... / ...
CommitLineData
1%define modname xcache
2Summary: %{modname} - PHP opcode cacher
3Summary(pl.UTF-8): %{modname} - buforowanie opcodów PHP
4Name: php-%{modname}
5Version: 1.3.1
6Release: 3
7License: BSD
8Group: Development/Languages/PHP
9URL: http://xcache.lighttpd.net/
10Source0: http://xcache.lighttpd.net/pub/Releases/%{version}/xcache-%{version}.tar.bz2
11# Source0-md5: 36f3af6f1ab1ff631c4dc73f5d541226
12Source1: %{modname}-apache.conf
13Source2: %{modname}-lighttpd.conf
14BuildRequires: php-devel >= 3:5.1
15BuildRequires: rpmbuild(macros) >= 1.344
16BuildRequires: sed >= 4.0
17%{?requires_zend_extension}
18Requires: php-common >= 4:5.0.4
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%define _webapps /etc/webapps
22%define _webapp %{modname}
23%define _sysconfdir %{_webapps}/%{_webapp}
24%define _appdir %{_datadir}/%{_webapp}
25
26%description
27XCache is a fast, stable PHP opcode cacher that has been tested and is
28now running on production servers under high load.
29
30%description -l pl.UTF-8
31XCache to szybkie, stabilne buforowanie opcodów PHP, przetestowane i
32działające na produkcyjnych serwerach o dużym obciążeniu.
33
34%package web
35Summary: WEB interface for xCache
36Group: Libraries
37Requires: %{name} = %{epoch}:%{version}-%{release}
38Requires: webapps
39Requires: webserver(php) >= 5.0
40
41%description web
42Via this web interface script you can manage and view statistics of
43xCache.
44
45More information you can find at %{url}.
46
47%prep
48%setup -q -n %{modname}-%{version}
49%{__sed} -i -e '
50 s,zend_extension =.*,zend_extension = %{php_extensiondir}/xcache.so,
51 s,zend_extension_ts = .*,zend_extension_ts = %{php_extensiondir}/xcache.so,
52' xcache.ini
53
54%build
55phpize
56%configure \
57 --enable-xcache \
58 --enable-xcache-optimizer \
59 --enable-xcache-coverager
60%{__make}
61
62%install
63rm -rf $RPM_BUILD_ROOT
64install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{_sysconfdir}}
65
66%{__make} install \
67 INSTALL_ROOT=$RPM_BUILD_ROOT
68
69# The cache directory where pre-compiled files will reside
70install -d $RPM_BUILD_ROOT/var/cache/php-%{modname}
71install -d $RPM_BUILD_ROOT%{_appdir}
72
73# Drop in the bit of configuration
74cp -a xcache.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
75cp -a admin/* $RPM_BUILD_ROOT%{_appdir}
76
77cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
78cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
79cp -a %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post
85%php_webserver_restart
86
87%postun
88if [ "$1" = 0 ]; then
89 %php_webserver_restart
90fi
91
92%triggerin web -- apache1 < 1.3.37-3, apache1-base
93%webapp_register apache %{_webapp}
94
95%triggerun web -- apache1 < 1.3.37-3, apache1-base
96%webapp_unregister apache %{_webapp}
97
98%triggerin web -- apache < 2.2.0, apache-base
99%webapp_register httpd %{_webapp}
100
101%triggerun web -- apache < 2.2.0, apache-base
102%webapp_unregister httpd %{_webapp}
103
104%triggerin web -- lighttpd
105%webapp_register lighttpd %{_webapp}
106
107%triggerun web -- lighttpd
108%webapp_unregister lighttpd %{_webapp}
109
110%files
111%defattr(644,root,root,755)
112%doc AUTHORS README THANKS
113%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
114%attr(755,root,root) %{php_extensiondir}/%{modname}.so
115
116# XXX: what for this dir is used?
117%dir %attr(775,root,http) /var/cache/php-xcache
118
119%files web
120%defattr(644,root,root,755)
121%dir %attr(750,root,http) %{_sysconfdir}
122%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
123%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
124%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
125%{_appdir}
This page took 0.095581 seconds and 4 git commands to generate.