]> git.pld-linux.org Git - packages/php-xcache.git/blame - php-xcache.spec
- rel 1
[packages/php-xcache.git] / php-xcache.spec
CommitLineData
82f5b15c 1%define _modname xcache
82f5b15c 2Summary: %{_modname} - PHP opcode cacher
fd6082ef 3Summary(pl.UTF-8): %{_modname} - buforowanie opcodów PHP
82f5b15c 4Name: php-%{_modname}
6d2ee3c9 5Version: 1.2.0
cc268ab1 6Release: 1
82f5b15c
ER
7License: BSD
8Group: Development/Languages/PHP
2405d2a6
ER
9URL: http://xcache.lighttpd.net/
10Source0: http://210.51.190.228/pub/XCache/Releases/xcache-%{version}.tar.bz2
11# Source0-md5: ffeaa9547037e098d9b041eb9741b51e
38d97360 12Patch0: xcache-m4.patch
2405d2a6 13BuildRequires: php-devel >= 3:5.1
e9d7bfa1 14BuildRequires: rpmbuild(macros) >= 1.344
99ae26ca 15BuildRequires: sed >= 4.0
22775bf0 16%{?requires_zend_extension}
e9d7bfa1 17Requires: php-common >= 4:5.0.4
82f5b15c
ER
18BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20%description
99ae26ca
ER
21XCache is a fast, stable PHP opcode cacher that has been tested and is
22now running on production servers under high load.
82f5b15c 23
b3c5667f
JR
24%description -l pl.UTF-8
25XCache to szybkie, stabilne buforowanie opcodów PHP, przetestowane i
26działające na produkcyjnych serwerach o dużym obciążeniu.
822de9e6 27
82f5b15c
ER
28%prep
29%setup -q -n xcache
38d97360 30%patch0 -p1
82f5b15c 31%{__sed} -i -e '
e9d7bfa1
ER
32 s,zend_extension =.*,zend_extension = %{php_extensiondir}/xcache.so,
33 s,zend_extension_ts = .*,zend_extension_ts = %{php_extensiondir}/xcache.so,
82f5b15c
ER
34' xcache.ini
35
2405d2a6
ER
36%build
37phpize
38%configure \
39 --enable-xcache \
40 --enable-xcache-optimizer \
41 --enable-xcache-coverager
42%{__make} -j1
43
82f5b15c
ER
44%install
45rm -rf $RPM_BUILD_ROOT
e9d7bfa1 46install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
82f5b15c
ER
47
48%{__make} install \
49 INSTALL_ROOT=$RPM_BUILD_ROOT
50
2405d2a6
ER
51# The cache directory where pre-compiled files will reside
52install -d $RPM_BUILD_ROOT/var/cache/php-xcache
53install -d $RPM_BUILD_ROOT%{_datadir}/xcache
54
55# Drop in the bit of configuration
e9d7bfa1 56install xcache.ini $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
2405d2a6 57install -D admin/* $RPM_BUILD_ROOT%{_datadir}/xcache
82f5b15c
ER
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%post
e9d7bfa1 63%php_webserver_restart
82f5b15c
ER
64
65%postun
66if [ "$1" = 0 ]; then
e9d7bfa1 67 %php_webserver_restart
82f5b15c
ER
68fi
69
70%files
71%defattr(644,root,root,755)
72%doc AUTHORS README THANKS
e9d7bfa1
ER
73%config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
74%attr(755,root,root) %{php_extensiondir}/%{_modname}.so
2405d2a6
ER
75%{_datadir}/xcache
76%dir %attr(775,root,http) /var/cache/php-xcache
This page took 0.073511 seconds and 4 git commands to generate.