]> git.pld-linux.org Git - packages/php-pear-Event_Dispatcher.git/blob - php-pear-Event_Dispatcher.spec
- updated to: 1.1.0
[packages/php-pear-Event_Dispatcher.git] / php-pear-Event_Dispatcher.spec
1 %include        /usr/lib/rpm/macros.php
2 %define         _class          Event
3 %define         _subclass       Dispatcher
4 %define         _status         stable
5 %define         _pearname       %{_class}_%{_subclass}
6
7 Summary:        %{_pearname} - dispatch notifications using PHP callbacks
8 Summary(pl.UTF-8):      %{_pearname} - przekazywanie powiadomień za pośrednictwem callbacków PHP
9 Name:           php-pear-%{_pearname}
10 Version:        1.1.0
11 Release:        1
12 Epoch:          0
13 License:        BSD
14 Group:          Development/Languages/PHP
15 Source0:        http://pear.php.net/get/%{_pearname}-%{version}.tgz
16 # Source0-md5:  cf21ab8b519110a0d574a6822a67a6d8
17 URL:            http://pear.php.net/package/Event_Dispatcher/
18 BuildRequires:  php-pear-PEAR
19 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
20 BuildRequires:  rpmbuild(macros) >= 1.300
21 Requires:       php-pear
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The Event_Dispatcher acts as a notification dispatch table. It is used
27 to notify other objects of interesting things. This information is
28 encapsulated in Event_Notification objects. Client objects register
29 themselves with the Event_Dispatcher as observers of specific
30 notifications posted by other objects. When an event occurs, an object
31 posts an appropriate notification to the Event_Dispatcher. The
32 Event_Dispatcher dispatches a message to each registered observer,
33 passing the notification as the sole argument.
34
35 In PEAR status of this package is: %{_status}.
36
37 %description -l pl.UTF-8
38 Event_Dispatcher działa jako tabela przekazywania powiadomień. Służy
39 do powiadamiania innych obiektów o interesujących rzeczach. Informacje
40 te są opakowywane w obiekty Event_Notification. Obiekty klienckie
41 rejestrują się w klasie Event_Dispatcher jako obserwatorzy konkretnych
42 powiadomień wysyłanych przez inne obiekty. Kiedy zachodzi zdarzenie,
43 obiekt wysyła odpowiednie powiadomienie do klasy Event_Dispatcher.
44 Event_Dispatcher przekazuje tę wiadomość do każdego zarejestrowanego
45 obserwatora, przekazując powiadomienie jako jedyny argument.
46
47 Ta klasa ma w PEAR status: %{_status}.
48
49 %package tests
50 Summary:        Tests for PEAR::%{_pearname}
51 Summary(pl.UTF-8):      Testy dla PEAR::%{_pearname}
52 Group:          Development/Languages/PHP
53 Requires:       %{name} = %{epoch}:%{version}-%{release}
54 AutoProv:       no
55 AutoReq:        no
56
57 %description tests
58 Tests for PEAR::%{_pearname}.
59
60 %description tests -l pl.UTF-8
61 Testy dla PEAR::%{_pearname}.
62
63 %prep
64 %pear_package_setup
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT%{php_pear_dir}
69 %pear_package_install
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc install.log
77 %doc docs/%{_pearname}/examples
78 %{php_pear_dir}/.registry/*.reg
79 %{php_pear_dir}/%{_class}
80
81 %files tests
82 %defattr(644,root,root,755)
83 %{php_pear_dir}/tests/*
This page took 0.094011 seconds and 3 git commands to generate.