]> git.pld-linux.org Git - packages/php-ioncube.git/blob - php-ioncube.spec
- update loaders to 3.1.32
[packages/php-ioncube.git] / php-ioncube.spec
1 %define         _name           ioncube
2 Summary:        ionCube loader module for PHP
3 Summary(pl.UTF-8):      Moduł wczytujący ionCube dla PHP
4 Name:           php-%{_name}
5 # this is version of x86 modules; ppc one are usually older
6 Version:        3.1.32
7 Release:        1
8 License:        redistributable
9 Group:          Libraries
10 Source0:        http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_x86.tar.bz2
11 # Source0-md5:  72fc7232400152f62eb7898404a31799
12 Source1:        http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_x86-64.tar.bz2
13 # Source1-md5:  89e31fe0aee019717ca4b27b375c8ca4
14 Source2:        http://downloads2.ioncube.com/loader_downloads/ioncube_loaders_lin_ppc.tar.bz2
15 # Source2-md5:  4876ff298ca17df0435c8f2214b11f8b
16 URL:            http://ioncube.com/
17 BuildRequires:  php-devel >= 3:5.0.0
18 BuildRequires:  rpmbuild(macros) >= 1.344
19 %{?requires_php_extension}
20 Requires:       php-common >= 4:5.0.4
21 ExclusiveArch:  %{ix86} %{x8664} ppc
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 ionCube loader module for PHP.
26
27 %description -l pl.UTF-8
28 Moduł wczytujący ionCube dla PHP.
29
30 %prep
31 %ifarch %{ix86}
32 %setup -q -T -b 0 -n %{_name}
33 %endif
34 %ifarch %{x8664}
35 %setup -q -T -b 1 -n %{_name}
36 %endif
37 %ifarch ppc
38 %setup -q -T -b 2 -n %{_name}
39 %endif
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT{%{php_extensiondir},%{php_sysconfdir}/conf.d}
44
45 install $(ls -1 *_ts.so  | sort | tail -n 1) $RPM_BUILD_ROOT%{php_extensiondir}/%{_name}.so
46 echo "zend_extension_ts=%{php_extensiondir}/%{_name}.so" > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_name}.ini
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %post
52 %php_webserver_restart
53
54 %postun
55 if [ "$1" = 0 ]; then
56         %php_webserver_restart
57 fi
58
59 %files
60 %defattr(644,root,root,755)
61 %doc *.txt *.php
62 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_name}.ini
63 %attr(755,root,root) %{php_extensiondir}/ioncube.so
This page took 0.038417 seconds and 4 git commands to generate.