]> git.pld-linux.org Git - packages/php-adodb.git/blob - php-adodb.spec
- don't copy pear files without pear
[packages/php-adodb.git] / php-adodb.spec
1 # TODO
2 # - rename to php-adodb
3 #
4 %bcond_without  pear    # Don't build pear-dependent packages.
5
6 %include        /usr/lib/rpm/macros.php
7 %define         ver     %(echo %{version} | tr -d .)
8 %define         subver  a
9 %define         rel             0.1
10 Summary:        Unique interface to access different SQL databases
11 Summary(pl.UTF-8):      Jednolity inferfejs dostępu do baz danych SQL
12 Name:           adodb
13 Version:        4.96
14 Release:        %{subver}.%{rel}
15 License:        dual licensed using BSD-Style and LGPL
16 Group:          Libraries
17 Source0:        http://dl.sourceforge.net/adodb/%{name}%{ver}%{subver}.tgz
18 # Source0-md5:  9aebb0e04d8e67493c0e70fc75c9fc43
19 Patch0:         %{name}-paths.patch
20 URL:            http://adodb.sourceforge.net/
21 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
22 Requires:       php-common
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _noautoreq 'pear(\.\./.*)' 'pear(adodb.*)' 'pear(test.*)' 'pear(.*.inc.php)'
27 %define         _noautoprov 'pear(adodb/.*)'
28
29 %define         _appdir         %{_datadir}/php/%{name}
30
31 %description
32 PHP's database access functions are not standardized. This creates a
33 need for a database class library to hide the differences between the
34 different databases (encapsulate the differences) so we can easily
35 switch databases.
36
37 It currently supports MySQL, Interbase, Oracle, Microsoft SQL Server,
38 Sybase, PostgreSQL, Foxpro, Access, ADO and ODBC.
39
40 %description -l pl.UTF-8
41 Funkcje dostępu do baz danych w PHP nie są ustandaryzowane. To
42 powoduje iż potrzebna jest biblioteka dostarczająca jednolite funkcje
43 ukrywająca różnice pomiędzy różnymi bazami dzięki czemu łatwo można
44 zmieniać bazy.
45
46 Aktualnie obsługuje MySQL, Interbase, Oracle, Microsoft SQL Server,
47 Sybase, PostgreSQL, Foxpro, Access, ADO i ODBC.
48
49 %package -n php-pear-Auth_Container_ADOdb
50 Summary:        ADOdb container for PEAR Auth
51 Summary(pl.UTF-8):      Kontener ADOdb dla PEAR Auth
52 Group:          Development/Languages/PHP
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       %{name}-pear
55 Requires:       php-pear-Auth
56
57 %description -n php-pear-Auth_Container_ADOdb
58 Storage driver for fetching login data from a database using
59 ADOdb-PHP.
60
61 This storage driver can use all databases which are supported by the
62 ADOdb DB abstraction layer to fetch login data.
63
64 %description -n php-pear-Auth_Container_ADOdb -l pl.UTF-8
65 Sterownik przechowywania danych do pobierania danych logowania z bazy
66 danych przy użyciu ADOdb-PHP.
67
68 Ten sterownik przechowywania danych może używać wszystkich baz danych
69 obsługiwanych przez warstwę abstrakcji ADOdb DB do pobierania danych.
70
71 %package pear
72 Summary:        PEAR DB Emulation Layer for ADOdb
73 Summary(pl.UTF-8):      Warstwa emulacji PEAR DB dla ADOdb
74 Group:          Development/Languages/PHP
75 Requires:       %{name} = %{version}-%{release}
76 Requires:       php-pear
77
78 %description pear
79 PEAR DB Emulation Layer for ADODB.
80
81 %description pear -l pl.UTF-8
82 Warstwa emulacji PEAR DB dla ADOdb.
83
84 %package tests
85 Summary:        Tests for ADOdb
86 Summary(pl.UTF-8):      Testy dla ADOdb
87 Group:          Development/Languages/PHP
88 Requires:       %{name} = %{epoch}:%{version}-%{release}
89
90 %description tests
91 Tests for ADOdb.
92
93 %description tests -l pl.UTF-8
94 Testy dla ADOdb.
95
96 %prep
97 %setup -q -n %{name}
98 # undos the source
99 find . -type f -print0 | xargs -0 sed -i -e 's,\r$,,'
100
101 %patch0 -p1
102 mv pear/{readme.Auth.txt,README}
103 rm -rf session/old
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT%{_appdir}/{drivers,datadict,perf,lang,session,xsl}
108
109 cp -a *.php *.dtd drivers datadict tests lang perf session xsl \
110         $RPM_BUILD_ROOT%{_appdir}
111
112 %if %{with pear}
113 install -d $RPM_BUILD_ROOT%{php_pear_dir}/Auth/Container
114 cp -a pear/Auth/Container/ADOdb.php $RPM_BUILD_ROOT%{php_pear_dir}/Auth/Container
115 %endif
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %triggerpostun -- adodb < 4.67-1.17
121 %banner -e %{name} <<EOF
122 ADODB includes have been moved to %{_appdir}.
123 If you're too lazy to fix your code, make compat symlink:
124 ln -s %{_appdir} %{php_pear_dir}/adodb
125 EOF
126 #'
127
128 %files
129 %defattr(644,root,root,755)
130 %dir %{_appdir}
131 %{_appdir}/datadict
132 %{_appdir}/drivers
133 %{_appdir}/lang
134 %{_appdir}/perf
135 %{_appdir}/server.php
136 %{_appdir}/session
137 %{_appdir}/xmlschema.dtd
138 %{_appdir}/xmlschema03.dtd
139 %{_appdir}/xsl
140
141 %{_appdir}/adodb-csvlib.inc.php
142 %{_appdir}/adodb-datadict.inc.php
143 %{_appdir}/adodb-error.inc.php
144 %{_appdir}/adodb-errorhandler.inc.php
145 %{_appdir}/adodb-exceptions.inc.php
146 %{_appdir}/adodb-iterator.inc.php
147 %{_appdir}/adodb-lib.inc.php
148 %{_appdir}/adodb-pager.inc.php
149 %{_appdir}/adodb-perf.inc.php
150 %{_appdir}/adodb-php4.inc.php
151 %{_appdir}/adodb-time.inc.php
152 %{_appdir}/adodb-xmlschema.inc.php
153 %{_appdir}/adodb.inc.php
154 %{_appdir}/toexport.inc.php
155 %{_appdir}/tohtml.inc.php
156 %{_appdir}/adodb-active-record.inc.php
157 %{_appdir}/adodb-xmlschema03.inc.php
158 %{_appdir}/adodb-memcache.lib.inc.php
159
160 %if %{with pear}
161 %files tests
162 %defattr(644,root,root,755)
163 %{_appdir}/tests
164 %{_appdir}/pivottable.inc.php
165 %{_appdir}/rsfilter.inc.php
166
167 %files pear
168 %defattr(644,root,root,755)
169 %{_appdir}/adodb-pear.inc.php
170 %{_appdir}/adodb-errorpear.inc.php
171
172 %files -n php-pear-Auth_Container_ADOdb
173 %defattr(644,root,root,755)
174 %doc pear/README
175 %{php_pear_dir}/Auth/Container/ADOdb.php
176 %endif
This page took 0.074535 seconds and 3 git commands to generate.