]> git.pld-linux.org Git - packages/photoqt.git/blob - photoqt.spec
- updated to 3.3 (ready for exiv2 0.28)
[packages/photoqt.git] / photoqt.spec
1 # TODO:
2 # VIDEO_MPV (upstream on by default) (BR: libmpv)
3 # LIBVIPS (upstream off by default) (BR: glib2, vips, vips-cpp)
4 #
5 # Conditional build:
6 %bcond_without  gmagick         # GraphicsMagick support
7
8 %define qt_ver  5.9
9 Summary:        Simple but powerful Qt-based image viewer
10 Summary(pl.UTF-8):      Prosta, ale mająca duże możliwości przeglądarka obrazków oparta na Qt
11 Name:           photoqt
12 Version:        3.3
13 Release:        1
14 License:        GPL v2+
15 Group:          X11/Applications
16 #Source0Download: http://photoqt.org/down/
17 Source0:        https://photoqt.org/downloads/source/%{name}-%{version}.tar.gz
18 # Source0-md5:  d06988f0c505266bffbd187b6a4e8379
19 Patch0:         %{name}-pychromecast.patch
20 URL:            https://photoqt.org/
21 BuildRequires:  DevIL-devel
22 BuildRequires:  FreeImage-devel
23 %{?with_gmagick:BuildRequires:  GraphicsMagick-c++-devel}
24 BuildRequires:  Qt5Concurrent-devel >= %{qt_ver}
25 BuildRequires:  Qt5Core-devel >= %{qt_ver}
26 BuildRequires:  Qt5DBus-devel >= %{qt_ver}
27 BuildRequires:  Qt5Gui-devel >= %{qt_ver}
28 BuildRequires:  Qt5Multimedia-devel >= %{qt_ver}
29 BuildRequires:  Qt5PrintSupport-devel >= %{qt_ver}
30 BuildRequires:  Qt5Quick-devel >= %{qt_ver}
31 BuildRequires:  Qt5Sql-devel >= %{qt_ver}
32 BuildRequires:  Qt5Svg-devel >= %{qt_ver}
33 BuildRequires:  Qt5Widgets-devel >= %{qt_ver}
34 BuildRequires:  Qt5Xml-devel >= %{qt_ver}
35 BuildRequires:  cmake >= 3.16
36 BuildRequires:  exiv2-devel >= 0.26
37 BuildRequires:  libarchive-devel
38 BuildRequires:  libraw-devel
39 BuildRequires:  libstdc++-devel >= 6:4.7
40 BuildRequires:  pkgconfig
41 BuildRequires:  poppler-qt5-devel
42 BuildRequires:  pugixml-devel
43 BuildRequires:  python3-pychromecast
44 BuildRequires:  qt5-build >= %{qt_ver}
45 BuildRequires:  qt5-linguist >= %{qt_ver}
46 BuildRequires:  qt5-qmake >= %{qt_ver}
47 BuildRequires:  rpmbuild(macros) >= 1.596
48 Requires(post,postun):  desktop-file-utils
49 Requires(post,postun):  gtk-update-icon-cache
50 Requires:       Qt5Core >= %{qt_ver}
51 Requires:       Qt5Gui >= %{qt_ver}
52 Requires:       Qt5Quick >= %{qt_ver}
53 Requires:       Qt5Sql >= %{qt_ver}
54 Requires:       Qt5Sql-sqldriver-sqlite3 >= %{qt_ver}
55 Requires:       Qt5Svg >= %{qt_ver}
56 Requires:       Qt5Widgets >= %{qt_ver}
57 Requires:       hicolor-icon-theme
58 # psd imageformat plugin
59 Suggests:       libqpsd-qt5
60 Suggests:       xcftools
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %description
64 Simple but powerful Qt-based image viewer.
65
66 %description -l pl.UTF-8
67 Prosta, ale mająca duże możliwości przeglądarka obrazków oparta na Qt.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72
73 %build
74 %cmake -B build \
75         -DEXIV2=ON \
76         %{!?with_gmagick:-DGM=OFF} \
77         -DVIDEO_MPV=OFF
78
79 %{__make} -C build
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} -C build install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 # no longer installed by default?
88 cp -p org.photoqt.PhotoQt.standalone.desktop $RPM_BUILD_ROOT%{_desktopdir}
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post
94 %update_desktop_database
95 %update_icon_cache hicolor
96
97 %postun
98 %update_desktop_database
99 %update_icon_cache hicolor
100
101 %files
102 %defattr(644,root,root,755)
103 %doc CHANGELOG README.md
104 %attr(755,root,root) %{_bindir}/photoqt
105 %{_datadir}/metainfo/org.photoqt.PhotoQt.metainfo.xml
106 %{_desktopdir}/org.photoqt.PhotoQt.desktop
107 %{_desktopdir}/org.photoqt.PhotoQt.standalone.desktop
108 %{_iconsdir}/hicolor/*x*/apps/org.photoqt.PhotoQt.png
This page took 0.169035 seconds and 4 git commands to generate.