]> git.pld-linux.org Git - packages/perl.git/commitdiff
- removed empty no description
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 24 Dec 2002 20:10:19 +0000 (20:10 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- use standard [! ] shellglob exclusions
- fixed db4 patch (s/-ldb4.1/-ldb-4.1/)
- link patch - don't try -lbind -lnsl -lutil (seem not needed for anything);
  but linking is still not perfect: libperl.so should be linked with
  -lcrypt -lm, and perl binaries with just -lperl -ldl

Changed files:
    perl-db4.patch -> 1.3
    perl-link.patch -> 1.1
    perl.spec -> 1.178

perl-db4.patch
perl-link.patch [new file with mode: 0644]
perl.spec

index 1cb15ea413d5f1c6207ed751864c0d92082f4529..8b3de136b366e969e53d2f6cdc8f6ab54eece074 100644 (file)
@@ -18,7 +18,7 @@
      NAME      => 'NDBM_File',
 -    LIBS => ["-L/usr/local/lib -lndbm", "-ldbm -lucb"],
 -    CCFLAGS => '-I/usr/include/db1 -Dbool=char -DHAS_BOOL',
-+    LIBS => ["-L/usr/local/lib -ldb4.1"],
++    LIBS => ["-L/usr/local/lib -ldb-4.1"],
 +    CCFLAGS => '-Dbool=char -DHAS_BOOL',
      MAN3PODS  => {},  # Pods will be built by installman.
      XSPROTOARG => '-noprototypes',            # XXX remove later?
diff --git a/perl-link.patch b/perl-link.patch
new file mode 100644 (file)
index 0000000..202fc07
--- /dev/null
@@ -0,0 +1,16 @@
+--- perl-5.6.1/Configure.orig  Mon Mar 19 04:03:33 2001
++++ perl-5.6.1/Configure       Tue Dec 24 20:12:56 2002
+@@ -1030,10 +1030,9 @@
+ : List of libraries we want.
+ : If anyone needs -lnet, put it in a hint file.
+-libswanted='sfio socket bind inet nsl nm ndbm gdbm dbm db malloc dl'
+-libswanted="$libswanted dld ld sun m c cposix posix"
+-libswanted="$libswanted ndir dir crypt sec"
+-libswanted="$libswanted ucb bsd BSD PW x iconv util"
++libswanted='ndbm gdbm db dl'
++libswanted="$libswanted m c"
++libswanted="$libswanted crypt"
+ : We probably want to search /usr/shlib before most other libraries.
+ : This is only used by the lib/ExtUtils/MakeMaker.pm routine extliblist.
+ glibpth=`echo " $glibpth " | sed -e 's! /usr/shlib ! !'`
index 194ccbae4528f4139643421ed68ae04db07c1539..3e0f8417d29ef1aa5bd023edccd02152818f9944 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -45,6 +45,7 @@ Patch10:      %{name}-sitearch.patch
 Patch11:       %{name}-soname.patch
 Patch12:       %{name}-db4.patch
 Patch13:       %{name}-gcc3.patch
+Patch14:       %{name}-link.patch
 URL:           http://www.perl.org/
 BuildRequires: db-devel > 4.1
 BuildRequires: gdbm-devel
@@ -170,8 +171,6 @@ sistema e programa
 são escritos em Perl. Você precisa do pacote perl instalado no seu
 sistema de maneira a que este possa tratar de 'scripts' de Perl.
 
-%description -l no
-
 %description -l pt_BR
 Perl é uma linguagem interpretada, otimizada para tratar arquivos
 texto, extraindo informação desses arquivos e mostrando relatórios
@@ -329,8 +328,8 @@ Summary(es):        Perl's base modules
 Summary(pl):   Practical Extraction and Report Language - modu³y
 Summary(pt_BR):        Módulos do perl básicos
 Group:         Applications/Text
+Requires:      %{name} = %{version}
 Requires:      perl-Test-Harness
-Prereq:                %{name} = %{version}
 Provides:      perl-ANSIColor
 Provides:      perl-DProf
 Provides:      perl-Devel-Peek
@@ -358,7 +357,7 @@ programas/ scripts.
 Summary:       Perl POD documentation
 Summary(pl):   Dokumentacja Perla w formacie POD
 Group:         Applications/Text
-Prereq:                %{name} = %{version}
+Requires:      %{name} = %{version}
 
 %description pod
 Practical Extraction and Report Language - POD docs.
@@ -383,6 +382,7 @@ POD.
 %patch11 -p1
 %patch12 -p1
 %patch13 -p1
+%patch14 -p1
 
 for i in find-* ; do
        mv -f $i $i.old
@@ -767,9 +767,9 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/find2perl.1*
 %{_mandir}/man1/perl.1*
 %{_mandir}/man1/perl[ae-z]*.1*
-%{_mandir}/man1/perlb[^u]*.1*
-%{_mandir}/man1/perlc[^c]*.1*
-%{_mandir}/man1/perld[^o]*.1*
+%{_mandir}/man1/perlb[!u]*.1*
+%{_mandir}/man1/perlc[!c]*.1*
+%{_mandir}/man1/perld[!o]*.1*
 %{_mandir}/man1/s2p.1*
 %{_mandir}/man1/xsubpp.1*
 %lang(fi) %{_mandir}/fi/man1/perl*
@@ -1026,5 +1026,5 @@ rm -rf $RPM_BUILD_ROOT
 
 %files pod
 %defattr(644,root,root,755)
-%{_libdir}/perl5/%{version}/pod/perl[^d]*
-%{_libdir}/perl5/%{version}/pod/perld[^i]*
+%{_libdir}/perl5/%{version}/pod/perl[!d]*
+%{_libdir}/perl5/%{version}/pod/perld[!i]*
This page took 0.040229 seconds and 4 git commands to generate.