]> git.pld-linux.org Git - packages/perl.git/commitdiff
- updated to 6.5.5-3
authoramateja <amateja@pld-linux.org>
Thu, 27 Aug 2009 06:50:08 +0000 (06:50 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    perl-PerlIO.patch -> 1.2
    perl-h2ph-includes.patch -> 1.2
    perl-t-syslog.patch -> 1.2
    perl-timer-test.patch -> 1.3
    perl-write-permissions.patch -> 1.3
    perl.spec -> 1.418
    perl_581-noroot_install.patch -> 1.2
    perl_581-soname.patch -> 1.5
    perl_585-microperl_uconfig.patch -> 1.6

perl-PerlIO.patch
perl-h2ph-includes.patch
perl-t-syslog.patch
perl-timer-test.patch
perl-write-permissions.patch
perl.spec
perl_581-noroot_install.patch
perl_581-soname.patch
perl_585-microperl_uconfig.patch

index 0d79255a93c3694ca08b926dbb68b753330eff0d..1ee702507b0aa3676b5389801cdd46e0cfaf781d 100644 (file)
@@ -1,6 +1,6 @@
 diff -ur perl-5.10.0.org/ext/PerlIO/via/via.xs perl-5.10.0/ext/PerlIO/via/via.xs
---- perl-5.10.0.org/ext/PerlIO/via/via.xs      2007-12-18 11:47:07.000000000 +0100
-+++ perl-5.10.0/ext/PerlIO/via/via.xs  2008-08-10 00:35:51.367506014 +0200
+--- perl-5.10.0.org/ext/PerlIO-via/via.xs      2007-12-18 11:47:07.000000000 +0100
++++ perl-5.10.0/ext/PerlIO-via/via.xs  2008-08-10 00:35:51.367506014 +0200
 @@ -89,7 +89,7 @@
            if (!s->fh) {
                GV *gv = newGVgen(HvNAME_get(s->stash));
index 84a6e97647c0508ef87fb28b5ddbc5c47a96c801..1097d0edd92288a1bf693bce67a75e68e88bb9d1 100644 (file)
@@ -1,6 +1,6 @@
---- perl-5.10.0/utils/h2ph.PL.orig     2007-12-18 11:47:08.000000000 +0100
-+++ perl-5.10.0/utils/h2ph.PL  2008-02-10 14:01:47.206525485 +0100
-@@ -717,6 +717,7 @@
+--- perl-5.10.1/utils/h2ph.PL.orig     2009-08-25 10:14:50.000000000 +0200
++++ perl-5.10.1/utils/h2ph.PL  2009-08-25 10:23:00.000000000 +0200
+@@ -722,6 +722,7 @@
  
      return if ($file eq "-");
  
@@ -8,12 +8,14 @@
      open HEADER, $file or return;
          while (defined($line = <HEADER>)) {
              while (/\\$/) { # Handle continuation lines
-@@ -726,6 +727,8 @@
-             if ($line =~ /^#\s*include\s+<(.*?)>/) {
-                 push(@ARGV, $1) unless $Is_converted{$1};
+@@ -736,7 +737,9 @@
+                     $new_file = "$1/$new_file";
+                 }
+                 push(@ARGV, $new_file) unless $Is_converted{$new_file};
+-            }
 +            } elsif ($line =~ /^#\s*include\s+\"(.*?)\"/) {
-+                push(@ARGV, $filedir . $1) unless $Is_converted{$filedir . $1};
-             }
++                  push(@ARGV, $filedir . $new_file) unless $Is_converted{$filedir . $new_file};
++          }
          }
      close HEADER;
+ }
index c41b5a33db981c5c713d95f91266c0f28ab085cc..e014b79c65516ddf1c88a3f75f9f5fe95d00eb0c 100644 (file)
@@ -1,15 +1,15 @@
---- perl-5.10.0/ext/Sys/Syslog/t/syslog.t~     2008-02-26 07:24:29.000000000 +0000
-+++ perl-5.10.0/ext/Sys/Syslog/t/syslog.t      2008-02-26 07:24:34.000000000 +0000
-@@ -201,7 +201,11 @@
+--- perl-5.10.1/ext/Sys-Syslog/t/syslog.t.orig 2009-08-25 10:25:36.000000000 +0200
++++ perl-5.10.1/ext/Sys-Syslog/t/syslog.t      2009-08-25 10:27:58.000000000 +0200
+@@ -213,7 +213,11 @@
          }
      }
      else  {
 -        ok( $r, "setlogsock() should return true: '$r'" );
-+              if (-r "/dev/log") {
-+                      ok( $r, "setlogsock() should return true: '$r'" );
-+              } else {
-+                      ok( !$r, "setlogsock() should return false: '$r'" );
-+        }
++          if (-r "/dev/log") {
++                    ok( $r, "setlogsock() should return true: '$r'" );
++            } else {
++                    ok( !$r, "setlogsock() should return false: '$r'" );
++          }
      }
  
      # setlogsock() with "stream" and an empty path
index 95cd45ce780cf2cf2ff98862f183539a9c47e83b..d9b075f4b07bc467b5884a989103d48861be3521 100644 (file)
@@ -1,5 +1,5 @@
---- perl-5.8.8/ext/Time/HiRes/t/HiRes.t~       2005-12-17 20:20:26.000000000 +0100
-+++ perl-5.8.8/ext/Time/HiRes/t/HiRes.t        2007-02-11 00:06:42.000000000 +0100
+--- perl-5.10.1/ext/Time-HiRes/t/HiRes.t.orig  2005-12-17 20:20:26.000000000 +0100
++++ perl-5.10.1/ext/Time-HiRes/t/HiRes.t       2007-02-11 00:06:42.000000000 +0100
 @@ -113,7 +113,7 @@
  # completes fine with (say) 30% slosh, and fail otherwise.  If you do that,
  # consider changing over to test.pl at the same time.
index 4004ba77f8cf9c1f2be721b22885064d9a921f18..9827beb58ed07787165e5c7ef1ac3e5ec436042c 100644 (file)
@@ -1,15 +1,15 @@
---- ExtUtils-MakeMaker-6.30.orig/lib/ExtUtils/Install.pm       2005-03-22 04:30:24.000000000 +0000
-+++ ExtUtils-MakeMaker-6.30.write-permissions/lib/ExtUtils/Install.pm  2006-10-30 16:14:28.000000000 +0000
-@@ -666,7 +666,7 @@
-             utime($atime,$mtime + $Is_VMS,$targetfile) unless $nonono>1;
+--- perl-5.10.1/lib/ExtUtils/Install.pm.orig   2009-08-25 08:46:26.000000000 +0200
++++ perl-5.10.1/lib/ExtUtils/Install.pm        2009-08-25 08:48:05.000000000 +0200
+@@ -813,7 +813,7 @@
+                 utime($atime,$mtime + $Is_VMS,$targetfile) unless $dry_run>1;
  
  
--            $mode = 0444 | ( $mode & 0111 ? 0111 : 0 );
-+            $mode = 0644 | ( $mode & 0111 ? 0111 : 0 );
-             $mode = $mode | 0222
-                 if $realtarget ne $targetfile;
-             _chmod( $mode, $targetfile, $verbose );
-@@ -1018,7 +1018,7 @@
+-                $mode = 0444 | ( $mode & 0111 ? 0111 : 0 );
++                $mode = 0644 | ( $mode & 0111 ? 0111 : 0 );
+                 $mode = $mode | 0222
+                     if $realtarget ne $targetfile;
+                 _chmod( $mode, $targetfile, $verbose );
+@@ -1215,7 +1215,7 @@
          }
          my($mode,$atime,$mtime) = (stat $from)[2,8,9];
          utime($atime,$mtime+$Is_VMS,$to);
@@ -18,4 +18,3 @@
          next unless $from =~ /\.pm$/;
          _autosplit($to,$autodir);
      }
-
index 84f67b7cf058ff8c5b3f0add8f9252d9a07fb9a8..fbbef96b4ee3327ddf8e528d21931a84c4ef57c9 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -28,7 +28,7 @@
 # NOTE
 # - modules in 5.10.0: http://search.cpan.org/~rgarcia/perl-5.10.0/
 
-%define                abi     5.10.0
+%define                abi     5.10.1
 %define                perlthread      %{?with_threads:-thread-multi}
 
 %define                perl_privlib    %{_datadir}/perl5/%{ver}
@@ -42,8 +42,8 @@
 %define                perl_modver()           %([ -f %{SOURCE3} ] && awk -vp=%1 '$1 == p{print $3}' %{SOURCE3} || echo ERROR)
 %define                perl_modversion()       %([ -f %{SOURCE3} ] && awk -vp=%1 '$1 == p{m=$1; gsub(/::/, "-", m); printf("perl-%s = %s\\n", m, $3)}END{if (!m) printf("# Error looking up [%s]\\n", p)}' %{SOURCE3} || echo ERROR)
 
-%define                ver     5.10.0
-%define                rel     20
+%define                ver     5.10.1
+%define                rel     1
 Summary:       Practical Extraction and Report Language (Perl)
 Summary(cs.UTF-8):     Programovací jazyk Perl
 Summary(da.UTF-8):     Programmeringssproget Perl
@@ -72,7 +72,7 @@ Epoch:                1
 License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/src/%{name}-%{ver}.tar.gz
-# Source0-md5: d2c39b002ebfd2c3c5dba589365c5a71
+# Source0-md5: b9b2fdb957f50ada62d73f43ee75d044
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: de47d7893f49ad7f41ba69c78511c0db
 Source2:       %{name}.prov
@@ -87,9 +87,9 @@ Patch6:               %{name}-write-permissions.patch
 Patch7:                %{name}-timer-test.patch
 Patch8:                %{name}-h2ph-includes.patch
 Patch9:                %{name}-t-syslog.patch
-Patch10:       %{name}-PerlIO.patch
-Patch11:       %{name}-attribute_error.patch
-Patch12:       %{name}-parameter_passing.patch
+#Patch10:      %{name}-ListUtil.patch
+#Patch11:      %{name}-attribute_error.patch
+#Patch12:      %{name}-parameter_passing.patch
 URL:           http://dev.perl.org/perl5/
 %ifarch ppc
 # gcc 3.3.x miscompiles pp_hot.c
@@ -660,9 +660,9 @@ z biblioteki GNU gdbm.
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
-%patch10 -p1
-%patch11 -p1
-%patch12 -p1
+#%patch10 -p1
+#%patch11 -p1
+#%patch12 -p1
 
 %build
 
@@ -700,14 +700,14 @@ sh Configure \
 
 ## {Scalar,List}::Util should be in perl_archlib (it's a bit tricky and should
 ## probably be done in %%prep, but then Configure would complain (->MANIFEST))
-mv ext/List/Util/lib/List/Util.pm ext/List/Util
-%{__rm} ext/List/Util/Makefile.PL
-cat <<'EOF' > ext/List/Util/Makefile.PL
+mv ext/List-Util/lib/List/Util.pm ext/List-Util
+%{__rm} ext/List-Util/Makefile.PL
+cat <<'EOF' > ext/List-Util/Makefile.PL
 use ExtUtils::MakeMaker;
 WriteMakefile(NAME=>"List::Util", VERSION_FROM=>"Util.pm", DEFINE=>"-DPERL_EXT");
 EOF
 
-%{__make} \
+%{__make} -j1 \
        LIBPERL_SONAME=libperl.so.%{abi} \
        LDDLFLAGS="%{rpmcflags} -shared"
 
@@ -722,7 +722,7 @@ chmod a+x runperl
 ## microperl
 %if %{with microperl}
 %{__rm} uconfig.h
-%{__make} -f Makefile.micro \
+%{__make} -j1 -f Makefile.micro \
        archlib=%{perl_archlib} \
        archlibexp=%{perl_archlib} \
        privlib=%{perl_privlib} \
index 47a50474bbbf14445dae9f8af1252b726349f0cd..b4978358a297c3376e73b4d736a3029477594fef 100644 (file)
@@ -4,8 +4,8 @@
  
  # Do some quick sanity checks.
  
--if (!$nonono && $d_dosuid && $>) { die "You must run as root to install suidperl\n"; }
-+#if (!$nonono && $d_dosuid && $>) { die "You must run as root to install suidperl\n"; }
+-if (!$opts{notify} && $d_dosuid && $>) { die "You must run as root to install suidperl\n"; }
++#if (!$opts{notify} && $d_dosuid && $>) { die "You must run as root to install suidperl\n"; }
  
     $installbin                || die "No installbin directory in config.sh\n";
  -d $installbin                || mkpath($installbin, $verbose, 0777);
index 60e5f8d42977728204395831a9e0ec107cf72a55..606d7065f8f8fece77a8f7f2a9490a8b4ff5c56e 100644 (file)
@@ -1,6 +1,6 @@
---- perl-5.10.0/Makefile.SH.orig       2008-01-09 21:37:11.870736307 +0000
-+++ perl-5.10.0/Makefile.SH    2008-01-09 22:47:51.579350787 +0000
-@@ -124,7 +124,7 @@
+--- perl-5.10.1/Makefile.SH.orig       2009-08-25 08:26:10.000000000 +0200
++++ perl-5.10.0/Makefile.SH    2009-08-25 08:32:41.000000000 +0200
+@@ -160,7 +160,7 @@
            # INSTALL file, under "Building a shared perl library".
            # If there is no pre-existing $libperl, we don't need
            # to do anything further.
@@ -9,7 +9,7 @@
                rm -f preload
                cat <<'EOT' > preload
  #! /bin/sh
-@@ -135,7 +135,7 @@
+@@ -171,7 +171,7 @@
  EOT
                chmod 755 preload
                ldlibpth="$ldlibpth `pwd`/preload `pwd`/$libperl"
            ;;
        os390)  test -f /bin/env && ldlibpth="/bin/env $ldlibpth"
                ;;
-@@ -581,14 +581,16 @@
- Makefile: $Makefile_s
- !GROK!THIS!
- else
--      $spitshell >>Makefile <<'!NO!SUBS!'
+@@ -728,14 +728,16 @@
+ !NO!SUBS!
+               ;;
+     esac
+-      $spitshell >>$Makefile <<'!NO!SUBS!'
 -$(LIBPERL): $& $(obj) $(DYNALOADER) $(LIBPERLEXPORT)
-+      $spitshell >>Makefile <<!NO!SUBS!
++      $spitshell >>$Makefile <<!NO!SUBS!
 +LIBPERL_SONAME=\$(LIBPERL).$version
 +\$(LIBPERL): \$& \$(obj) \$(DYNALOADER) \$(LIBPERLEXPORT)
  !NO!SUBS!
        case "$useshrplib" in
        true)
-               $spitshell >>Makefile <<'!NO!SUBS!'
+               $spitshell >>$Makefile <<'!NO!SUBS!'
 -      rm -f $@
 -      $(LD) -o $@ $(SHRPLDFLAGS) $(obj) $(DYNALOADER) $(libs)
 +      rm -f $@ $(LIBPERL_SONAME)
index 97478b520f63f1c0d80da7a875a64f53918fd5a5..a731d80c334c7d12a7fd2ffe41120261180e97cc 100644 (file)
@@ -25,15 +25,14 @@ diff -urN perl-5.10.0.org/Makefile.micro perl-5.10.0/Makefile.micro
  
  # Do not regenerate perly.c and perly.h.
  
-diff -urN perl-5.10.0.org/uconfig.sh perl-5.10.0/uconfig.sh
---- perl-5.10.0.org/uconfig.sh 2007-12-18 11:47:08.000000000 +0100
-+++ perl-5.10.0/uconfig.sh     2008-01-09 14:21:01.327533497 +0100
+--- perl-5.10.1/uconfig.sh.orig        2009-08-25 08:37:36.000000000 +0200
++++ perl-5.10.1/uconfig.sh     2009-08-25 08:43:07.000000000 +0200
 @@ -5,12 +5,7 @@
  afsroot='/afs'
  alignbytes='4'
  aphostname='/bin/hostname'
--archlib='/usr/local/lib/perl5/5.10/unknown'
--archlibexp='/usr/local/lib/perl5/5.10/unknown'
+-archlib='/usr/local/lib/perl5/5.11/unknown'
+-archlibexp='/usr/local/lib/perl5/5.11/unknown'
 -archname='unknown'
  asctime_r_proto='0'
 -bin='/usr/local/bin'
@@ -47,19 +46,19 @@ diff -urN perl-5.10.0.org/uconfig.sh perl-5.10.0/uconfig.sh
  d_alarm='undef'
 -d_archlib='undef'
 +d_archlib='define'
+ d_asctime64='undef'
  d_asctime_r='undef'
  d_atolf='undef'
- d_atoll='undef'
-@@ -221,7 +216,7 @@
+@@ -232,7 +227,7 @@
  d_libm_lib_version='undef'
  d_link='undef'
- d_localtime_r='undef'
+ d_localtime64='undef'
 -d_localtime_r_needs_tzset='undef'
 +d_localtime_r_needs_tzset='define'
+ d_localtime_r='undef'
  d_locconv='undef'
  d_lockf='undef'
- d_longdbl='undef'
-@@ -639,14 +634,10 @@
+@@ -661,14 +656,10 @@
  old_pthread_create_joinable=''
  optimize='-O2'
  orderlib='false'
@@ -69,13 +68,13 @@ diff -urN perl-5.10.0.org/uconfig.sh perl-5.10.0/uconfig.sh
  package='perl5'
  phostname='hostname'
  pidtype=int
--privlib='/usr/local/lib/perl5/5.10'
--privlibexp='/usr/local/lib/perl5/5.10'
+-privlib='/usr/local/lib/perl5/5.11'
+-privlibexp='/usr/local/lib/perl5/5.11'
  procselfexe=''
  prototype='undef'
  ptrsize='4'
-@@ -673,8 +664,6 @@
- sPRIx64='"Lx"'
+@@ -699,8 +690,6 @@
+ sPRIXU64='"LX"'
  sSCNfldbl='"llf"'
  sched_yield='sched_yield()'
 -scriptdir='/usr/local/bin'
This page took 0.065101 seconds and 4 git commands to generate.