]> git.pld-linux.org Git - packages/perl.git/commitdiff
- version 5.10.1
authorradek <radek@pld-linux.org>
Sat, 12 Sep 2009 10:07:23 +0000 (10:07 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- kill the List::Util hack (pointless)

Changed files:
    perl-PerlIO.patch -> 1.4
    perl-attribute_error.patch -> 1.2
    perl-h2ph-includes.patch -> 1.4
    perl-modules -> 1.10
    perl-parameter_passing.patch -> 1.2
    perl-t-syslog.patch -> 1.4
    perl-timer-test.patch -> 1.5
    perl-write-permissions.patch -> 1.5
    perl.spec -> 1.420
    perl_581-noroot_install.patch -> 1.4
    perl_581-soname.patch -> 1.7
    perl_585-microperl_uconfig.patch -> 1.8

12 files changed:
perl-PerlIO.patch [deleted file]
perl-attribute_error.patch [deleted file]
perl-h2ph-includes.patch [deleted file]
perl-modules
perl-parameter_passing.patch [deleted file]
perl-t-syslog.patch
perl-timer-test.patch
perl-write-permissions.patch
perl.spec
perl_581-noroot_install.patch
perl_581-soname.patch
perl_585-microperl_uconfig.patch

diff --git a/perl-PerlIO.patch b/perl-PerlIO.patch
deleted file mode 100644 (file)
index 0d79255..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur perl-5.10.0.org/ext/PerlIO/via/via.xs perl-5.10.0/ext/PerlIO/via/via.xs
---- perl-5.10.0.org/ext/PerlIO/via/via.xs      2007-12-18 11:47:07.000000000 +0100
-+++ perl-5.10.0/ext/PerlIO/via/via.xs  2008-08-10 00:35:51.367506014 +0200
-@@ -89,7 +89,7 @@
-           if (!s->fh) {
-               GV *gv = newGVgen(HvNAME_get(s->stash));
-               GvIOp(gv) = newIO();
--              s->fh = newRV_noinc((SV *) gv);
-+              s->fh = newRV((SV *) gv);
-               s->io = GvIOp(gv);
-           }
-           IoIFP(s->io) = PerlIONext(f);
diff --git a/perl-attribute_error.patch b/perl-attribute_error.patch
deleted file mode 100644 (file)
index 60b4a5d..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
---- perl-5.10.0/t/comp/require.t.orig  2007-12-18 11:47:08.000000000 +0100
-+++ perl-5.10.0/t/comp/require.t       2008-12-13 14:24:44.344895352 +0100
-@@ -15,7 +15,7 @@
- my $Is_EBCDIC = (ord('A') == 193) ? 1 : 0;
- my $Is_UTF8   = (${^OPEN} || "") =~ /:utf8/;
--my $total_tests = 49;
-+my $total_tests = 50;
- if ($Is_EBCDIC || $Is_UTF8) { $total_tests -= 3; }
- print "1..$total_tests\n";
-@@ -258,6 +258,20 @@
-     }
- }
-+#  [perl #49472] Attributes + Unkown Error
-+
-+{
-+    do_require
-+      'use strict;sub MODIFY_CODE_ATTRIBUTE{} sub f:Blah {$nosuchvar}';
-+    my $err = $@;
-+    $err .= "\n" unless $err =~ /\n$/;
-+    unless ($err =~ /Global symbol "\$nosuchvar" requires /) {
-+      $err =~ s/^/# /mg;
-+      print "${err}not ";
-+    }
-+    print "ok ", ++$i, " [perl #49472]\n";
-+}
-+
- ##########################################
- # What follows are UTF-8 specific tests. #
- # Add generic tests before this point.   #
---- perl-5.10.0/toke.c.orig    2007-12-18 11:47:08.000000000 +0100
-+++ perl-5.10.0/toke.c 2008-12-13 14:24:47.805309079 +0100
-@@ -692,6 +692,7 @@
- #else
-     parser->nexttoke = 0;
- #endif
-+    parser->error_count = oparser ? oparser->error_count : 0;
-     parser->copline = NOLINE;
-     parser->lex_state = LEX_NORMAL;
-     parser->expect = XSTATE;
diff --git a/perl-h2ph-includes.patch b/perl-h2ph-includes.patch
deleted file mode 100644 (file)
index 84a6e97..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
---- perl-5.10.0/utils/h2ph.PL.orig     2007-12-18 11:47:08.000000000 +0100
-+++ perl-5.10.0/utils/h2ph.PL  2008-02-10 14:01:47.206525485 +0100
-@@ -717,6 +717,7 @@
-     return if ($file eq "-");
-+    (my $filedir = $file) =~ s/[^\/]*$//;
-     open HEADER, $file or return;
-         while (defined($line = <HEADER>)) {
-             while (/\\$/) { # Handle continuation lines
-@@ -726,6 +727,8 @@
-             if ($line =~ /^#\s*include\s+<(.*?)>/) {
-                 push(@ARGV, $1) unless $Is_converted{$1};
-+            } elsif ($line =~ /^#\s*include\s+\"(.*?)\"/) {
-+                push(@ARGV, $filedir . $1) unless $Is_converted{$filedir . $1};
-             }
-         }
-     close HEADER;
index 39d31d6e75862b70884f9a37422c3184738cd013..28b4a9c7382046fe9368f91181c36442876f6720 100644 (file)
@@ -1,53 +1,55 @@
-# Module versions from Perl 5.10.0 distribution.
-Encode = 2.23
-File::Compare = 1.1005
-File::Spec = 3.2501
-File::Temp = 0.18
-IO = 1.23_01
-PerlIO::via::QuotedPrint = 0.06
-Safe = 2.12
-Socket = 1.80
-Tie::File = 0.97_02
-CPAN = 1.9205
-Devel::DProf = 20050603.00
-Devel::PPPort = 3.13
-Devel::Peek = 1.03
-ExtUtils::Embed = 1.27
-ExtUtils::MakeMaker = 6.42
-Attribute::Handlers = 0.79
-CGI = 3.29
+# Module versions from Perl 5.10.1 distribution.
+Attribute::Handlers = 0.85
+CGI = 3.43
+CPAN = 1.9402
 Class::ISA = 0.33
-Digest = 1.15
-Digest::MD5 = 2.36_01
-Filter::Simple = 0.82
-FindBin = 1.49
-GDBM_File = 1.08
+Devel::DProf = 20080331.00
+Devel::PPPort = 3.19
+Devel::Peek = 1.04
+Digest = 1.16
+Digest::MD5 = 2.39
+Encode = 2.35
+ExtUtils::Embed = 1.28
+ExtUtils::MakeMaker = 6.55_02
+File::Compare = 1.1006
+File::Spec = 3.3
+File::Temp = 0.22
+Filter::Simple = 0.84
+FindBin = 1.50
+GDBM_File = 1.09
 Hash::Util = 0.07
 I18N::LangTags = 0.35
-IPC::SysV = 1.05
-Locale::Maketext = 1.12
-MIME::Base64 = 3.07_01
-Math::BigInt = 1.88
-Math::BigRat = 0.21
-Math::Trig = 1.04
-Memoize = 1.01_02
-Module::Build = 0.280801
-NEXT = 0.60_01
+IO = 1.25
+IPC::SysV = 2.01
+Locale::Maketext = 1.13
+MIME::Base64 = 3.08
+Math::BigInt = 1.89
+Math::BigRat = 0.22
+Math::Trig = 1.2
+Memoize = 1.01_03
+Module::Build = 0.340201
+NEXT = 0.64
+Parse::CPAN::Meta = 1.39
+PerlIO::via::QuotedPrint = 0.06
 Pod::LaTeX = 0.58
-Pod::Parser = 1.35
-Storable = 2.18
-Term::ANSIColor = 1.12
+Pod::Parser = 1.37
+Safe = 2.18
+Socket = 1.82
+Storable = 2.20
+Term::ANSIColor = 2.00
 Term::Cap = 1.12
-Test = 1.25
-Test::Harness = 2.64
-Test::Simple = 0.72
+Test = 1.25_02
+Test::Harness = 3.17
+Test::Simple = 0.92
 Text::Balanced = 2.0.0
-Text::ParseWords = 3.26
+Text::ParseWords = 3.27
 Text::Soundex = 3.03
-Text::Tabs = 2007.1117
-Time::HiRes = 1.9711
-UNIVERSAL = 1.04
+Text::Tabs = 2009.0305
+Tie::File = 0.97_02
+Time::HiRes = 1.9719
+UNIVERSAL = 1.05
 Unicode::Collate = 0.52
-Unicode::Normalize = 1.02
+Unicode::Normalize = 1.03
+autodie = 2.06_01
 libnet = 1.22
-version = 0.74
+version = 0.77
diff --git a/perl-parameter_passing.patch b/perl-parameter_passing.patch
deleted file mode 100644 (file)
index 49969e8..0000000
+++ /dev/null
@@ -1,151 +0,0 @@
-commit fafafbaf705adfdf05ff97b6ab5149ba4ee3c039
-Author: Rick Delaney <rick@consumercontact.com>
-Date:   Sun Jan 6 09:14:39 2008 -0500
-
-    Big slowdown in 5.10 @_ parameter passing
-    Message-ID: <20080106191439.GF13935@bort.ca>
-    
-    p4raw-id: //depot/perl@32891
-
-diff --git a/op.c b/op.c
-index a732aa4..af52a3a 100644
---- a/op.c
-+++ b/op.c
-@@ -3992,6 +3992,7 @@ Perl_newASSIGNOP(pTHX_ I32 flags, OP *left, I32 optype, OP *right)
-       static const char no_list_state[] = "Initialization of state variables"
-           " in list context currently forbidden";
-       OP *curop;
-+      bool maybe_common_vars = TRUE;
-       PL_modcount = 0;
-       /* Grandfathering $[ assignment here.  Bletch.*/
-@@ -4009,6 +4010,65 @@ Perl_newASSIGNOP(pTHX_ I32 flags, OP *left, I32 optype, OP *right)
-       o = newBINOP(OP_AASSIGN, flags, list(force_list(right)), curop);
-       o->op_private = (U8)(0 | (flags >> 8));
-+      if ((left->op_type == OP_LIST
-+           || (left->op_type == OP_NULL && left->op_targ == OP_LIST)))
-+      {
-+          OP* lop = ((LISTOP*)left)->op_first;
-+          maybe_common_vars = FALSE;
-+          while (lop) {
-+              if (lop->op_type == OP_PADSV ||
-+                  lop->op_type == OP_PADAV ||
-+                  lop->op_type == OP_PADHV ||
-+                  lop->op_type == OP_PADANY) {
-+                  if (!(lop->op_private & OPpLVAL_INTRO))
-+                      maybe_common_vars = TRUE;
-+
-+                  if (lop->op_private & OPpPAD_STATE) {
-+                      if (left->op_private & OPpLVAL_INTRO) {
-+                          /* Each variable in state($a, $b, $c) = ... */
-+                      }
-+                      else {
-+                          /* Each state variable in
-+                             (state $a, my $b, our $c, $d, undef) = ... */
-+                      }
-+                      yyerror(no_list_state);
-+                  } else {
-+                      /* Each my variable in
-+                         (state $a, my $b, our $c, $d, undef) = ... */
-+                  }
-+              } else if (lop->op_type == OP_UNDEF ||
-+                         lop->op_type == OP_PUSHMARK) {
-+                  /* undef may be interesting in
-+                     (state $a, undef, state $c) */
-+              } else {
-+                  /* Other ops in the list. */
-+                  maybe_common_vars = TRUE;
-+              }
-+              lop = lop->op_sibling;
-+          }
-+      }
-+      else if ((left->op_private & OPpLVAL_INTRO)
-+              && (   left->op_type == OP_PADSV
-+                  || left->op_type == OP_PADAV
-+                  || left->op_type == OP_PADHV
-+                  || left->op_type == OP_PADANY))
-+      {
-+          maybe_common_vars = FALSE;
-+          if (left->op_private & OPpPAD_STATE) {
-+              /* All single variable list context state assignments, hence
-+                 state ($a) = ...
-+                 (state $a) = ...
-+                 state @a = ...
-+                 state (@a) = ...
-+                 (state @a) = ...
-+                 state %a = ...
-+                 state (%a) = ...
-+                 (state %a) = ...
-+              */
-+              yyerror(no_list_state);
-+          }
-+      }
-+
-       /* PL_generation sorcery:
-        * an assignment like ($a,$b) = ($c,$d) is easier than
-        * ($a,$b) = ($c,$a), since there is no need for temporary vars.
-@@ -4023,7 +4083,7 @@ Perl_newASSIGNOP(pTHX_ I32 flags, OP *left, I32 optype, OP *right)
-        * to store these values, evil chicanery is done with SvUVX().
-        */
--      {
-+      if (maybe_common_vars) {
-           OP *lastop = o;
-           PL_generation++;
-           for (curop = LINKLIST(o); curop != o; curop = LINKLIST(curop)) {
-@@ -4084,54 +4144,6 @@ Perl_newASSIGNOP(pTHX_ I32 flags, OP *left, I32 optype, OP *right)
-               o->op_private |= OPpASSIGN_COMMON;
-       }
--      if ((left->op_type == OP_LIST
--           || (left->op_type == OP_NULL && left->op_targ == OP_LIST))) {
--          OP* lop = ((LISTOP*)left)->op_first;
--          while (lop) {
--              if (lop->op_type == OP_PADSV ||
--                  lop->op_type == OP_PADAV ||
--                  lop->op_type == OP_PADHV ||
--                  lop->op_type == OP_PADANY) {
--                  if (lop->op_private & OPpPAD_STATE) {
--                      if (left->op_private & OPpLVAL_INTRO) {
--                          /* Each variable in state($a, $b, $c) = ... */
--                      }
--                      else {
--                          /* Each state variable in
--                             (state $a, my $b, our $c, $d, undef) = ... */
--                      }
--                      yyerror(no_list_state);
--                  } else {
--                      /* Each my variable in
--                         (state $a, my $b, our $c, $d, undef) = ... */
--                  }
--              } else {
--                  /* Other ops in the list. undef may be interesting in
--                     (state $a, undef, state $c) */
--              }
--              lop = lop->op_sibling;
--          }
--      }
--      else if (((left->op_private & (OPpLVAL_INTRO | OPpPAD_STATE))
--                  == (OPpLVAL_INTRO | OPpPAD_STATE))
--              && (   left->op_type == OP_PADSV
--                  || left->op_type == OP_PADAV
--                  || left->op_type == OP_PADHV
--                  || left->op_type == OP_PADANY))
--      {
--          /* All single variable list context state assignments, hence
--             state ($a) = ...
--             (state $a) = ...
--             state @a = ...
--             state (@a) = ...
--             (state @a) = ...
--             state %a = ...
--             state (%a) = ...
--             (state %a) = ...
--          */
--          yyerror(no_list_state);
--      }
--
-       if (right && right->op_type == OP_SPLIT && !PL_madskills) {
-           OP* tmpop = ((LISTOP*)right)->op_first;
-           if (tmpop && (tmpop->op_type == OP_PUSHRE)) {
index c41b5a33db981c5c713d95f91266c0f28ab085cc..63adba46d62f8bdbd904f15578d37f8f2fd71563 100644 (file)
@@ -1,5 +1,5 @@
---- perl-5.10.0/ext/Sys/Syslog/t/syslog.t~     2008-02-26 07:24:29.000000000 +0000
-+++ perl-5.10.0/ext/Sys/Syslog/t/syslog.t      2008-02-26 07:24:34.000000000 +0000
+--- perl-5.10.0/ext/Sys-Syslog/t/syslog.t~     2008-02-26 07:24:29.000000000 +0000
++++ perl-5.10.0/ext/Sys-Syslog/t/syslog.t      2008-02-26 07:24:34.000000000 +0000
 @@ -201,7 +201,11 @@
          }
      }
index 95cd45ce780cf2cf2ff98862f183539a9c47e83b..e82e0ce9bab3583bcd6c8a76c65a0feb37d8b354 100644 (file)
@@ -1,5 +1,5 @@
---- perl-5.8.8/ext/Time/HiRes/t/HiRes.t~       2005-12-17 20:20:26.000000000 +0100
-+++ perl-5.8.8/ext/Time/HiRes/t/HiRes.t        2007-02-11 00:06:42.000000000 +0100
+--- perl-5.8.8/ext/Time-HiRes/t/HiRes.t~       2005-12-17 20:20:26.000000000 +0100
++++ perl-5.8.8/ext/Time-HiRes/t/HiRes.t        2007-02-11 00:06:42.000000000 +0100
 @@ -113,7 +113,7 @@
  # completes fine with (say) 30% slosh, and fail otherwise.  If you do that,
  # consider changing over to test.pl at the same time.
index 4004ba77f8cf9c1f2be721b22885064d9a921f18..3df48c7ac563ee9d5f792a77af379482398fd7a4 100644 (file)
@@ -1,15 +1,15 @@
---- ExtUtils-MakeMaker-6.30.orig/lib/ExtUtils/Install.pm       2005-03-22 04:30:24.000000000 +0000
-+++ ExtUtils-MakeMaker-6.30.write-permissions/lib/ExtUtils/Install.pm  2006-10-30 16:14:28.000000000 +0000
-@@ -666,7 +666,7 @@
-             utime($atime,$mtime + $Is_VMS,$targetfile) unless $nonono>1;
+--- perl-5.10.1/lib/ExtUtils/Install.pm.orig   2009-08-03 21:36:03.000000000 +0200
++++ perl-5.10.1/lib/ExtUtils/Install.pm        2009-09-12 10:07:06.181527344 +0200
+@@ -813,7 +813,7 @@
+                 utime($atime,$mtime + $Is_VMS,$targetfile) unless $dry_run>1;
  
  
--            $mode = 0444 | ( $mode & 0111 ? 0111 : 0 );
-+            $mode = 0644 | ( $mode & 0111 ? 0111 : 0 );
-             $mode = $mode | 0222
-                 if $realtarget ne $targetfile;
-             _chmod( $mode, $targetfile, $verbose );
-@@ -1018,7 +1018,7 @@
+-                $mode = 0444 | ( $mode & 0111 ? 0111 : 0 );
++                $mode = 0644 | ( $mode & 0111 ? 0111 : 0 );
+                 $mode = $mode | 0222
+                     if $realtarget ne $targetfile;
+                 _chmod( $mode, $targetfile, $verbose );
+@@ -1215,7 +1215,7 @@
          }
          my($mode,$atime,$mtime) = (stat $from)[2,8,9];
          utime($atime,$mtime+$Is_VMS,$to);
@@ -18,4 +18,3 @@
          next unless $from =~ /\.pm$/;
          _autosplit($to,$autodir);
      }
-
index 84f67b7cf058ff8c5b3f0add8f9252d9a07fb9a8..6af95e1d5b14a1e0d36d846e6cac0edb12f01a9a 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -42,8 +42,8 @@
 %define                perl_modver()           %([ -f %{SOURCE3} ] && awk -vp=%1 '$1 == p{print $3}' %{SOURCE3} || echo ERROR)
 %define                perl_modversion()       %([ -f %{SOURCE3} ] && awk -vp=%1 '$1 == p{m=$1; gsub(/::/, "-", m); printf("perl-%s = %s\\n", m, $3)}END{if (!m) printf("# Error looking up [%s]\\n", p)}' %{SOURCE3} || echo ERROR)
 
-%define                ver     5.10.0
-%define                rel     20
+%define                ver     5.10.1
+%define                rel     1
 Summary:       Practical Extraction and Report Language (Perl)
 Summary(cs.UTF-8):     Programovací jazyk Perl
 Summary(da.UTF-8):     Programmeringssproget Perl
@@ -72,7 +72,7 @@ Epoch:                1
 License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
 Source0:       http://www.cpan.org/src/%{name}-%{ver}.tar.gz
-# Source0-md5: d2c39b002ebfd2c3c5dba589365c5a71
+# Source0-md5: b9b2fdb957f50ada62d73f43ee75d044
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: de47d7893f49ad7f41ba69c78511c0db
 Source2:       %{name}.prov
@@ -85,11 +85,7 @@ Patch4:              %{name}-test-noproc.patch
 Patch5:                %{name}_585-microperl_uconfig.patch
 Patch6:                %{name}-write-permissions.patch
 Patch7:                %{name}-timer-test.patch
-Patch8:                %{name}-h2ph-includes.patch
 Patch9:                %{name}-t-syslog.patch
-Patch10:       %{name}-PerlIO.patch
-Patch11:       %{name}-attribute_error.patch
-Patch12:       %{name}-parameter_passing.patch
 URL:           http://dev.perl.org/perl5/
 %ifarch ppc
 # gcc 3.3.x miscompiles pp_hot.c
@@ -105,7 +101,7 @@ Requires:   %{name}-base = %{epoch}:%{ver}-%{release}
 Requires:      %{name}-modules = %{epoch}:%{ver}-%{release}
 Suggests:      %{name}-doc-reference = %{epoch}:%{ver}-%{release}
 Suggests:      perldoc
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+BuildRoot:     %{tmpdir}/%{name}-%{ver}-root-%(id -u -n)
 
 %define                __perl          %{_builddir}/perl-%{ver}/runperl
 %define                __perl_provides %{__perl} %{SOURCE2}
@@ -397,6 +393,7 @@ Provides:   %perl_modversion Math::BigRat
 Provides:      %perl_modversion Math::Trig
 Provides:      %perl_modversion Memoize
 Provides:      %perl_modversion NEXT
+Provides:      %perl_modversion Parse::CPAN::Meta
 Provides:      %perl_modversion Pod::LaTeX
 Provides:      %perl_modversion Pod::Parser
 Provides:      %perl_modversion Storable
@@ -658,11 +655,7 @@ z biblioteki GNU gdbm.
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
-%patch8 -p1
 %patch9 -p1
-%patch10 -p1
-%patch11 -p1
-%patch12 -p1
 
 %build
 
@@ -698,15 +691,6 @@ sh Configure \
        -%{?with_threads:D}%{!?with_threads:U}usethreads \
        -Duselargefiles
 
-## {Scalar,List}::Util should be in perl_archlib (it's a bit tricky and should
-## probably be done in %%prep, but then Configure would complain (->MANIFEST))
-mv ext/List/Util/lib/List/Util.pm ext/List/Util
-%{__rm} ext/List/Util/Makefile.PL
-cat <<'EOF' > ext/List/Util/Makefile.PL
-use ExtUtils::MakeMaker;
-WriteMakefile(NAME=>"List::Util", VERSION_FROM=>"Util.pm", DEFINE=>"-DPERL_EXT");
-EOF
-
 %{__make} \
        LIBPERL_SONAME=libperl.so.%{abi} \
        LDDLFLAGS="%{rpmcflags} -shared"
@@ -819,7 +803,8 @@ if [ ! -f installed.stamp ]; then
 
        install -d doc-base/{Getopt/Long,Switch} \
                doc-devel/ExtUtils \
-               doc-modules/{Attribute/Handlers,Filter/Simple,I18N/LangTags,Locale/{Codes,Maketext},Memoize,NEXT,Net/Ping,Term/ANSIColor,Test/Simple,Text/{Balanced,TabsWrap},Unicode/Collate,unicore}
+               doc-modules/{Attribute/Handlers,Filter/Simple,I18N/LangTags,Locale/{Codes,Maketext},Memoize,NEXT} \
+               doc-modules/{Net/Ping,Term/ANSIColor,Test/Simple,Text/{Balanced,TabsWrap},Unicode/Collate,unicore}
 
        # needed only for tests
        %{__rm} $RPM_BUILD_ROOT%{perl_privlib}/Unicode/Collate/keys.txt
@@ -870,7 +855,7 @@ for m in $(awk '!/^#/ && !/^$/{print $1}' %{SOURCE3}); do
                v=$(awk '/^libnet /{print $2; exit}' lib/Net/Changes)
                ;;
        *)
-               v=$(%{__perl} -M$m -e "print \$$m::VERSION" )
+               v=$(%{__perl} -M$m -e "print $m->VERSION" )
                ;;
        esac
        echo "$m = $v" >> perl-modules
@@ -892,6 +877,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc README AUTHORS
+%attr(755,root,root) %{_bindir}/perlthanks
 
 %files libs
 %defattr(644,root,root,755)
@@ -916,6 +902,8 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{perl_archlib}/auto
 
 ## pragmas
+%{perl_privlib}/autodie*
+%{_mandir}/man3/autodie*
 %{perl_privlib}/base.pm
 %{_mandir}/man3/base.*
 %{perl_privlib}/constant.pm
@@ -928,8 +916,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/fields.*
 %{perl_privlib}/integer.pm
 %{_mandir}/man3/integer.*
-%{perl_privlib}/overload.pm
-%{_mandir}/man3/overload.*
+%{perl_privlib}/overload*
+%{_mandir}/man3/overload*
+%{perl_privlib}/parent.pm
+%{_mandir}/man3/parent.*
 %{perl_privlib}/sort.pm
 %{_mandir}/man3/sort.*
 %{perl_privlib}/strict.pm
@@ -961,6 +951,8 @@ rm -rf $RPM_BUILD_ROOT
 %{perl_privlib}/IPC
 %{_mandir}/man3/IPC::Open*
 %{_mandir}/man3/IPC::Cmd*
+%{perl_privlib}/Safe*
+%{_mandir}/man3/Safe*
 %{perl_privlib}/SelectSaver.pm
 %{_mandir}/man3/SelectSaver.*
 %{perl_privlib}/Symbol.pm
@@ -976,8 +968,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/DynaLoader*
 %{perl_archlib}/Errno*
 %{_mandir}/man3/Errno*
-%{perl_archlib}/Safe*
-%{_mandir}/man3/Safe*
 %{perl_archlib}/XSLoader*
 %{_mandir}/man3/XSLoader*
 
@@ -1080,6 +1070,7 @@ rm -rf $RPM_BUILD_ROOT
 %{perl_archlib}/O.*
 %{_mandir}/man3/O.*
 
+%{perl_privlib}/B
 %{perl_archlib}/B
 %{perl_archlib}/B.pm
 %dir %{perl_archlib}/auto/B
@@ -1160,8 +1151,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/less.*
 %{perl_privlib}/locale.pm
 %{_mandir}/man3/locale.*
-%{perl_privlib}/mro.pm
-%{_mandir}/man3/mro.*
 %{perl_privlib}/open.pm
 %{_mandir}/man3/open.*
 %{perl_privlib}/sigtrap.pm
@@ -1169,12 +1158,15 @@ rm -rf $RPM_BUILD_ROOT
 %{perl_privlib}/utf8.pm
 %{_mandir}/man3/utf8.*
 %{perl_privlib}/version.pm
-%{_mandir}/man3/version.*
+%{_mandir}/man3/version*
 
 %{perl_archlib}/attrs.pm
 %dir %{perl_archlib}/auto/attrs
 %attr(755,root,root) %{perl_archlib}/auto/attrs/*.so
 %{_mandir}/man3/attrs.*
+%{perl_archlib}/mro.pm
+%attr(755,root,root) %{perl_archlib}/auto/mro/*.so
+%{_mandir}/man3/mro.*
 %{perl_archlib}/re.pm
 %dir %{perl_archlib}/auto/re
 %attr(755,root,root) %{perl_archlib}/auto/re/*.so
@@ -1209,10 +1201,10 @@ rm -rf $RPM_BUILD_ROOT
 %{perl_archlib}/Compress
 %dir %{perl_archlib}/auto/Compress
 %dir %{perl_archlib}/auto/Compress/Raw
-%dir %{perl_archlib}/auto/Compress/Raw/Zlib
-%attr(755,root,root) %{perl_archlib}/auto/Compress/Raw/Zlib/*.so
-%{perl_archlib}/auto/Compress/Raw/Zlib/*.ix
-%dir %{perl_archlib}/auto/Compress/Zlib
+%dir %{perl_archlib}/auto/Compress/Raw/*/
+%attr(755,root,root) %{perl_archlib}/auto/Compress/Raw/*/*.so
+%{perl_archlib}/auto/Compress/Raw/*/*.ix
+%dir %{perl_archlib}/auto/Compress/*
 %{perl_archlib}/auto/Compress/Zlib/*.ix
 %{_mandir}/man3/Compress*
 
@@ -1327,6 +1319,8 @@ rm -rf $RPM_BUILD_ROOT
 
 %{perl_privlib}/AnyDBM*
 %{_mandir}/man3/AnyDBM*
+%{perl_privlib}/App
+%{_mandir}/man3/App::Prove*
 %{perl_privlib}/Archive*
 %{_mandir}/man3/Archive*
 %{perl_privlib}/Attribute
@@ -1374,6 +1368,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/Package::*
 %{perl_privlib}/Params
 %{_mandir}/man3/Params::*
+%{perl_privlib}/Parse
+%{_mandir}/man3/Parse::CPAN::Meta*
 %{perl_privlib}/Pod
 %{_mandir}/man3/Pod::*
 %{perl_archlib}/Scalar
@@ -1384,6 +1380,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/SelfLoader.*
 %{perl_privlib}/Shell.*
 %{_mandir}/man3/Shell.*
+%{perl_privlib}/TAP
+%{_mandir}/man3/TAP::*
 # FIXME: README and Changes files
 %{perl_privlib}/Switch.*
 %{_mandir}/man3/Switch.*
@@ -1480,6 +1478,6 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with microperl}
 %files -n microperl
 %defattr(644,root,root,755)
-%doc README.micro Todo.micro
+%doc README.micro
 %attr(755,root,root) %{_bindir}/microperl
 %endif
index 47a50474bbbf14445dae9f8af1252b726349f0cd..13afc642616d9f18e5d16e94ccfd12eeeaad066e 100644 (file)
@@ -1,15 +1,15 @@
---- perl-5.8.1/installperl.orig        Fri Aug 22 12:26:11 2003
-+++ perl-5.8.1/installperl     Fri Aug 22 12:26:28 2003
-@@ -226,7 +226,7 @@
+--- perl-5.10.1/installperl.orig       2009-08-14 00:40:10.000000000 +0200
++++ perl-5.10.1/installperl    2009-09-12 09:56:30.724923937 +0200
+@@ -235,7 +235,7 @@
  
  # Do some quick sanity checks.
  
--if (!$nonono && $d_dosuid && $>) { die "You must run as root to install suidperl\n"; }
-+#if (!$nonono && $d_dosuid && $>) { die "You must run as root to install suidperl\n"; }
+-if (!$opts{notify} && $d_dosuid && $>) { die "You must run as root to install suidperl\n"; }
++#if (!$opts{notify} && $d_dosuid && $>) { die "You must run as root to install suidperl\n"; }
  
     $installbin                || die "No installbin directory in config.sh\n";
- -d $installbin                || mkpath($installbin, $verbose, 0777);
-@@ -361,7 +361,7 @@
+ -d $installbin                || mkpath($installbin, $opts{verbose}, 0777);
+@@ -344,7 +344,7 @@
  safe_unlink("$installbin/s$perl_verbase$ver$exe_ext");
  if ($d_dosuid) {
      copy("suidperl$exe_ext", "$installbin/s$perl_verbase$ver$exe_ext");
index 60e5f8d42977728204395831a9e0ec107cf72a55..72a81b796c865c5170fa6c3e51d7bb0a85767886 100644 (file)
@@ -1,6 +1,6 @@
---- perl-5.10.0/Makefile.SH.orig       2008-01-09 21:37:11.870736307 +0000
-+++ perl-5.10.0/Makefile.SH    2008-01-09 22:47:51.579350787 +0000
-@@ -124,7 +124,7 @@
+--- perl-5.10.1/Makefile.SH.orig       2009-08-03 22:43:30.000000000 +0200
++++ perl-5.10.1/Makefile.SH    2009-09-12 10:03:20.451763024 +0200
+@@ -160,7 +160,7 @@
            # INSTALL file, under "Building a shared perl library".
            # If there is no pre-existing $libperl, we don't need
            # to do anything further.
@@ -9,7 +9,7 @@
                rm -f preload
                cat <<'EOT' > preload
  #! /bin/sh
-@@ -135,7 +135,7 @@
+@@ -171,7 +171,7 @@
  EOT
                chmod 755 preload
                ldlibpth="$ldlibpth `pwd`/preload `pwd`/$libperl"
            ;;
        os390)  test -f /bin/env && ldlibpth="/bin/env $ldlibpth"
                ;;
-@@ -581,14 +581,16 @@
- Makefile: $Makefile_s
- !GROK!THIS!
- else
--      $spitshell >>Makefile <<'!NO!SUBS!'
+@@ -728,14 +728,16 @@
+ !NO!SUBS!
+               ;;
+     esac
+-      $spitshell >>$Makefile <<'!NO!SUBS!'
 -$(LIBPERL): $& $(obj) $(DYNALOADER) $(LIBPERLEXPORT)
 +      $spitshell >>Makefile <<!NO!SUBS!
 +LIBPERL_SONAME=\$(LIBPERL).$version
@@ -30,7 +30,7 @@
  !NO!SUBS!
        case "$useshrplib" in
        true)
-               $spitshell >>Makefile <<'!NO!SUBS!'
+               $spitshell >>$Makefile <<'!NO!SUBS!'
 -      rm -f $@
 -      $(LD) -o $@ $(SHRPLDFLAGS) $(obj) $(DYNALOADER) $(libs)
 +      rm -f $@ $(LIBPERL_SONAME)
index 97478b520f63f1c0d80da7a875a64f53918fd5a5..9a2e7bf549d0f54f6055e479a1f40b2a36cdc73b 100644 (file)
@@ -1,39 +1,11 @@
-diff -urN perl-5.10.0.org/Makefile.micro perl-5.10.0/Makefile.micro
---- perl-5.10.0.org/Makefile.micro     2007-12-18 11:47:07.000000000 +0100
-+++ perl-5.10.0/Makefile.micro 2008-01-09 14:22:14.801222180 +0100
-@@ -39,6 +39,12 @@
- distclean:    clean
-+# not really autoconfigured variables (PLD hack, requires patched uconfig.sh)
-+NRACV = archlib=$(archlib) archlibexp=$(archlibexp) privlib=$(privlib) \
-+      privlibexp=$(privlibexp) archname=$(archname) osname=$(osname) \
-+      bin=$(bin) scriptdir=$(scriptdir) scriptdirexp=$(scriptdirexp) \
-+      usemallocwrap=$(usemallocwrap)
-+
- # The microconfiguration.
- # Cannot use $$ in the command line itself, so using var expansion instead.
-@@ -47,7 +53,9 @@
-       $(PERL) -MConfig -pi -e "s/^((?:short|int|long(?:dbl|long)?|ptr|double|[iun]v|u?quad|[iu]\d+|fpos|lseek)(?:size|type)|byteorder|d_quad|quadkind|use64.+)=.*/\\1='"$(Config)"'/g" uconfig.shx
- regen_uconfig uconfig.h: uconfig.sh
--      $(ENV) CONFIG_SH=uconfig.sh CONFIG_H=uconfig.h sh ./config_h.SH
-+      $(ENV) CONFIG_SH=uconfig.sh CONFIG_H=uconfig.h $(NRACV) sh ./config_h.SH
-+
-+uconfig.h: regen_uconfig
- # Do not regenerate perly.c and perly.h.
-diff -urN perl-5.10.0.org/uconfig.sh perl-5.10.0/uconfig.sh
---- perl-5.10.0.org/uconfig.sh 2007-12-18 11:47:08.000000000 +0100
-+++ perl-5.10.0/uconfig.sh     2008-01-09 14:21:01.327533497 +0100
+--- perl-5.10.1/uconfig.sh.orig        2009-04-19 18:18:52.000000000 +0200
++++ perl-5.10.1/uconfig.sh     2009-09-12 10:05:33.571536125 +0200
 @@ -5,12 +5,7 @@
  afsroot='/afs'
  alignbytes='4'
  aphostname='/bin/hostname'
--archlib='/usr/local/lib/perl5/5.10/unknown'
--archlibexp='/usr/local/lib/perl5/5.10/unknown'
+-archlib='/usr/local/lib/perl5/5.11/unknown'
+-archlibexp='/usr/local/lib/perl5/5.11/unknown'
 -archname='unknown'
  asctime_r_proto='0'
 -bin='/usr/local/bin'
@@ -47,19 +19,19 @@ diff -urN perl-5.10.0.org/uconfig.sh perl-5.10.0/uconfig.sh
  d_alarm='undef'
 -d_archlib='undef'
 +d_archlib='define'
+ d_asctime64='undef'
  d_asctime_r='undef'
  d_atolf='undef'
- d_atoll='undef'
-@@ -221,7 +216,7 @@
+@@ -232,7 +227,7 @@
  d_libm_lib_version='undef'
  d_link='undef'
- d_localtime_r='undef'
+ d_localtime64='undef'
 -d_localtime_r_needs_tzset='undef'
 +d_localtime_r_needs_tzset='define'
+ d_localtime_r='undef'
  d_locconv='undef'
  d_lockf='undef'
- d_longdbl='undef'
-@@ -639,14 +634,10 @@
+@@ -661,14 +656,10 @@
  old_pthread_create_joinable=''
  optimize='-O2'
  orderlib='false'
@@ -69,13 +41,13 @@ diff -urN perl-5.10.0.org/uconfig.sh perl-5.10.0/uconfig.sh
  package='perl5'
  phostname='hostname'
  pidtype=int
--privlib='/usr/local/lib/perl5/5.10'
--privlibexp='/usr/local/lib/perl5/5.10'
+-privlib='/usr/local/lib/perl5/5.11'
+-privlibexp='/usr/local/lib/perl5/5.11'
  procselfexe=''
  prototype='undef'
  ptrsize='4'
-@@ -673,8 +664,6 @@
- sPRIx64='"Lx"'
+@@ -699,8 +690,6 @@
+ sPRIXU64='"LX"'
  sSCNfldbl='"llf"'
  sched_yield='sched_yield()'
 -scriptdir='/usr/local/bin'
This page took 0.118551 seconds and 4 git commands to generate.