]> git.pld-linux.org Git - packages/perl.git/commitdiff
868d3e9256975b483d00311399411519 perl_580-errno_h-parsing.patch
authorradek <radek@pld-linux.org>
Fri, 7 Feb 2003 19:50:01 +0000 (19:50 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
6857cfc36db516cce5a599b782e61354  perl_580-find_provides.patch
5ace60f1f1de2a5680584f42dc24a7a8  perl_580-noroot_install.patch
ebf2de0b3a85322316194ade5101760b  perl_580-perluniintro.patch
a4082d0186269ce2f5e31dcdd735ddca  perl_580-soname.patch
a2c56b0dc0e1f7825c1215167e313be1  perl_580-use-LD_PRELOAD-for-libperl.so.patch

Changed files:
    perl_580-errno_h-parsing.patch -> 1.1
    perl_580-find_provides.patch -> 1.1
    perl_580-noroot_install.patch -> 1.1
    perl_580-perluniintro.patch -> 1.1
    perl_580-soname.patch -> 1.1
    perl_580-use-LD_PRELOAD-for-libperl.so.patch -> 1.1

perl_580-errno_h-parsing.patch [new file with mode: 0644]
perl_580-find_provides.patch [new file with mode: 0644]
perl_580-noroot_install.patch [new file with mode: 0644]
perl_580-perluniintro.patch [new file with mode: 0644]
perl_580-soname.patch [new file with mode: 0644]
perl_580-use-LD_PRELOAD-for-libperl.so.patch [new file with mode: 0644]

diff --git a/perl_580-errno_h-parsing.patch b/perl_580-errno_h-parsing.patch
new file mode 100644 (file)
index 0000000..7b490ba
--- /dev/null
@@ -0,0 +1,17 @@
+diff -urN perl-5.6.1.orig/ext/Errno/Errno_pm.PL perl-5.6.1/ext/Errno/Errno_pm.PL
+--- perl-5.6.1.orig/ext/Errno/Errno_pm.PL      Sun Apr  8 08:09:16 2001
++++ perl-5.6.1/ext/Errno/Errno_pm.PL   Thu Apr 12 20:58:53 2001
+@@ -37,6 +37,13 @@
+             warn "Cannot open '$file'";
+             return;
+       }     
++    } elsif ($^O eq 'linux') {
++      # With the -dM option option, gcc outputs every #define's it finds
++      my $cpp = default_cpp();
++      unless(open(FH, "$cpp -dM < $file |")) {
++            warn "Cannot open '$file'";
++            return;
++      }
+     } else {
+       unless(open(FH,"< $file")) {
+           # This file could be a temporary file created by cppstdin
diff --git a/perl_580-find_provides.patch b/perl_580-find_provides.patch
new file mode 100644 (file)
index 0000000..759b20e
--- /dev/null
@@ -0,0 +1,208 @@
+diff -urN perl-5.6.1/find-perl-provides perl-5.6.1-grabba/find-perl-provides
+--- perl-5.6.1/find-perl-provides      Thu Jan  1 00:00:00 1970
++++ perl-5.6.1-grabba/find-perl-provides       Sun Mar  3 14:41:39 2002
+@@ -0,0 +1,23 @@
++#!/bin/sh
++ulimit -c 0
++
++export LD_LIBRARY_PATH="FPPATH"
++
++filelist=`sed "s/['\"]/\\\&/g"`
++if [ -f __rpm_noautoprovfiles ] ; then
++      for i in `cat __rpm_noautoprovfiles`; do
++              filelist=`echo $filelist | sed "s![[:space:]]*$i[[:space:]]*!!g"`
++      done
++fi
++
++
++echo $filelist|/usr/lib/rpm/find-provides
++provides_perl=`FPPATH/find-perl.prov $filelist`
++if [ -f __rpm_noautoprov ] ; then
++      for i in `cat __rpm_noautoprov`; do
++              provides_perl=`echo $provides_perl | sed "s!\<$i[[:space:]]*!!g"`
++      done
++fi
++
++echo "$provides_perl" | grep -v '^perl(DynaLoader)$'
++
+diff -urN perl-5.6.1/find-perl.prov perl-5.6.1-grabba/find-perl.prov
+--- perl-5.6.1/find-perl.prov  Thu Jan  1 00:00:00 1970
++++ perl-5.6.1-grabba/find-perl.prov   Sun Mar  3 14:37:16 2002
+@@ -0,0 +1,177 @@
++#!FPPATH/perl
++
++# RPM (and it's source code) is covered under two separate licenses.
++
++# The entire code base may be distributed under the terms of the GNU
++# General Public License (GPL), which appears immediately below.
++# Alternatively, all of the source code in the lib subdirectory of the
++# RPM source code distribution as well as any code derived from that
++# code may instead be distributed under the GNU Library General Public
++# License (LGPL), at the choice of the distributor. The complete text
++# of the LGPL appears at the bottom of this file.
++
++# This alternative is allowed to enable applications to be linked
++# against the RPM library (commonly called librpm) without forcing
++# such applications to be distributed under the GPL.
++
++# Any questions regarding the licensing of RPM should be addressed to
++# Erik Troan <ewt@redhat.com>.
++
++# a simple script to print the proper name for perl libraries.
++
++# To save development time I do not parse the perl grammmar but
++# instead just lex it looking for what I want.  I take special care to
++# ignore comments and pod's.
++
++# it would be much better if perl could tell us the proper name of a
++# given script.
++
++# The filenames to scan are either passed on the command line or if
++# that is empty they are passed via stdin.
++
++# If there are lines in the file which match the pattern
++#      (m/^\s*\$VERSION\s*=\s+/)
++# then these are taken to be the version numbers of the modules.
++# Special care is taken with a few known idioms for specifying version
++# numbers of files under rcs/cvs control.
++
++# If there are strings in the file which match the pattern
++#     m/^\s*\$RPM_Provides\s*=\s*["'](.*)['"]/i
++# then these are treated as additional names which are provided by the
++# file and are printed as well.
++
++# I plan to rewrite this in C so that perl is not required by RPM at
++# build time.
++
++# by Ken Estes Mail.com kestes@staff.mail.com
++
++if ("@ARGV") {
++  foreach (@ARGV) {
++     if (! m=(/(doc|usr/src)/|\.(so|gz|ph|pod|h|html|al|ix)$)=) {
++      process_file($_) if -f "$_";
++    }
++  }
++} else {
++
++  # notice we are passed a list of filenames NOT as common in unix the
++  # contents of the file.
++
++  foreach (<>) {
++     if (! m=(/(doc|usr/src)/|\.(so|gz|ph|pod|h|html|al|ix)$)=) {
++      process_file($_) if -f "$_";
++    }
++  }
++}
++
++
++foreach $module (sort keys %require) {
++  if (length($require{$module}) == 0) {
++    print "perl($module)\n";
++  } else {
++
++    # I am not using rpm3.0 so I do not want spaces arround my
++    # operators. Also I will need to change the processing of the
++    # $RPM_* vairable when I upgrade.
++
++    print "perl($module) = $require{$module}\n";
++  }
++}
++
++exit 0;
++
++
++
++sub process_file {
++
++  my ($file) = @_;
++  chomp $file;
++  
++  open(FILE, "<$file")||
++    die("$0: Could not open file: '$file' : $!\n");
++
++  my ($package, $version) = ();
++
++  while (<FILE>) {
++    
++    # skip the documentation
++
++    # we should not need to have item in this if statement (it
++    # properly belongs in the over/back section) but people do not
++    # read the perldoc.
++
++    if ( (m/^=(head1|head2|pod|item)/) .. (m/^=(cut)/ || eof) ) {
++      next;
++    }
++    
++    if ( (m/^=(over)/) .. (m/^=(back)/ || eof) ) {
++      next;
++    }
++    
++    # skip the data section
++    if (m/^__(DATA|END)__$/) {
++      last;
++    }
++
++    # not everyone puts the package name of the file as the first
++    # package name so we report all namespaces as if they were
++    # provided packages (really ugly).
++
++    if (m/^\s*package\s+([_:a-zA-Z0-9]+)\s*;/ && !$require{$1}) {
++      $package=$1;
++      undef $version;
++      $require{$package}=undef;
++    }
++
++    # after we found the package name take the first assignment to
++    # $VERSION as the version number. Exporter requires that the
++    # variable be called VERSION so we are safe.
++
++    # here are examples of VERSION lines from the perl distribution
++
++    #FindBin.pm:$VERSION = $VERSION = sprintf("%d.%02d", q$Revision$ =~ /(\d+)\.(\d+)/);
++    #ExtUtils/Install.pm:$VERSION = substr q$Revision$, 10;
++    #CGI/Apache.pm:$VERSION = (qw$Revision$)[1];
++    #DynaLoader.pm:$VERSION = $VERSION = "1.03";     # avoid typo warning
++    #Cwd.pm:our $VERSION = '2.04';
++
++    # here is example of VERSION line from RPC::PlClient module
++
++    # RPC/PlClient.pm:$RPC::PlClient::VERSION = '0.2016';
++
++    if ( 
++      ($package) && 
++      (m/^\s*(our)?\s*\$(${package}::)?VERSION\s*=/)
++       ) {
++
++      # first see if the version string contains the string
++      # '$Revision' this often causes bizzare strings and is the most
++      # common method of non static numbering.
++
++      if (m/(\$Revision: (\d+[.0-9]+))/) {
++      $version= $2; 
++      } elsif (m/[\'\"]?(\d+[.0-9]+)[\'\"]?/) {
++      
++      # look for a static number hard coded in the script
++      
++      $version= $1; 
++      }
++      $require{$package}=$version;
++    }
++    
++    # Each keyword can appear multiple times.  Don't
++    #  bother with datastructures to store these strings,
++    #  if we need to print it print it now.
++      
++    if ( m/^\s*\$RPM_Provides\s*=\s*["'](.*)['"]/i) {
++      foreach $_ (spit(/\s+/, $1)) {
++      print "$_\n";
++      }
++    }
++
++  }
++
++  close(FILE)||
++    die("$0: Could not close file: '$file' : $!\n");
++
++  return ;
++}
diff --git a/perl_580-noroot_install.patch b/perl_580-noroot_install.patch
new file mode 100644 (file)
index 0000000..231da6a
--- /dev/null
@@ -0,0 +1,20 @@
+--- perl-5.6.0/installperl.pius        Wed Mar  8 13:22:41 2000
++++ perl-5.6.0/installperl     Sun Jul  2 13:36:20 2000
+@@ -143,8 +143,6 @@
+ # Do some quick sanity checks.
+-if ($d_dosuid && $>) { die "You must run as root to install suidperl\n"; }
+-
+    $installbin                || die "No installbin directory in config.sh\n";
+ -d $installbin                || mkpath($installbin, 1, 0777);
+ -d $installbin                || $nonono || die "$installbin is not a directory\n";
+@@ -224,7 +222,7 @@
+ safe_unlink("$installbin/s$perl_verbase$ver$exe_ext");
+ if ($d_dosuid) {
+     copy("suidperl$exe_ext", "$installbin/s$perl_verbase$ver$exe_ext");
+-    chmod(04711, "$installbin/s$perl_verbase$ver$exe_ext");
++    chmod(0755, "$installbin/s$perl_verbase$ver$exe_ext");
+ }
+ # Install library files.
diff --git a/perl_580-perluniintro.patch b/perl_580-perluniintro.patch
new file mode 100644 (file)
index 0000000..37676a9
--- /dev/null
@@ -0,0 +1,11 @@
+--- pod/perluniintro.pod.orig  Thu Feb  6 12:45:57 2003
++++ pod/perluniintro.pod       Thu Feb  6 12:46:10 2003
+@@ -363,7 +363,7 @@
+ With the C<open> pragma you can use the C<:locale> layer
+-    $ENV{LC_ALL} = $ENV{LANG} = 'ru_RU.KOI8-R';
++    BEGIN { $ENV{LC_ALL} = $ENV{LANG} = 'ru_RU.KOI8-R'; }
+     # the :locale will probe the locale environment variables like LC_ALL
+     use open OUT => ':locale'; # russki parusski
+     open(O, ">koi8");
diff --git a/perl_580-soname.patch b/perl_580-soname.patch
new file mode 100644 (file)
index 0000000..6f9aee7
--- /dev/null
@@ -0,0 +1,14 @@
+--- perl-5.6.1/Makefile.SH~    Sun Apr 15 18:20:15 2001
++++ perl-5.6.1/Makefile.SH     Sun Apr 15 18:36:49 2001
+@@ -429,7 +429,8 @@
+       case "$useshrplib" in
+       true)
+-              $spitshell >>Makefile <<'!NO!SUBS!'
+-      $(LD) -o $@ $(SHRPLDFLAGS) perl$(OBJ_EXT) $(obj)
+-!NO!SUBS!
++              $spitshell >>Makefile <<!GROK!THIS!
++      \$(LD) -o \$(LIBPERL).$version \$(SHRPLDFLAGS) -Wl,-soname,\$(LIBPERL).$version perl\$(OBJ_EXT) \$(obj)
++      ln -sf \$(LIBPERL).$version \$@
++!GROK!THIS!
+               case "$osname" in
+               aix)
diff --git a/perl_580-use-LD_PRELOAD-for-libperl.so.patch b/perl_580-use-LD_PRELOAD-for-libperl.so.patch
new file mode 100644 (file)
index 0000000..105f911
--- /dev/null
@@ -0,0 +1,16 @@
+--- perl-5.6.0/Makefile.SH.pix Sat Mar 11 11:05:24 2000
++++ perl-5.6.0/Makefile.SH     Fri Dec 15 07:29:42 2000
+@@ -30,12 +30,7 @@
+ true)
+       # Prefix all runs of 'miniperl' and 'perl' with 
+       # $ldlibpth so that ./perl finds *this* shared libperl.
+-      case "$LD_LIBRARY_PATH" in
+-      '')
+-              ldlibpth="LD_LIBRARY_PATH=`pwd`";;
+-      *)
+-              ldlibpth="LD_LIBRARY_PATH=`pwd`:${LD_LIBRARY_PATH}";;
+-      esac
++        ldlibpth="LD_PRELOAD=`pwd`/libperl.so"
+       pldlflags="$cccdlflags"
+       case "${osname}${osvers}" in
This page took 0.065327 seconds and 4 git commands to generate.