]> git.pld-linux.org Git - packages/perl.git/commitdiff
- updated
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 9 Jan 2008 13:32:34 +0000 (13:32 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    perl-test-noproc.patch -> 1.2
    perl_585-microperl_uconfig.patch -> 1.5

perl-test-noproc.patch
perl_585-microperl_uconfig.patch

index 9f6337f766003f9bc3f4f7416ddfc38ec89722a0..62d22ed627df613706f2630c775fcc5030f730b4 100644 (file)
@@ -1,21 +1,22 @@
 --- perl-5.8.2/ext/threads/t/join.t.orig       Tue Sep 30 19:10:32 2003
 +++ perl-5.8.2/ext/threads/t/join.t    Mon Dec  8 14:49:12 2003
-@@ -93,6 +93,10 @@
+@@ -118,6 +118,10 @@
  
  # We parse ps output so this is OS-dependent.
  if ($^O eq 'linux') {
-+  if (! -d "/proc/$$") {
-+    # proc not mounted? skip.
-+    skip("\$0 check: /proc not mounted?");
-+  } else {
-   # First modify $0 in a subthread.
-   print "# mainthread: \$0 = $0\n";
-   threads->new( sub {
-@@ -123,6 +127,7 @@
-   } else {
-     skip("\$0 check: opening 'ps -f |' failed: $!");
-   }
-+  }
++    if (! -d "/proc/$$") {
++      # proc not mounted? skip.
++      skip("\$0 check: /proc not mounted?");
++    } else {
+     # First modify $0 in a subthread.
+     #print "# mainthread: \$0 = $0\n";
+     threads->create(sub{ #print "# subthread: \$0 = $0\n";
+@@ -148,6 +152,7 @@
+     } else {
+         skip("\$0 check: opening 'ps -f |' failed: $!");
+     }
++    }
  } else {
-   skip("\$0 check: only on Linux");
+     skip("\$0 check: only on Linux");
  }
+
index 17f19a568559fa1048ead17420b5d54f17d12ff7..97478b520f63f1c0d80da7a875a64f53918fd5a5 100644 (file)
@@ -1,18 +1,47 @@
---- perl-5.8.5/uconfig.sh      2004-07-04 23:43:22.000000000 +0200
-+++ perl-5.8.5/uconfig.sh      2004-07-21 20:26:34.639594224 +0200
-@@ -4,11 +4,7 @@
- afs='false'
+diff -urN perl-5.10.0.org/Makefile.micro perl-5.10.0/Makefile.micro
+--- perl-5.10.0.org/Makefile.micro     2007-12-18 11:47:07.000000000 +0100
++++ perl-5.10.0/Makefile.micro 2008-01-09 14:22:14.801222180 +0100
+@@ -39,6 +39,12 @@
+ distclean:    clean
++# not really autoconfigured variables (PLD hack, requires patched uconfig.sh)
++NRACV = archlib=$(archlib) archlibexp=$(archlibexp) privlib=$(privlib) \
++      privlibexp=$(privlibexp) archname=$(archname) osname=$(osname) \
++      bin=$(bin) scriptdir=$(scriptdir) scriptdirexp=$(scriptdirexp) \
++      usemallocwrap=$(usemallocwrap)
++
+ # The microconfiguration.
+ # Cannot use $$ in the command line itself, so using var expansion instead.
+@@ -47,7 +53,9 @@
+       $(PERL) -MConfig -pi -e "s/^((?:short|int|long(?:dbl|long)?|ptr|double|[iun]v|u?quad|[iu]\d+|fpos|lseek)(?:size|type)|byteorder|d_quad|quadkind|use64.+)=.*/\\1='"$(Config)"'/g" uconfig.shx
+ regen_uconfig uconfig.h: uconfig.sh
+-      $(ENV) CONFIG_SH=uconfig.sh CONFIG_H=uconfig.h sh ./config_h.SH
++      $(ENV) CONFIG_SH=uconfig.sh CONFIG_H=uconfig.h $(NRACV) sh ./config_h.SH
++
++uconfig.h: regen_uconfig
+ # Do not regenerate perly.c and perly.h.
+diff -urN perl-5.10.0.org/uconfig.sh perl-5.10.0/uconfig.sh
+--- perl-5.10.0.org/uconfig.sh 2007-12-18 11:47:08.000000000 +0100
++++ perl-5.10.0/uconfig.sh     2008-01-09 14:21:01.327533497 +0100
+@@ -5,12 +5,7 @@
  afsroot='/afs'
  alignbytes='4'
--archlib='/usr/local/lib/perl5/5.9/unknown'
--archlibexp='/usr/local/lib/perl5/5.9/unknown'
+ aphostname='/bin/hostname'
+-archlib='/usr/local/lib/perl5/5.10/unknown'
+-archlibexp='/usr/local/lib/perl5/5.10/unknown'
 -archname='unknown'
  asctime_r_proto='0'
 -bin='/usr/local/bin'
+-binexp='/usr/local/bin'
  byteorder='1234'
  castflags='0'
- charsize='1'
-@@ -36,7 +32,7 @@
+ cf_by='root@localhost'
+@@ -43,7 +38,7 @@
  d_accessx='undef'
  d_aintl='undef'
  d_alarm='undef'
  d_asctime_r='undef'
  d_atolf='undef'
  d_atoll='undef'
-@@ -194,6 +194,7 @@
- d_ldbl_dig='undef'
+@@ -221,7 +216,7 @@
+ d_libm_lib_version='undef'
  d_link='undef'
  d_localtime_r='undef'
+-d_localtime_r_needs_tzset='undef'
 +d_localtime_r_needs_tzset='define'
  d_locconv='undef'
  d_lockf='undef'
  d_longdbl='undef'
-@@ -594,11 +591,8 @@
- obj_ext='.o'
+@@ -639,14 +634,10 @@
+ old_pthread_create_joinable=''
  optimize='-O2'
  orderlib='false'
 -osname='unknown'
+-osvers='unknown'
+ otherlibdirs=' '
+ package='perl5'
  phostname='hostname'
  pidtype=int
--privlib='/usr/local/lib/perl5/5.9'
--privlibexp='/usr/local/lib/perl5/5.9'
+-privlib='/usr/local/lib/perl5/5.10'
+-privlibexp='/usr/local/lib/perl5/5.10'
  procselfexe=''
  prototype='undef'
  ptrsize='4'
-@@ -625,8 +619,6 @@
+@@ -673,8 +664,6 @@
  sPRIx64='"Lx"'
  sSCNfldbl='"llf"'
  sched_yield='sched_yield()'
  seedfunc='srand'
  selectminbits='32'
  selecttype=int
---- perl-5.8.5/Makefile.micro  2004-07-04 23:43:19.000000000 +0200
-+++ perl-5.8.5/Makefile.micro  2004-07-21 20:28:23.168095384 +0200
-@@ -34,10 +34,18 @@
- distclean:    clean
-+# not really autoconfigured variables (PLD hack, requires patched uconfig.sh)
-+NRACV = archlib=$(archlib) archlibexp=$(archlibexp) privlib=$(privlib) \
-+      privlibexp=$(privlibexp) archname=$(archname) osname=$(osname) \
-+      bin=$(bin) scriptdir=$(scriptdir) scriptdirexp=$(scriptdirexp) \
-+      usemallocwrap=$(usemallocwrap)
-+
- # The microconfiguration.
- regen_uconfig:
--      $(ENV) CONFIG_SH=uconfig.sh CONFIG_H=uconfig.h sh ./config_h.SH
-+      $(ENV) CONFIG_SH=uconfig.sh CONFIG_H=uconfig.h $(NRACV) sh ./config_h.SH
-+ 
-+ uconfig.h: regen_uconfig
- # Do not regenerate perly.c and perly.h.
This page took 0.048631 seconds and 4 git commands to generate.