]> git.pld-linux.org Git - packages/perl.git/commitdiff
up to 5.36.0
authorJan Palus <atler@pld-linux.org>
Sun, 21 Aug 2022 10:18:17 +0000 (12:18 +0200)
committerJan Palus <atler@pld-linux.org>
Sun, 21 Aug 2022 10:18:17 +0000 (12:18 +0200)
perl-Destroy-GDBM-NDBM-ODBM-SDBM-_File-objects.patch
perl-modules
perl-modules2
perl.spec
perl_585-microperl_uconfig.patch

index 939465ca2fa5634a772cad089b256daeb0d25e12..b40baee776011aec7cf4be6f81aebc0f12d882c7 100644 (file)
@@ -50,7 +50,7 @@ index 33e08e2..7160f54 100644
        } else {
            RETVAL = NULL;
 @@ -109,15 +111,17 @@ gdbm_DESTROY(db)
-       PREINIT:
+     PREINIT:
        int i = store_value;
      CODE:
 -        if (gdbm_file_close(db)) {
index be8da55606c70764a5a97a54e70e3137f4dea77e..25f8c8601a472f98353fa58cbffee467aaf86442 100644 (file)
@@ -1,82 +1,82 @@
-# Module versions from Perl 5.34.1 distribution.
-Archive::Tar = 2.38
-Attribute::Handlers = 1.01
-CPAN = 2.28
+# Module versions from Perl 5.36.0 distribution.
+Archive::Tar = 2.40
+Attribute::Handlers = 1.02
+CPAN = 2.33
 CPAN::Meta = 2.150010
 CPAN::Meta::YAML = 0.018
-Compress::Raw::Bzip2 = 2.101
-Compress::Raw::Zlib = 2.101
-Compress::Zlib = 2.102
-Devel::PPPort = 3.62
-Devel::Peek = 1.3
-Digest = 1.19
+Compress::Raw::Bzip2 = 2.103
+Compress::Raw::Zlib = 2.105
+Compress::Zlib = 2.106
+Devel::PPPort = 3.68
+Devel::Peek = 1.32
+Digest = 1.20
 Digest::MD5 = 2.58
 Digest::SHA = 6.02
-Encode = 3.0801
+Encode = 3.17
 ExtUtils::CBuilder = 0.280236
-ExtUtils::Command = 7.62
+ExtUtils::Command = 7.64
 ExtUtils::Embed = 1.35
 ExtUtils::Install = 2.2
-ExtUtils::MakeMaker = 7.62
+ExtUtils::MakeMaker = 7.64
 ExtUtils::Manifest = 1.73
-ExtUtils::ParseXS = 3.43
-File::Compare = 1.1006
+ExtUtils::ParseXS = 3.45
+File::Compare = 1.1007
 File::Temp = 0.2311
 Filter::Simple = 0.96
-FindBin = 1.52
-GDBM_File = 1.19_01
+FindBin = 1.53
+GDBM_File = 1.23
 Getopt::Long = 2.52
-Hash::Util = 0.25
+Hash::Util = 0.28
 I18N::LangTags = 0.45
-IO = 1.46
+IO = 1.50
 IO::Zlib = 1.11
 IPC::Cmd = 1.04
 IPC::SysV = 2.09
-JSON::PP = 4.06
-Locale::Maketext = 1.29
+JSON::PP = 4.07
+Locale::Maketext = 1.31
 Locale::Maketext::Simple = 0.21_01
 MIME::Base64 = 3.16
-Math::BigInt = 1.999818
-Math::BigInt::FastCalc = 0.5009
-Math::BigRat = 0.2614
+Math::BigInt = 1.999830
+Math::BigInt::FastCalc = 0.5012
+Math::BigRat = 0.2621
 Math::Complex = 1.5902
 Math::Trig = 1.23
 Memoize = 1.03_01
-Module::CoreList = 5.20220313
+Module::CoreList = 5.20220520
 Module::Load = 0.36
 Module::Load::Conditional = 0.74
 Module::Metadata = 1.000037
-NEXT = 0.68
+NEXT = 0.69
 Params::Check = 0.38
 Parse::CPAN::Meta = 2.150010
 Perl::OSType = 1.010
 PerlIO::via::QuotedPrint = 0.09
 Pod::Escapes = 1.07
-Pod::Simple = 3.42
+Pod::Simple = 3.43
 Safe = 2.43
-Socket = 2.031
-Storable = 3.23
+Socket = 2.033
+Storable = 3.26
 Sys::Syslog = 0.36
 Term::ANSIColor = 5.01
 Term::Cap = 1.17
 Test = 1.31
-Test::Builder::Tester = 1.302183
-Test::Harness = 3.43
-Test::Simple = 1.302183
-Test::Tester = 1.302183
-Test::use::ok = 1.302183
+Test::Builder::Tester = 1.302190
+Test::Harness = 3.44
+Test::Simple = 1.302190
+Test::Tester = 1.302190
+Test::use::ok = 1.302190
 Text::Balanced = 2.04
-Text::ParseWords = 3.30
-Text::Tabs = 2013.0523
+Text::ParseWords = 3.31
+Text::Tabs = 2021.0814
 Tie::File = 1.06
 Tie::RefHash = 1.40
-Time::HiRes = 1.9767
+Time::HiRes = 1.977
 Time::Piece = 1.3401
-UNIVERSAL = 1.13
-Unicode::Collate = 1.29
-Unicode::Normalize = 1.28
+UNIVERSAL = 1.14
+Unicode::Collate = 1.31
+Unicode::Normalize = 1.31
 autodie = 2.34
-bignum = 0.51
+bignum = 0.65
 libnet = 3.13
 parent = 0.238
-version = 0.9928
+version = 0.9929
index aefe5b1a4e6af8ab9e0c3f925d57b24850f3f9e4..d18454097024c0722ce9e0d9f5e5a845f4fd095c 100644 (file)
@@ -1,4 +1,4 @@
-# Non-straight named module versions from Perl 5.34.1 distribution.
-IO-Compress    IO::Compress::Base = 2.102
-PathTools      File::Spec = 3.80
-Scalar-List-Utils      List::Util = 1.55
+# Non-straight named module versions from Perl 5.36.0 distribution.
+IO-Compress    IO::Compress::Base = 2.106
+PathTools      File::Spec = 3.84
+Scalar-List-Utils      List::Util = 1.62
index 857d20e669e4ec34e69038561367d339cfcc9834..d32ee91005544d76bab052a588ce85d00fab9f8a 100644 (file)
--- a/perl.spec
+++ b/perl.spec
@@ -25,7 +25,7 @@
 # NOTE
 # - modules in 5.20.0: http://search.cpan.org/~rjbs/perl-5.20.0/
 
-%define                abi     5.34.0
+%define                abi     5.36.0
 %define                perlthread      %{?with_threads:-thread-multi}
 
 %define                perl_privlib    %{_datadir}/perl5/%{ver}
@@ -43,7 +43,7 @@
 %define                perl_mod2verrel()       %([ -f %{SOURCE4} ] && awk -vp=%1 -vr=%2 '$1 == p { print $4"-"r }' %{SOURCE4} || echo ERROR)
 %define                perl_mod2version()      %([ -f %{SOURCE4} ] && awk -vp=%1 '$1 == p { m=$2; printf("perl-%s = %s\\n", p, $4)}END{if (!m) printf("# Error looking up [%s]\\n", p) }' %{SOURCE4} || echo ERROR)
 
-%define                ver     5.34.1
+%define                ver     5.36.0
 %define                rel     1
 Summary:       Practical Extraction and Report Language (Perl)
 Summary(cs.UTF-8):     Programovací jazyk Perl
@@ -73,7 +73,7 @@ Epoch:                1
 License:       GPL v1+ or Artistic
 Group:         Development/Languages/Perl
 Source0:       https://www.cpan.org/src/5.0/%{name}-%{ver}.tar.xz
-# Source0-md5: 7d2ece7f50775ea1ff739831935a24bd
+# Source0-md5: 826e42da130011699172fd655e49cfa2
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: de47d7893f49ad7f41ba69c78511c0db
 Source2:       %{name}.prov
@@ -862,7 +862,7 @@ WANTED='
 cd "$owd"
 
 ## remove man pages for other operating systems
-%{__rm}        $RPM_BUILD_ROOT%{_mandir}/man1/perl{aix,amiga,bs2000,cygwin,dos}* \
+%{__rm}        $RPM_BUILD_ROOT%{_mandir}/man1/perl{aix,amiga,bs2000,cygwin}* \
        $RPM_BUILD_ROOT%{_mandir}/man1/perl{freebsd,hpux,macos,os2,os390}* \
        $RPM_BUILD_ROOT%{_mandir}/man1/perl{qnx,solaris,vms,vos,win32}*
 
@@ -1026,6 +1026,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/autodie*.3perl*
 %{perl_privlib}/base.pm
 %{_mandir}/man3/base.3perl*
+%{perl_privlib}/builtin.pm
+%{_mandir}/man3/builtin.3perl*
 %{perl_privlib}/constant.pm
 %{_mandir}/man3/constant.3perl*
 %{perl_privlib}/diagnostics.pm
@@ -1306,6 +1308,7 @@ rm -rf $RPM_BUILD_ROOT
 %doc doc-modules/*
 
 %{perl_privlib}/unicore
+%{_mandir}/man3/unicore::Name.3perl*
 
 ## pragmas
 %{perl_privlib}/autouse.pm
@@ -1604,6 +1607,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/Pod::Checker.3perl*
 %{_mandir}/man3/Pod::Escapes.3perl*
 %{_mandir}/man3/Pod::Html.3perl*
+%{_mandir}/man3/Pod::Html::Util.3perl*
 %{_mandir}/man3/Pod::Man.3perl*
 %{_mandir}/man3/Pod::ParseLink.3perl*
 %{_mandir}/man3/Pod::Perldoc*.3perl*
index d1ab849666a15904f64a04a51a488bd99a6f2d86..534b37be06c7ee58f8c0cbd1d769d38e9a915fde 100644 (file)
@@ -4,9 +4,9 @@ diff -urNp -x '*.orig' perl-5.32.1.org/uconfig.h perl-5.32.1/uconfig.h
 @@ -5261,5 +5261,5 @@
  
  /* Generated from:
-  * 6edd641b187b02d0daa8cb53f5d22f2dcca115a0d3e744f51b0292d2db484ca5 config_h.SH
-- * a9ec40c778a205e0256475b5ef025389f7ea06d75d09ac92414f6b99839577e8 uconfig.sh
-+ * 53517d8479a10c057164fb5c7a7e622259dd031c80920f9b6a3614b5a5f94267 uconfig.sh
+  * 87e5998978daf803d19866c43bca24d7c01dc74119650db16f8d18d83f355da9 config_h.SH
+- * 1a5fe19cbcfd68ba70230580fd344189b5c78c11b2285efd5976366e51b3257e uconfig.sh
++ * 1a5fe19cbcfd68ba70230580fd344189b5c78c11b2285efd5976366e51b3257e uconfig.sh
   * ex: set ro: */
 diff -urNp -x '*.orig' perl-5.32.1.org/uconfig.sh perl-5.32.1/uconfig.sh
 --- perl-5.32.1.org/uconfig.sh 2020-12-18 11:04:36.000000000 +0100
@@ -15,8 +15,8 @@ diff -urNp -x '*.orig' perl-5.32.1.org/uconfig.sh perl-5.32.1/uconfig.sh
  afsroot='/afs'
  alignbytes='4'
  aphostname='/bin/hostname'
--archlib='/usr/local/lib/perl5/5.34/unknown'
--archlibexp='/usr/local/lib/perl5/5.34/unknown'
+-archlib='/usr/local/lib/perl5/5.36/unknown'
+-archlibexp='/usr/local/lib/perl5/5.36/unknown'
 -archname='unknown'
  asctime_r_proto='0'
 -bin='/usr/local/bin'
@@ -42,7 +42,7 @@ diff -urNp -x '*.orig' perl-5.32.1.org/uconfig.sh perl-5.32.1/uconfig.sh
  d_locconv='undef'
  d_lockf='undef'
  d_log1p='undef'
-@@ -774,15 +769,11 @@ obj_ext='.o'
+@@ -774,16 +769,12 @@ obj_ext='.o'
  old_pthread_create_joinable=''
  optimize=''
  orderlib='false'
@@ -51,10 +51,11 @@ diff -urNp -x '*.orig' perl-5.32.1.org/uconfig.sh perl-5.32.1/uconfig.sh
  otherlibdirs=' '
  package='perl5'
  perl_static_inline='static'
+ perl_thread_local=''
  phostname='hostname'
  pidtype=int
--privlib='/usr/local/lib/perl5/5.34'
--privlibexp='/usr/local/lib/perl5/5.34'
+-privlib='/usr/local/lib/perl5/5.36'
+-privlibexp='/usr/local/lib/perl5/5.36'
  procselfexe=''
  prototype='undef'
  ptrsize='4'
This page took 0.092354 seconds and 4 git commands to generate.