]> git.pld-linux.org Git - packages/perl.git/blob - perl.spec
1be2abae697731ff3ac2b5d7cdb50b1ad5a0c0f7
[packages/perl.git] / perl.spec
1 %define         perlver 5.005
2 %define         perlrel 03
3 %define         perlthread -thread
4
5 Summary:        Practical Extraction and Report Language
6 Summary(de):    Praktische Extraktions- und Berichtsprache 
7 Summary(fr):    Practical Extraction and Report Language (Perl)
8 Summary(pl):    Practical Extraction and Report Language (Perl)
9 Summary(tr):    Kabuk yorumlama dili
10 Name:           perl
11 Version:        %{perlver}_%{perlrel}
12 Release:        4
13 Copyright:      GPL
14 Group:          Utilities/Text
15 Group(pl):      Narzêdzia/Tekst
16 Source:         ftp://ftp.perl.org/pub/perl/CPAN/src/5.0/%{name}%{version}.tar.gz
17 Patch0:         perl-noroot_install.patch
18 URL:            http://www.perl.org/
19 Requires:       csh
20 Buildroot:      /tmp/%{name}-%{version}-root
21
22 %description
23 Perl is an interpreted language optimized for scanning arbitrary text
24 files, extracting information from those text files, and printing reports
25 based on that information.  It's also a good language for many system
26 management tasks.  The language is intended to be practical (easy to use,
27 efficient, complete) rather than beautiful (tiny, elegant, minimal).
28
29 This version has support for threads compiled in.
30
31 %description -l de
32 Perl ist eine Interpreter-Sprache, die zum Durchsuchen beliebiger Text-
33 dateien, Extrahieren von Informationen aus diesen Dateien und Drucken von
34 auf diesen Informationen basierenden Berichten optimiert ist. Die Sprache
35 eignet sich außerdem für viele Systemverwaltungsaufgaben. Sie ist eher 
36 praktisch (einfache Anwendung,effizient, vollständig) als schön (winzig,
37 elegant, minimal).
38
39 %description -l fr
40 Perl est un langage interprété, optimisé pour filtrer des fichiers texte,
41 extraire des informations de ces fichiers, et imprimer des rapports basés
42 sur ces informations. C'est aussi un bon langage pour de nombreuses procédures
43 de gestion système. Ce langage se veut pratique (simple à utiliser, efficace,
44 complet) autant qu'agréable (conscrit, élégant, minimal).
45
46 %description -l pl
47 Perl jest jêzykiem przeznaczonym do skanowania plików tekstowych, wyci±gania
48 z nich informacji i drukowania raportu bazuj±cego na tych informacjach. Jest
49 równie¿ doskona³ym jêzykiem dla wielu narzêdzi do nadzoru systemu. Jêzyk ten
50 jest w zamierzeniu praktycznym (³atwym w u¿yciu, efektywnym, kompletnym) 
51 bardziej ni¿ piêkny ;) (skromny, elegancki, minimalny).
52
53 %description -l tr
54 Perl, metin dosyalarýný taramak, bu metin dosyalarýndan bilgi çýkarmak ve
55 bu bilgiye dayalý raporlar hazýrlamak icin geliþtirilmiþ bir yorumlamalý
56 dildir. Ayrýca pek çok sistem yönetimi görevleri için de yararlý yetenekleri
57 vardýr. Perl, güzel (ufak, zarif, minimum) olmaktan çok, pratik olmaya
58 yönelik (kullanýmý kolay, verimli, eksiksiz) olarak tasarlanmýþtýr.
59
60 %package -n     sperl
61 Summary:        Practical Extraction and Report Language (SUID root binary)
62 Summary(pl):    Practical Extraction and Report Language (SUID root binaria)
63 Group:          Utilities/Text
64 Group(pl):      Narzêdzia/Tekst
65 Requires:       %{name} = %{version}
66
67 %description -n sperl
68 Practical Extraction and Report Language (SUID root binary).
69
70 %description -n sperl -l pl
71 Practical Extraction and Report Language (SUID root binaria).
72
73 %prep
74 %setup  -q -n %{name}%{version}
75 %patch0 -p1
76
77 %build
78 # this is gross
79 cat > config.over <<EOF
80 installprefix=$RPM_BUILD_ROOT/usr
81 test -d \$installprefix || mkdir \$installprefix
82 test -d \$installprefix/bin || mkdir \$installprefix/bin
83 installarchlib=\`echo \$installarchlib | sed "s!\$prefix!\$installprefix!"\`
84 installbin=\`echo \$installbin | sed "s!\$prefix!\$installprefix!"\`
85 installman1dir=\`echo \$installman1dir | sed "s!\$prefix!\$installprefix!"\`
86 installman3dir=\`echo \$installman3dir | sed "s!\$prefix!\$installprefix!"\`
87 installprivlib=\`echo \$installprivlib | sed "s!\$prefix!\$installprefix!"\`
88 installscript=\`echo \$installscript | sed "s!\$prefix!\$installprefix!"\`
89 installsitelib=\`echo \$installsitelib | sed "s!\$prefix!\$installprefix!"\`
90 installsitearch=\`echo \$installsitearch | sed "s!\$prefix!\$installprefix!"\`
91 EOF
92
93 sh Configure \
94         -des \
95         -Darchname=%{_target} \
96         -Dprefix=/usr \
97         -Dman1dir=%{_mandir}/man1 \
98         -Dman3dir=%{_mandir}/man3 \
99         -Dman3ext=3pm \
100         -Doptimize="$RPM_OPT_FLAGS" \
101         -Duseshrplib \
102         -Dusethreads \
103         -Dd_dosuid \
104         -Ud_setresuid \
105         -Ud_setresgid 
106
107 make
108
109 # Strip binaries (done now rather than at install)
110
111 strip {perl,suidperl,x2p/a2p}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT
116
117 make install
118 install utils/pl2pm $RPM_BUILD_ROOT%{_bindir}/pl2pm
119
120 #LD_LIBRARY_PATH=%{_builddir}/%{name}%{perlver}_%{perlrel}: $RPM_BUILD_ROOT%{_bindir}/perl 
121
122 (cd %{_includedir} ;
123 PERL5LIB=$RPM_BUILD_ROOT%{_libdir}/perl5 $RPM_BUILD_ROOT%{_bindir}/perl \
124 $RPM_BUILD_ROOT%{_libdir}/perl5/%{perlver}%{perlrel}/%{_target}%{perlthread} \
125 $RPM_BUILD_ROOT%{_bindir}/h2ph \
126 -d $RPM_BUILD_ROOT%{_libdir}/perl5/%{_target}/%{perlver}%{perlrel}/ \
127 *.h sys/*.h linux/*.h asm/*.h net/*.h netinet/*.h arpa/*.h )
128
129 ( cd $RPM_BUILD_ROOT%{_libdir}/perl5/%{perlver}%{perlrel}/%{_target}%{perlthread}/
130
131 mv .packlist .packlist.old
132 sed "s|$RPM_BUILD_ROOT||g" < .packlist.old > .packlist
133 rm -f .packlist.old
134
135 mv Config.pm Config.pm.old
136 sed "s|$RPM_BUILD_ROOT||g" < Config.pm.old > Config.pm
137 rm -f Config.pm.old )
138
139 gzip -9fn $RPM_BUILD_ROOT%{_mandir}/man*/* \
140         README Change*
141
142 find $RPM_BUILD_ROOT%{_libdir}/perl5 -name \*.so -exec strip --strip-unneeded {} \;
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %files
148 %defattr(644,root,root,755)
149 %doc README.gz Change*
150
151 %attr(755,root,root) %{_bindir}/a2p
152 %attr(755,root,root) %{_bindir}/c2ph
153 %attr(755,root,root) %{_bindir}/find2perl
154 %attr(755,root,root) %{_bindir}/h2ph
155 %attr(755,root,root) %{_bindir}/h2xs
156 %attr(755,root,root) %{_bindir}/perl
157 %attr(755,root,root) %{_bindir}/perl%{perlver}%{perlrel}
158 %attr(755,root,root) %{_bindir}/perlbug
159 %attr(755,root,root) %{_bindir}/perlcc
160 %attr(755,root,root) %{_bindir}/perldoc
161 %attr(755,root,root) %{_bindir}/pl2pm
162 %attr(755,root,root) %{_bindir}/pod2html
163 %attr(755,root,root) %{_bindir}/pod2latex
164 %attr(755,root,root) %{_bindir}/pod2man
165 %attr(755,root,root) %{_bindir}/pod2text
166 %attr(755,root,root) %{_bindir}/pstruct
167 %attr(755,root,root) %{_bindir}/s2p
168 %attr(755,root,root) %{_bindir}/splain
169
170 %dir %{_libdir}/perl5
171 %attr( - ,root,root) %{_libdir}/perl5/*
172 %{_mandir}/man[13]/*
173
174 %files -n sperl
175 %attr(4755,root,root) %{_bindir}/sperl%{perlver}%{perlrel}
176 %attr(4755,root,root) %{_bindir}/suidperl
177
178 %changelog
179 * Sun May  9 1999 Piotr Czerwiñski <pius@pld.org.pl>
180   [5.005_03-4]
181 - FHS 2.0 compliant changes.
182
183 * Tue Apr 20 1999 Artur Frysiak <wiget@pld.org.pl>
184   [5.005_03-2]
185 - updated to 5.005_03
186 - changed source URL
187 - added -Dman3dir=%{_mandir}/man3 -Dman3ext=3pm -Duseshrplib to Configure
188 - corrected .packlist
189 - changed --strip-debug to --strip-unneeded
190 - gzipped %doc (instead bzipping2)
191 - commpiled on rpm 3
192
193 * Mon Oct 26 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
194   [5.005_02-2]
195 - added using $RPM_OPT_FLAGS during compile,
196 - added stripping modules,
197 - added URL,
198 - added sperl subpackage with suid perl binaries.
199
200 * Tue Sep 15 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
201   [5.005_02-1]
202 - updated to 5.005_02
203   (based on Ian Macdonald <ianmacd@xs4all.nl> spec files),
204 - install -d instead mkdir -p,
205 - added %defattr, but It's still unable to build from non root's account,
206 - man3 subdirectory moved to %{_mandir}/man3,
207 - minor modifications of spec file.   
208
209 * Mon Jun 15 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
210   [5.005_01-1]
211 - added pl translation,
212 - moved %changelog to end of spec,
213 - removed all old patches. 
214 - start at RH spec file.
This page took 0.038329 seconds and 3 git commands to generate.