]> git.pld-linux.org Git - packages/perl.git/blame - perl.spec
- added GDBM_File as a subpackage (fixup needed, see comment in it's
[packages/perl.git] / perl.spec
CommitLineData
6d45ca4e 1#
2# Conditional build:
3# _without_tests - do not perform "make test"
4# _without_threads - build without support for threads
5# _without_largefiles - build without large file support
3d18c4ab 6# _without_gdbm - build without the GDBM_File module
6d45ca4e 7#
8# TODO:
9# - Think about unicore. If uf8*.pm, encode.pm, charnamess.pm (and
10# probably others) are in the perl-base package, unicore should also
11# be there. But it's 5MB...
12# - Think about the package separation. Split between perl, perl-base
13# and perl-modules is far from obvius.
6d45ca4e 14# - fix "FIXME"s, review "XXX"s
15# - fix perl.prov's handling in rpm -- it should use the __perl macro
80a1a2f4 16# - fix some duplicate files
3d18c4ab 17# - add the {O,N}DBM_File modules
6d45ca4e 18# - *TESTING*
19#
20
21%define __find_provides %{_builddir}/%{name}-%{version}/find-perl-provides.sh
22%define perlthread %{?!_without_threads:-thread-multi}
3eb80867 23
6d45ca4e 24%define perl_privlib %{_datadir}/perl5/%{version}
25%define perl_archlib %{_libdir}/perl5/%{version}/%{_target_platform}%{perlthread}
01393b52 26%define perl_sitelib %{_usr}/local/share/perl5
6d45ca4e 27%define perl_sitearch %{_usr}/local/lib/perl5/%{version}/%{_target_platform}%{perlthread}
01393b52 28%define perl_vendorlib %{_datadir}/perl5/vendor_perl
6d45ca4e 29%define perl_vendorarch %{_libdir}/perl5/vendor_perl/%{version}/%{_target_platform}%{perlthread}
3eb80867 30
557db02e 31Summary: Practical Extraction and Report Language (Perl)
7095bd2b 32