]> git.pld-linux.org Git - packages/perl-threads.git/blob - perl-threads.spec
- initial
[packages/perl-threads.git] / perl-threads.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    threads
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        threads - Perl interpreter-based threads
8 Name:           perl-threads
9 Version:        2.01
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/J/JD/JDHEDDEN/threads-%{version}.tar.gz
15 # Source0-md5:  aec3a036c31ffa868adda1170ef26240
16 URL:            http://search.cpan.org/dist/threads/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 %endif
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Since Perl 5.8, thread programming has been available using a model
25 called interpreter threads which provides a new Perl interpreter for
26 each thread, and, by default, results in no data or state information
27 being shared between threads.
28
29 %prep
30 %setup -q -n %{pdir}-%{version}
31
32 %build
33 %{__perl} Makefile.PL \
34         INSTALLDIRS=vendor
35 %{__make} \
36         CC="%{__cc}" \
37         OPTIMIZE="%{rpmcflags}"
38
39 %{?with_tests:%{__make} test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 %{__make} pure_install \
45         DESTDIR=$RPM_BUILD_ROOT
46
47 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
48 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes README
56 %{perl_vendorarch}/threads.pm
57 %dir %{perl_vendorarch}/auto/threads
58 %attr(755,root,root) %{perl_vendorarch}/auto/threads/*.so
59 %{_mandir}/man3/*
60 %{_examplesdir}/%{name}-%{version}
This page took 0.119842 seconds and 3 git commands to generate.