]> git.pld-linux.org Git - packages/perl-threads.git/blob - perl-threads.spec
rebuild with perl 5.32
[packages/perl-threads.git] / perl-threads.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define         pdir    threads
6 Summary:        threads - Perl interpreter-based threads
7 Name:           perl-threads
8 Version:        2.21
9 Release:        3
10 # same as perl
11 License:        GPL v1+ or Artistic
12 Group:          Development/Languages/Perl
13 Source0:        http://www.cpan.org/modules/by-authors/id/J/JD/JDHEDDEN/threads-%{version}.tar.gz
14 # Source0-md5:  45fa009703074f0b0b0d036cb23706e3
15 URL:            http://search.cpan.org/dist/threads/
16 BuildRequires:  perl-devel >= 1:5.8.0
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 Since Perl 5.8, thread programming has been available using a model
22 called interpreter threads which provides a new Perl interpreter for
23 each thread, and, by default, results in no data or state information
24 being shared between threads.
25
26 %prep
27 %setup -q -n %{pdir}-%{version}
28
29 %build
30 %{__perl} Makefile.PL \
31         INSTALLDIRS=vendor
32 %{__make} \
33         CC="%{__cc}" \
34         OPTIMIZE="%{rpmcflags}"
35
36 %{?with_tests:%{__make} test}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40
41 %{__make} pure_install \
42         DESTDIR=$RPM_BUILD_ROOT
43
44 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
45 cp -a examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc Changes README
53 %{perl_vendorarch}/threads.pm
54 %dir %{perl_vendorarch}/auto/threads
55 %attr(755,root,root) %{perl_vendorarch}/auto/threads/threads.so
56 %{_mandir}/man3/threads.3pm*
57 %{_examplesdir}/%{name}-%{version}
This page took 0.075126 seconds and 3 git commands to generate.