]> git.pld-linux.org Git - packages/perl-prefork.git/blame - perl-prefork.spec
- new
[packages/perl-prefork.git] / perl-prefork.spec
CommitLineData
068f30b1 1#
2# Conditional build:
3%bcond_without tests # do not perform "make test"
4#
5%include /usr/lib/rpm/macros.perl
6%define pdir prefork
7Summary: prefork - Optimize module loading across forking and non-forking scenarios
8#Summary(pl):
9Name: perl-prefork
10Version: 0.03
11Release: 1
12# same as perl
13License: GPL v1+ or Artistic
14Group: Development/Languages/Perl
15Source0: http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{version}.tar.gz
16# Source0-md5: 040b340931bd8190b87c81130ea5f8d0
17BuildRequires: perl-devel >= 1:5.8.0
18BuildRequires: rpm-perlprov >= 4.1-13
19BuildRequires: perl-ExtUtils-MakeMaker >= 6.24-2
20BuildArch: noarch
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23%description
24The prefork pragma is intended to allow module writers to optimise module
25loading for B<both> scenarios with as little additional code as possible.
26
27The prefork.pm is intended to serve as a central and optional marshalling
28point for state detection (are we running in procedural or pre-forking
29mode) and to act as a relatively light-weight module loader.
30
31# %description -l pl
32# TODO
33
34%prep
35%setup -q -n %{pdir}-%{version}
36
37%build
38%{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"%{pdir}")' \
39 INSTALLDIRS=vendor
40%{__make}
41
42%{?with_tests:%{__make} test}
43
44%install
45rm -rf $RPM_BUILD_ROOT
46
47%{__make} install \
48 DESTDIR=$RPM_BUILD_ROOT
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%files
54%defattr(644,root,root,755)
55%doc Changes
56%{perl_vendorlib}/*.pm
57%{_mandir}/man3/*
This page took 0.0877019999999999 seconds and 4 git commands to generate.