]> git.pld-linux.org Git - packages/perl-namespace-autoclean.git/blame - perl-namespace-autoclean.spec
R: perl(Sub::Identify); rel 2
[packages/perl-namespace-autoclean.git] / perl-namespace-autoclean.spec
CommitLineData
65a6eaa7 1#
2# Conditional build:
65a6eaa7 3%bcond_without tests # do not perform "make test"
4#
65a6eaa7 5%define pdir namespace
6%define pnam autoclean
7Summary: namespace::autoclean removes all imported symbols at the end of compile cycle
8Summary(pl.UTF-8): namespace::autoclean usuwa wszystkie zaimportowane symbole pod koniec cyklu kompilacji
9Name: perl-namespace-autoclean
224b1f3e 10Version: 0.29
f4dc907e 11Release: 2
65a6eaa7 12License: GPL v1+ or Artistic
13Group: Development/Languages/Perl
81281b19 14Source0: http://www.cpan.org/modules/by-module/namespace/%{pdir}-%{pnam}-%{version}.tar.gz
224b1f3e 15# Source0-md5: 39b38c776cd1f0ee03cc70781a2f2798
7943b305 16URL: https://metacpan.org/release/namespace-autoclean
65a6eaa7 17BuildRequires: perl-devel >= 1:5.8.0
18BuildRequires: rpm-perlprov >= 4.1-13
7943b305 19BuildRequires: rpmbuild(macros) >= 1.745
81281b19
JB
20%if %{with tests}
21BuildRequires: perl-B-Hooks-EndOfScope >= 0.12
22BuildRequires: perl-Sub-Identify
23BuildRequires: perl-Test-Requires
24BuildRequires: perl-Test-Simple >= 0.88
25BuildRequires: perl-namespace-clean >= 0.20
65a6eaa7 26%endif
f4dc907e 27Requires: perl(Sub::Identify)
65a6eaa7 28BuildArch: noarch
29BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31%description
32When you import a function into a Perl package, it will naturally also
33be available as a method.
34
35The namespace::autoclean pragma will remove all imported symbols at
36the end of the current package's compile cycle. Functions called in
37the package itself will still be bound by their name, but they won't
38show up as methods on your class or instances.
39
40This module is very similar to namespace::clean, except it will clean
41all imported functions, no matter if you imported them before or after
42you used the pagma. It will also not touch anything that looks like a
43method, according to Class::MOP::Class::get_method_list.
44
45%description -l pl.UTF-8
46namespace::autoclean usuwa wszystkie zaimportowane symbole pod koniec
47cyklu kompilacji
48
49%prep
50%setup -q -n %{pdir}-%{pnam}-%{version}
51
52%build
53%{__perl} Makefile.PL \
54 INSTALLDIRS=vendor
55%{__make}
56
57%{?with_tests:%{__make} test}
58
59%install
60rm -rf $RPM_BUILD_ROOT
61
62%{__make} install \
63 DESTDIR=$RPM_BUILD_ROOT
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68%files
69%defattr(644,root,root,755)
70%doc Changes README
71%{perl_vendorlib}/namespace/*.pm
72%{_mandir}/man3/*
This page took 0.093613 seconds and 4 git commands to generate.