]> git.pld-linux.org Git - packages/perl-namespace-autoclean.git/blame - perl-namespace-autoclean.spec
- macros for perl autodeps
[packages/perl-namespace-autoclean.git] / perl-namespace-autoclean.spec
CommitLineData
65a6eaa7 1#
2# Conditional build:
65a6eaa7 3%bcond_without tests # do not perform "make test"
4#
65a6eaa7 5%define pdir namespace
6%define pnam autoclean
7Summary: namespace::autoclean removes all imported symbols at the end of compile cycle
8Summary(pl.UTF-8): namespace::autoclean usuwa wszystkie zaimportowane symbole pod koniec cyklu kompilacji
9Name: perl-namespace-autoclean
224b1f3e 10Version: 0.29
65a6eaa7 11Release: 1
12License: GPL v1+ or Artistic
13Group: Development/Languages/Perl
81281b19 14Source0: http://www.cpan.org/modules/by-module/namespace/%{pdir}-%{pnam}-%{version}.tar.gz
224b1f3e 15# Source0-md5: 39b38c776cd1f0ee03cc70781a2f2798
7943b305 16URL: https://metacpan.org/release/namespace-autoclean
65a6eaa7 17BuildRequires: perl-devel >= 1:5.8.0
18BuildRequires: rpm-perlprov >= 4.1-13
7943b305 19BuildRequires: rpmbuild(macros) >= 1.745
81281b19
JB
20%if %{with tests}
21BuildRequires: perl-B-Hooks-EndOfScope >= 0.12
22BuildRequires: perl-Sub-Identify
23BuildRequires: perl-Test-Requires
24BuildRequires: perl-Test-Simple >= 0.88
25BuildRequires: perl-namespace-clean >= 0.20
65a6eaa7 26%endif
27BuildArch: noarch
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31When you import a function into a Perl package, it will naturally also
32be available as a method.
33
34The namespace::autoclean pragma will remove all imported symbols at
35the end of the current package's compile cycle. Functions called in
36the package itself will still be bound by their name, but they won't
37show up as methods on your class or instances.
38
39This module is very similar to namespace::clean, except it will clean
40all imported functions, no matter if you imported them before or after
41you used the pagma. It will also not touch anything that looks like a
42method, according to Class::MOP::Class::get_method_list.
43
44%description -l pl.UTF-8
45namespace::autoclean usuwa wszystkie zaimportowane symbole pod koniec
46cyklu kompilacji
47
48%prep
49%setup -q -n %{pdir}-%{pnam}-%{version}
50
51%build
52%{__perl} Makefile.PL \
53 INSTALLDIRS=vendor
54%{__make}
55
56%{?with_tests:%{__make} test}
57
58%install
59rm -rf $RPM_BUILD_ROOT
60
61%{__make} install \
62 DESTDIR=$RPM_BUILD_ROOT
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files
68%defattr(644,root,root,755)
69%doc Changes README
70%{perl_vendorlib}/namespace/*.pm
71%{_mandir}/man3/*
This page took 0.124561 seconds and 4 git commands to generate.