]> git.pld-linux.org Git - packages/perl-local-lib.git/blob - perl-local-lib.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-local-lib.git] / perl-local-lib.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    local
6 %define pnam    lib
7 Summary:        local::lib - create and use a local lib/ for perl modules with PERL5LIB
8 #Summary(pl.UTF-8):     
9 Name:           perl-local-lib
10 Version:        1.008004
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-authors/id/A/AP/APEIRON/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  6244fa9d77e818594acbaf572aece326
17 URL:            http://search.cpan.org/dist/local-lib/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 local::lib allows for the bootstrapping and usage of a directory
25 containing Perl modules outside of Perl's @INC. This makes it easier
26 to ship an application with an app-specific copy of a Perl module,
27 or collection of modules. Useful in cases like when an upstream
28 maintainer hasn't applied a patch to a module of theirs that you need
29 for your application.
30
31 # %description -l pl.UTF-8
32 # TODO
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} pure_install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc Changes
56 %{perl_vendorlib}/local
57 %{_mandir}/man3/*
This page took 0.089865 seconds and 4 git commands to generate.