]> git.pld-linux.org Git - packages/perl-ldap.git/blob - perl-ldap.spec
- fixed usage of new style bconds
[packages/perl-ldap.git] / perl-ldap.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        perl-ldap module - a client interface to LDAP servers
7 Summary(pl):    Modu³ perl-ldap - kliencki interfejs do serwerów LDAP
8 Name:           perl-ldap
9 Version:        0.31
10 Release:        1
11 Epoch:          2
12 License:        GPL
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Net/%{name}-%{version}.tar.gz
15 # Source0-md5:  b3107452e2bb4d74d4b9892d61d50137
16 URL:            http://ldap.perl.org/
17 %if %{with tests}
18 BuildRequires:  perl-Authen-SASL >= 2.00
19 BuildRequires:  perl-Convert-ASN1 >= 0.07
20 BuildRequires:  perl-Digest-MD5
21 BuildRequires:  perl-IO-Socket-SSL
22 BuildRequires:  perl-MIME-Base64
23 BuildRequires:  perl-Module-Signature
24 BuildRequires:  perl-URI >= 1.08
25 BuildRequires:  perl-XML-SAX
26 BuildRequires:  perl-libwww
27 %endif
28 BuildRequires:  perl-devel >= 5.8.0
29 BuildRequires:  rpm-perlprov >= 4.1-13
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _noautoreq 'perl(Convert::ASN1::Debug)'
34
35 %description
36 perl-ldap is a collection of modules that implements a LDAP services
37 API for Perl programs.
38
39 %description -l pl
40 perl-ldap to zestaw modu³ów umo¿liwiaj±cych dostêp do us³ug LDAP z
41 poziomu programów w Perlu.
42
43 %prep
44 %setup -q -n perl-ldap-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 # this must be done after tests because of signature checking
54 find blib -type f | xargs -r perl -pi -e 's|/local/bin/perl\d*|/bin/perl|g'
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 cp -r {contrib,bin} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc CREDITS ChangeLog README RELEASE_NOTES TODO
71 %{perl_vendorlib}/LWP/Protocol/ldap.pm
72 %{perl_vendorlib}/Net/LDAP*.pm
73 %dir %{perl_vendorlib}/Net/LDAP
74 %{perl_vendorlib}/Net/LDAP/*.pm
75 %{perl_vendorlib}/Net/LDAP/Control
76 %{perl_vendorlib}/Net/LDAP/Extension
77 %{_mandir}/man3/N*
78 %{_examplesdir}/%{name}-%{version}
This page took 0.056461 seconds and 4 git commands to generate.