]> git.pld-linux.org Git - packages/perl-ldap.git/blob - perl-ldap.spec
Merge branch 'master' of git://git.pld-linux.org/packages/perl-ldap
[packages/perl-ldap.git] / perl-ldap.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (requires working ldap server and gnupg configured with key retrieval with hkp)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        perl-ldap module - a client interface to LDAP servers
7 Summary(pl.UTF-8):      Moduł perl-ldap - kliencki interfejs do serwerów LDAP
8 Name:           perl-ldap
9 Version:        0.56
10 Release:        2
11 Epoch:          3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{name}-%{version}.tar.gz
16 # Source0-md5:  4ea517a844bad34b79f05afcfd24cc05
17 Patch0:         non-unicode-dump.patch
18 URL:            http://ldap.perl.org/
19 BuildRequires:  perl-Authen-SASL >= 2.00
20 BuildRequires:  perl-Convert-ASN1 >= 0.20
21 BuildRequires:  perl-Digest-MD5
22 BuildRequires:  perl-IO-Socket-INET6
23 BuildRequires:  perl-IO-Socket-SSL >= 1.26
24 BuildRequires:  perl-JSON
25 BuildRequires:  perl-MIME-Base64
26 BuildRequires:  perl-URI >= 1.1
27 BuildRequires:  perl-XML-SAX-Writer
28 BuildRequires:  perl-devel >= 1:5.18.0
29 BuildRequires:  rpm-perlprov >= 4.1-13
30 %if %{with tests}
31 BuildRequires:  perl-Module-Signature
32 BuildRequires:  perl-Test-Simple
33 BuildRequires:  perl-libwww
34 %endif
35 Obsoletes:      perl-LDAP
36 BuildArch:      noarch
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 perl-ldap is a collection of modules that implements a LDAP services
41 API for Perl programs.
42
43 %description -l pl.UTF-8
44 perl-ldap to zestaw modułów umożliwiających dostęp do usług LDAP z
45 poziomu programów w Perlu.
46
47 %prep
48 %setup -q
49 %patch0 -p1
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 # this must be done after tests because of signature checking
59 find blib -type f | xargs -r perl -pi -e 's|/local/bin/perl\d*|/bin/perl|g'
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65 %{__make} pure_install \
66         DESTDIR=$RPM_BUILD_ROOT
67 cp -r {contrib,bin} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68
69 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/Bundle::Net::LDAP.3pm
70 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/{Bundle/Net/LDAP.pm,Net/{,LDAP/}*.pod}
71 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Net/LDAP/.packlist
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc CREDITS Changes README TODO
79 %{perl_vendorlib}/LWP/Protocol/ldap.pm
80 %{perl_vendorlib}/LWP/Protocol/ldapi.pm
81 %{perl_vendorlib}/LWP/Protocol/ldaps.pm
82 %{perl_vendorlib}/Net/LDAP*.pm
83 %dir %{perl_vendorlib}/Net/LDAP
84 %{perl_vendorlib}/Net/LDAP/*.pm
85 %{perl_vendorlib}/Net/LDAP/Control
86 %{perl_vendorlib}/Net/LDAP/Extension
87 %{perl_vendorlib}/Net/LDAP/Extra
88 %{perl_vendorlib}/Net/LDAP/Intermediate
89 %{_mandir}/man3/LWP::Protocol::ldap*
90 %{_mandir}/man3/N*
91 %{_examplesdir}/%{name}-%{version}
This page took 0.063375 seconds and 4 git commands to generate.