]> git.pld-linux.org Git - packages/perl-ldap.git/blob - perl-ldap.spec
- disable unicode warnings in entry->dump()
[packages/perl-ldap.git] / perl-ldap.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (requires working ldap server and gnupg configured with key retrieval with hkp)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        perl-ldap module - a client interface to LDAP servers
7 Summary(pl.UTF-8):      Moduł perl-ldap - kliencki interfejs do serwerów LDAP
8 Name:           perl-ldap
9 Version:        0.56
10 Release:        2
11 Epoch:          3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{name}-%{version}.tar.gz
16 # Source0-md5:  4ea517a844bad34b79f05afcfd24cc05
17 Patch0:         non-unicode-dump.patch
18 URL:            http://ldap.perl.org/
19 BuildRequires:  perl-Authen-SASL >= 2.00
20 BuildRequires:  perl-Convert-ASN1 >= 0.07
21 BuildRequires:  perl-Digest-MD5
22 BuildRequires:  perl-IO-Socket-SSL >= 0.81
23 BuildRequires:  perl-JSON
24 BuildRequires:  perl-URI >= 1.1
25 BuildRequires:  perl-XML-SAX-Writer
26 BuildRequires:  perl-devel >= 1:5.18.0
27 BuildRequires:  rpm-perlprov >= 4.1-13
28 %if %{with tests}
29 BuildRequires:  perl-Module-Signature
30 BuildRequires:  perl-libwww
31 %endif
32 Obsoletes:      perl-LDAP
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 perl-ldap is a collection of modules that implements a LDAP services
38 API for Perl programs.
39
40 %description -l pl.UTF-8
41 perl-ldap to zestaw modułów umożliwiających dostęp do usług LDAP z
42 poziomu programów w Perlu.
43
44 %prep
45 %setup -q
46 %patch0 -p1
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 # this must be done after tests because of signature checking
56 find blib -type f | xargs -r perl -pi -e 's|/local/bin/perl\d*|/bin/perl|g'
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62 %{__make} pure_install \
63         DESTDIR=$RPM_BUILD_ROOT
64 cp -r {contrib,bin} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Net/LDAP/.packlist
67 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/Bundle::Net::LDAP.3pm
68 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/{Bundle/Net/LDAP.pm,Net/{,LDAP/}*.pod}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc CREDITS Changes README TODO
76 %{perl_vendorlib}/LWP/Protocol/ldap.pm
77 %{perl_vendorlib}/LWP/Protocol/ldapi.pm
78 %{perl_vendorlib}/LWP/Protocol/ldaps.pm
79 %{perl_vendorlib}/Net/LDAP*.pm
80 %dir %{perl_vendorlib}/Net/LDAP
81 %{perl_vendorlib}/Net/LDAP/*.pm
82 %{perl_vendorlib}/Net/LDAP/Control
83 %{perl_vendorlib}/Net/LDAP/Extension
84 %{perl_vendorlib}/Net/LDAP/Extra
85 %{perl_vendorlib}/Net/LDAP/Intermediate
86 %{_mandir}/man3/LWP::Protocol::ldap*
87 %{_mandir}/man3/N*
88 %{_examplesdir}/%{name}-%{version}
This page took 0.736733 seconds and 4 git commands to generate.