]> git.pld-linux.org Git - packages/perl-ldap.git/blob - perl-ldap.spec
- updated to 0.33
[packages/perl-ldap.git] / perl-ldap.spec
1 #
2 # Conditional build:
3 %bcond_with     tests # perform "make test" (requires working ldap server and gnupg configured with key retrieval with hkp)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        perl-ldap module - a client interface to LDAP servers
7 Summary(pl):    Modu³ perl-ldap - kliencki interfejs do serwerów LDAP
8 Name:           perl-ldap
9 Version:        0.33
10 Release:        1
11 Epoch:          2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{name}-%{version}.tar.gz
16 # Source0-md5:  7002aedb8bcaa7169a8f0a8e22d34b72
17 URL:            http://ldap.perl.org/
18 %if %{with tests}
19 BuildRequires:  perl-Authen-SASL >= 2.00
20 BuildRequires:  perl-Convert-ASN1 >= 0.07
21 BuildRequires:  perl-Digest-MD5
22 BuildRequires:  perl-IO-Socket-SSL
23 BuildRequires:  perl-MIME-Base64
24 BuildRequires:  perl-Module-Signature
25 BuildRequires:  perl-URI >= 1.08
26 BuildRequires:  perl-XML-SAX
27 BuildRequires:  perl-libwww
28 %endif
29 BuildRequires:  perl-ExtUtils-AutoInstall
30 BuildRequires:  perl-devel >= 1:5.8.0
31 BuildRequires:  rpm-perlprov >= 4.1-13
32 Obsoletes:      perl-LDAP
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _noautoreq 'perl(Convert::ASN1::Debug)'
37
38 %description
39 perl-ldap is a collection of modules that implements a LDAP services
40 API for Perl programs.
41
42 %description -l pl
43 perl-ldap to zestaw modu³ów umo¿liwiaj±cych dostêp do us³ug LDAP z
44 poziomu programów w Perlu.
45
46 %prep
47 %setup -q
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52 %{__make}
53
54 %{?with_tests:%{__make} test}
55
56 # this must be done after tests because of signature checking
57 find blib -type f | xargs -r perl -pi -e 's|/local/bin/perl\d*|/bin/perl|g'
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62
63 %{__make} pure_install \
64         DESTDIR=$RPM_BUILD_ROOT
65 cp -r {contrib,bin} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
66
67 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Net/LDAP/.packlist
68 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/Bundle::Net::LDAP.3pm
69 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/{Bundle/Net/LDAP.pm,Net/{,LDAP/}*.pod}
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc CREDITS Changes README TODO
77 %{perl_vendorlib}/LWP/Protocol/ldap.pm
78 %{perl_vendorlib}/Net/LDAP*.pm
79 %dir %{perl_vendorlib}/Net/LDAP
80 %{perl_vendorlib}/Net/LDAP/*.pm
81 %{perl_vendorlib}/Net/LDAP/Control
82 %{perl_vendorlib}/Net/LDAP/Extension
83 %{_mandir}/man3/N*
84 %{_examplesdir}/%{name}-%{version}
This page took 0.035572 seconds and 4 git commands to generate.