]> git.pld-linux.org Git - packages/perl-ldap.git/blob - perl-ldap.spec
- rel. 2
[packages/perl-ldap.git] / perl-ldap.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        perl-ldap module - a client interface to LDAP servers
7 Summary(pl):    Modu³ perl-ldap - kliencki interfejs do serwerów LDAP
8 Name:           perl-ldap
9 Version:        0.31
10 Release:        2
11 Epoch:          2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{name}-%{version}.tar.gz
16 # Source0-md5:  b3107452e2bb4d74d4b9892d61d50137
17 URL:            http://ldap.perl.org/
18 %if %{with tests}
19 BuildRequires:  perl-Authen-SASL >= 2.00
20 BuildRequires:  perl-Convert-ASN1 >= 0.07
21 BuildRequires:  perl-Digest-MD5
22 BuildRequires:  perl-IO-Socket-SSL
23 BuildRequires:  perl-MIME-Base64
24 BuildRequires:  perl-Module-Signature
25 BuildRequires:  perl-URI >= 1.08
26 BuildRequires:  perl-XML-SAX
27 BuildRequires:  perl-libwww
28 %endif
29 BuildRequires:  perl-devel >= 1:5.8.0
30 BuildRequires:  rpm-perlprov >= 4.1-13
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %define         _noautoreq 'perl(Convert::ASN1::Debug)'
35
36 %description
37 perl-ldap is a collection of modules that implements a LDAP services
38 API for Perl programs.
39
40 %description -l pl
41 perl-ldap to zestaw modu³ów umo¿liwiaj±cych dostêp do us³ug LDAP z
42 poziomu programów w Perlu.
43
44 %prep
45 %setup -q -n perl-ldap-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor
50 %{__make}
51
52 %{?with_tests:%{__make} test}
53
54 # this must be done after tests because of signature checking
55 find blib -type f | xargs -r perl -pi -e 's|/local/bin/perl\d*|/bin/perl|g'
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63 cp -r {contrib,bin} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc CREDITS ChangeLog README RELEASE_NOTES TODO
71 %{perl_vendorlib}/LWP/Protocol/ldap.pm
72 %{perl_vendorlib}/Net/LDAP*.pm
73 %dir %{perl_vendorlib}/Net/LDAP
74 %{perl_vendorlib}/Net/LDAP/*.pm
75 %{perl_vendorlib}/Net/LDAP/Control
76 %{perl_vendorlib}/Net/LDAP/Extension
77 %{_mandir}/man3/N*
78 %{_examplesdir}/%{name}-%{version}
This page took 0.043443 seconds and 4 git commands to generate.