]> git.pld-linux.org Git - packages/perl-ldap.git/blob - perl-ldap.spec
- perl-ExtUtils-AutoInstall is not BRed (included in sources)
[packages/perl-ldap.git] / perl-ldap.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (requires working ldap server and gnupg configured with key retrieval with hkp)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        perl-ldap module - a client interface to LDAP servers
7 Summary(pl.UTF-8):      Moduł perl-ldap - kliencki interfejs do serwerów LDAP
8 Name:           perl-ldap
9 Version:        0.34
10 Release:        1
11 Epoch:          3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{name}-%{version}.tar.gz
16 # Source0-md5:  398689b0a7b1615075a6b5035f6e3e91
17 URL:            http://ldap.perl.org/
18 BuildRequires:  perl-Authen-SASL >= 2.00
19 BuildRequires:  perl-Convert-ASN1 >= 0.07
20 BuildRequires:  perl-Digest-MD5
21 BuildRequires:  perl-IO-Socket-SSL >= 0.81
22 BuildRequires:  perl-devel >= 1:5.8.0
23 BuildRequires:  rpm-perlprov >= 4.1-13
24 %if %{with tests}
25 BuildRequires:  perl-MIME-Base64
26 BuildRequires:  perl-Module-Signature
27 BuildRequires:  perl-URI >= 1.08
28 BuildRequires:  perl-XML-SAX
29 BuildRequires:  perl-libwww
30 %endif
31 Obsoletes:      perl-LDAP
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _noautoreq 'perl(Convert::ASN1::Debug)'
36
37 %description
38 perl-ldap is a collection of modules that implements a LDAP services
39 API for Perl programs.
40
41 %description -l pl.UTF-8
42 perl-ldap to zestaw modułów umożliwiających dostęp do usług LDAP z
43 poziomu programów w Perlu.
44
45 %prep
46 %setup -q
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 # this must be done after tests because of signature checking
56 find blib -type f | xargs -r perl -pi -e 's|/local/bin/perl\d*|/bin/perl|g'
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62 %{__make} pure_install \
63         DESTDIR=$RPM_BUILD_ROOT
64 cp -r {contrib,bin} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Net/LDAP/.packlist
67 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/Bundle::Net::LDAP.3pm
68 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/{Bundle/Net/LDAP.pm,Net/{,LDAP/}*.pod}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc CREDITS Changes README TODO
76 %{perl_vendorlib}/LWP/Protocol/ldap.pm
77 %{perl_vendorlib}/Net/LDAP*.pm
78 %dir %{perl_vendorlib}/Net/LDAP
79 %{perl_vendorlib}/Net/LDAP/*.pm
80 %{perl_vendorlib}/Net/LDAP/Control
81 %{perl_vendorlib}/Net/LDAP/Extension
82 %{_mandir}/man3/N*
83 %{_examplesdir}/%{name}-%{version}
This page took 0.05327 seconds and 4 git commands to generate.