]> git.pld-linux.org Git - packages/perl-ldap.git/blob - perl-ldap.spec
- updated to 0.3202
[packages/perl-ldap.git] / perl-ldap.spec
1 #
2 # Conditional build:
3 %bcond_without  tests # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        perl-ldap module - a client interface to LDAP servers
7 Summary(pl):    Modu³ perl-ldap - kliencki interfejs do serwerów LDAP
8 Name:           perl-ldap
9 Version:        0.3202
10 Release:        1
11 Epoch:          2
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{name}-%{version}.tar.gz
16 # Source0-md5:  57dc6214d06b4e9e2a3b0f778aa40261
17 URL:            http://ldap.perl.org/
18 %if %{with tests}
19 BuildRequires:  perl-Authen-SASL >= 2.00
20 BuildRequires:  perl-Convert-ASN1 >= 0.07
21 BuildRequires:  perl-Digest-MD5
22 BuildRequires:  perl-IO-Socket-SSL
23 BuildRequires:  perl-MIME-Base64
24 BuildRequires:  perl-Module-Signature
25 BuildRequires:  perl-URI >= 1.08
26 BuildRequires:  perl-XML-SAX
27 BuildRequires:  perl-libwww
28 %endif
29 BuildRequires:  perl-ExtUtils-AutoInstall
30 BuildRequires:  perl-devel >= 1:5.8.0
31 BuildRequires:  rpm-perlprov >= 4.1-13
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _noautoreq 'perl(Convert::ASN1::Debug)'
36
37 %description
38 perl-ldap is a collection of modules that implements a LDAP services
39 API for Perl programs.
40
41 %description -l pl
42 perl-ldap to zestaw modu³ów umo¿liwiaj±cych dostêp do us³ug LDAP z
43 poziomu programów w Perlu.
44
45 %prep
46 %setup -q -n perl-ldap-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 # this must be done after tests because of signature checking
56 find blib -type f | xargs -r perl -pi -e 's|/local/bin/perl\d*|/bin/perl|g'
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64 cp -r {contrib,bin} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc CREDITS Changes README TODO
72 %{perl_vendorlib}/LWP/Protocol/ldap.pm
73 %{perl_vendorlib}/Net/LDAP*.pm
74 %dir %{perl_vendorlib}/Net/LDAP
75 %{perl_vendorlib}/Net/LDAP/*.pm
76 %{perl_vendorlib}/Net/LDAP/Control
77 %{perl_vendorlib}/Net/LDAP/Extension
78 %{_mandir}/man3/N*
79 %{_examplesdir}/%{name}-%{version}
This page took 0.081966 seconds and 4 git commands to generate.