]> git.pld-linux.org Git - packages/perl-ldap.git/blob - perl-ldap.spec
- up to 0.57
[packages/perl-ldap.git] / perl-ldap.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (requires working ldap server and gnupg configured with key retrieval with hkp)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        perl-ldap module - a client interface to LDAP servers
7 Summary(pl.UTF-8):      Moduł perl-ldap - kliencki interfejs do serwerów LDAP
8 Name:           perl-ldap
9 Version:        0.57
10 Release:        1
11 Epoch:          3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{name}-%{version}.tar.gz
16 # Source0-md5:  deff50f0de5d4cf95145765b6edd67d1
17 Patch0:         non-unicode-dump.patch
18 Patch1:         ignore-uninitialized.patch
19 URL:            http://ldap.perl.org/
20 BuildRequires:  perl-Authen-SASL >= 2.00
21 BuildRequires:  perl-Convert-ASN1 >= 0.20
22 BuildRequires:  perl-Digest-MD5
23 BuildRequires:  perl-IO-Socket-INET6
24 BuildRequires:  perl-IO-Socket-SSL >= 1.26
25 BuildRequires:  perl-JSON
26 BuildRequires:  perl-MIME-Base64
27 BuildRequires:  perl-URI >= 1.1
28 BuildRequires:  perl-XML-SAX-Writer
29 BuildRequires:  perl-devel >= 1:5.18.0
30 BuildRequires:  rpm-perlprov >= 4.1-13
31 %if %{with tests}
32 BuildRequires:  perl-Module-Signature
33 BuildRequires:  perl-Test-Simple
34 BuildRequires:  perl-libwww
35 %endif
36 Obsoletes:      perl-LDAP
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 perl-ldap is a collection of modules that implements a LDAP services
42 API for Perl programs.
43
44 %description -l pl.UTF-8
45 perl-ldap to zestaw modułów umożliwiających dostęp do usług LDAP z
46 poziomu programów w Perlu.
47
48 %prep
49 %setup -q
50 %patch0 -p1
51 %patch1 -p1
52
53 %build
54 %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56 %{__make}
57
58 %{?with_tests:%{__make} test}
59
60 # this must be done after tests because of signature checking
61 find blib -type f | xargs -r perl -pi -e 's|/local/bin/perl\d*|/bin/perl|g'
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
66
67 %{__make} pure_install \
68         DESTDIR=$RPM_BUILD_ROOT
69 cp -r {contrib,bin} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
70
71 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man3/Bundle::Net::LDAP.3pm
72 %{__rm} $RPM_BUILD_ROOT%{perl_vendorlib}/{Bundle/Net/LDAP.pm,Net/{,LDAP/}*.pod}
73 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Net/LDAP/.packlist
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc CREDITS Changes README TODO
81 %{perl_vendorlib}/LWP/Protocol/ldap.pm
82 %{perl_vendorlib}/LWP/Protocol/ldapi.pm
83 %{perl_vendorlib}/LWP/Protocol/ldaps.pm
84 %{perl_vendorlib}/Net/LDAP*.pm
85 %dir %{perl_vendorlib}/Net/LDAP
86 %{perl_vendorlib}/Net/LDAP/*.pm
87 %{perl_vendorlib}/Net/LDAP/Control
88 %{perl_vendorlib}/Net/LDAP/Extension
89 %{perl_vendorlib}/Net/LDAP/Extra
90 %{perl_vendorlib}/Net/LDAP/Intermediate
91 %{_mandir}/man3/LWP::Protocol::ldap*
92 %{_mandir}/man3/N*
93 %{_examplesdir}/%{name}-%{version}
This page took 0.045502 seconds and 4 git commands to generate.