]> git.pld-linux.org Git - packages/perl-ldap.git/blob - perl-ldap.spec
- BR: perl-IO-Socket-SSL
[packages/perl-ldap.git] / perl-ldap.spec
1 #
2 # Conditional build:
3 %bcond_with     tests # perform "make test" (requires working ldap server and gnupg configured with key retrieval with hkp)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        perl-ldap module - a client interface to LDAP servers
7 Summary(pl.UTF-8):      Moduł perl-ldap - kliencki interfejs do serwerów LDAP
8 Name:           perl-ldap
9 Version:        0.34
10 Release:        1
11 Epoch:          3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{name}-%{version}.tar.gz
16 # Source0-md5:  398689b0a7b1615075a6b5035f6e3e91
17 URL:            http://ldap.perl.org/
18 %if %{with tests}
19 BuildRequires:  perl-IO-Socket-SSL
20 BuildRequires:  perl-MIME-Base64
21 BuildRequires:  perl-Module-Signature
22 BuildRequires:  perl-URI >= 1.08
23 BuildRequires:  perl-XML-SAX
24 BuildRequires:  perl-libwww
25 %endif
26 BuildRequires:  perl-Authen-SASL >= 2.00
27 BuildRequires:  perl-Convert-ASN1 >= 0.07
28 BuildRequires:  perl-Digest-MD5
29 BuildRequires:  perl-ExtUtils-AutoInstall
30 BuildRequires:  perl-IO-Socket-SSL
31 BuildRequires:  perl-devel >= 1:5.8.0
32 BuildRequires:  rpm-perlprov >= 4.1-13
33 Obsoletes:      perl-LDAP
34 BuildArch:      noarch
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _noautoreq 'perl(Convert::ASN1::Debug)'
38
39 %description
40 perl-ldap is a collection of modules that implements a LDAP services
41 API for Perl programs.
42
43 %description -l pl.UTF-8
44 perl-ldap to zestaw modułów umożliwiających dostęp do usług LDAP z
45 poziomu programów w Perlu.
46
47 %prep
48 %setup -q
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 # this must be done after tests because of signature checking
58 find blib -type f | xargs -r perl -pi -e 's|/local/bin/perl\d*|/bin/perl|g'
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63
64 %{__make} pure_install \
65         DESTDIR=$RPM_BUILD_ROOT
66 cp -r {contrib,bin} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
67
68 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Net/LDAP/.packlist
69 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/Bundle::Net::LDAP.3pm
70 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/{Bundle/Net/LDAP.pm,Net/{,LDAP/}*.pod}
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc CREDITS Changes README TODO
78 %{perl_vendorlib}/LWP/Protocol/ldap.pm
79 %{perl_vendorlib}/Net/LDAP*.pm
80 %dir %{perl_vendorlib}/Net/LDAP
81 %{perl_vendorlib}/Net/LDAP/*.pm
82 %{perl_vendorlib}/Net/LDAP/Control
83 %{perl_vendorlib}/Net/LDAP/Extension
84 %{_mandir}/man3/N*
85 %{_examplesdir}/%{name}-%{version}
This page took 0.030903 seconds and 4 git commands to generate.