]> git.pld-linux.org Git - packages/perl-ldap.git/blob - perl-ldap.spec
- up to 0.56
[packages/perl-ldap.git] / perl-ldap.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (requires working ldap server and gnupg configured with key retrieval with hkp)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        perl-ldap module - a client interface to LDAP servers
7 Summary(pl.UTF-8):      Moduł perl-ldap - kliencki interfejs do serwerów LDAP
8 Name:           perl-ldap
9 Version:        0.56
10 Release:        1
11 Epoch:          3
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Net/%{name}-%{version}.tar.gz
16 # Source0-md5:  4ea517a844bad34b79f05afcfd24cc05
17 URL:            http://ldap.perl.org/
18 BuildRequires:  perl-Authen-SASL >= 2.00
19 BuildRequires:  perl-Convert-ASN1 >= 0.07
20 BuildRequires:  perl-Digest-MD5
21 BuildRequires:  perl-IO-Socket-SSL >= 0.81
22 BuildRequires:  perl-JSON
23 BuildRequires:  perl-URI >= 1.1
24 BuildRequires:  perl-XML-SAX-Writer
25 BuildRequires:  perl-devel >= 1:5.18.0
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 %if %{with tests}
28 BuildRequires:  perl-Module-Signature
29 BuildRequires:  perl-libwww
30 %endif
31 Obsoletes:      perl-LDAP
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 perl-ldap is a collection of modules that implements a LDAP services
37 API for Perl programs.
38
39 %description -l pl.UTF-8
40 perl-ldap to zestaw modułów umożliwiających dostęp do usług LDAP z
41 poziomu programów w Perlu.
42
43 %prep
44 %setup -q
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 # this must be done after tests because of signature checking
54 find blib -type f | xargs -r perl -pi -e 's|/local/bin/perl\d*|/bin/perl|g'
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
59
60 %{__make} pure_install \
61         DESTDIR=$RPM_BUILD_ROOT
62 cp -r {contrib,bin} $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63
64 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Net/LDAP/.packlist
65 rm -f $RPM_BUILD_ROOT%{_mandir}/man3/Bundle::Net::LDAP.3pm
66 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/{Bundle/Net/LDAP.pm,Net/{,LDAP/}*.pod}
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc CREDITS Changes README TODO
74 %{perl_vendorlib}/LWP/Protocol/ldap.pm
75 %{perl_vendorlib}/LWP/Protocol/ldapi.pm
76 %{perl_vendorlib}/LWP/Protocol/ldaps.pm
77 %{perl_vendorlib}/Net/LDAP*.pm
78 %dir %{perl_vendorlib}/Net/LDAP
79 %{perl_vendorlib}/Net/LDAP/*.pm
80 %{perl_vendorlib}/Net/LDAP/Control
81 %{perl_vendorlib}/Net/LDAP/Extension
82 %{perl_vendorlib}/Net/LDAP/Extra
83 %{perl_vendorlib}/Net/LDAP/Intermediate
84 %{_mandir}/man3/LWP::Protocol::ldap*
85 %{_mandir}/man3/N*
86 %{_examplesdir}/%{name}-%{version}
This page took 0.041057 seconds and 4 git commands to generate.