]> git.pld-linux.org Git - packages/perl-inc-latest.git/blob - perl-inc-latest.spec
- new
[packages/perl-inc-latest.git] / perl-inc-latest.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    inc
6 %define         pnam    latest
7 Summary:        inc::latest - use modules bundled in inc/ if they are newer than installed ones
8 Summary(pl.UTF-8):      inc-latest - użycie modułów dołączonych w inc/ jeśli są nowsze od zainstalowanych
9 Name:           perl-inc-latest
10 Version:        0.500
11 Release:        1
12 License:        Apache v2.0
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-authors/id/D/DA/DAGOLDEN/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  d1e0deb52bcc9f9b0f990ceb077a8ffd
16 URL:            https://metacpan.org/release/inc-latest
17 BuildRequires:  perl-ExtUtils-MakeMaker >= 6.17
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRequires:  rpmbuild(macros) >= 1.745
21 %if %{with tests}
22 BuildRequires:  perl-Test-Simple
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 WARNING -- THIS IS AN EXPERIMENTAL MODULE. It was originally bundled
29 (as an experiment) with Module::Build and has been split out for more
30 general use.
31
32 The inc::latest module helps bootstrap configure-time dependencies for
33 CPAN distributions. These dependencies get bundled into the inc
34 directory within a distribution and are used by Makefile.PL or
35 Build.PL.
36
37 %description -l pl.UTF-8
38 UWAGA: TEN MODUŁ JEST EKSPERYMENTALNY. Oryginalnie był dołączany (jako
39 eksperyment) do Module::Build, następnie został wydzielony do bardziej
40 ogólnego użytku.
41
42 Moduł inc::latest pomaga przy bootstrapowaniu zależności czasu
43 konfiguracji dla pakietów CPAN. Zależności te są dołączane do katalogu
44 inc wewnątrz pakieut, a następnie używane przez Makefile.PL lub
45 Build.PL.
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49
50 %build
51 %{__perl} Makefile.PL \
52         INSTALLDIRS=vendor
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} pure_install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes
69 %{perl_vendorlib}/inc/latest.pm
70 %{perl_vendorlib}/inc/latest
71 %{_mandir}/man3/inc::latest*.3pm*
This page took 0.096493 seconds and 3 git commands to generate.