]> git.pld-linux.org Git - packages/perl-enum.git/blob - perl-enum.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-enum.git] / perl-enum.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pnam    enum
6 Summary:        enum - C style enumerated types and bitmask flags in Perl
7 Summary(pl.UTF-8):      enum - typy wyliczeniowe w stylu C i znaczniki bitowe dla Perla
8 Name:           perl-enum
9 Version:        1.016
10 Release:        5
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pnam}/%{pnam}-%{version}.tar.gz
15 # Source0-md5:  aace7ee8648e5d20c0e81f5a51cb6604
16 URL:            http://search.cpan.org/dist/enum/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 enum defines a set of symbolic constants with ordered numeric values
24 ala C enum types.
25
26 %description -l pl.UTF-8
27 enum definiuje zestaw stałych symbolicznych o uporządkowanych
28 wartościach numerycznych, podobnie do typów enum w C.
29
30 %prep
31 %setup -q -n %{pnam}-%{version}
32
33 %build
34 %{__perl} Makefile.PL \
35         INSTALLDIRS=vendor
36 %{__make}
37
38 %{?with_tests:%{__make} test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 %{__make} install \
44         DESTDIR=$RPM_BUILD_ROOT
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc Changes README
52 %{perl_vendorlib}/enum.pm
53 %{_mandir}/man3/*
This page took 0.11642 seconds and 3 git commands to generate.